summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-03-11 10:46:08 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-03-11 10:46:08 +0000
commit4a93f7c5f154e8af46b653e8a6fb1c8540b140a9 (patch)
tree18d50959d81140d6b895a78ccab545fd85c09410 /net-analyzer/p0f/p0f-2.0.5.ebuild
parentRevision bump; added postgres support via USE=postgres for bug 84797. Thanks ... (diff)
downloadgentoo-2-4a93f7c5f154e8af46b653e8a6fb1c8540b140a9.tar.gz
gentoo-2-4a93f7c5f154e8af46b653e8a6fb1c8540b140a9.tar.bz2
gentoo-2-4a93f7c5f154e8af46b653e8a6fb1c8540b140a9.zip
Version bump for bug 56640; cleaned up ebuilds, respect CFLAGS, respect FEATURES=nostrip. Also added static support via USE=static for 2.0.5.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer/p0f/p0f-2.0.5.ebuild')
-rw-r--r--net-analyzer/p0f/p0f-2.0.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/p0f/p0f-2.0.5.ebuild b/net-analyzer/p0f/p0f-2.0.5.ebuild
new file mode 100644
index 000000000000..e74db3285f0b
--- /dev/null
+++ b/net-analyzer/p0f/p0f-2.0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.5.ebuild,v 1.1 2005/03/11 10:46:08 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="p0f performs passive OS detection based on SYN packets."
+HOMEPAGE="http://lcamtuf.coredump.cx/p0f.shtml"
+SRC_URI="http://lcamtuf.coredump.cx/p0f/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc-macos"
+IUSE="static"
+
+DEPEND="virtual/libpcap"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ sed -i 's;#include <net/bpf.h>;;' p0f.c || die "sed p0f.c failed"
+ sed -i -e 's|^\(all: $(FILE)\).*$|\1|' \
+ -e "s|^\(CFLAGS.*=\).*$|\1${CFLAGS}|" mk/* || die "sed makefiles failed"
+}
+
+src_compile() {
+ local static
+ use static && static="static"
+ emake ${static} || die "emake ${static} failed"
+}
+
+src_install () {
+ use static && mv p0f-static p0f
+ dosbin p0f p0frep || die
+
+ insinto /etc/p0f
+ doins p0f.fp p0fa.fp p0fr.fp
+
+ doman p0f.1 || die
+ cd doc
+ dodoc ChangeLog CREDITS KNOWN_BUGS README TODO
+
+ newinitd ${FILESDIR}/${PN}.initd ${PN} || die "newinitd failed"
+}