summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-17 01:44:56 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-17 01:44:56 +0000
commitbd10212524d23c3c2bd3828fcf666c712a516568 (patch)
treed8465b359079141d465152e7730086eb69b50374 /net-analyzer/slurm/files
parentEAPI bump. Fix compiler warning. Convert sed scripts to patches. Remove short... (diff)
downloadgentoo-2-bd10212524d23c3c2bd3828fcf666c712a516568.tar.gz
gentoo-2-bd10212524d23c3c2bd3828fcf666c712a516568.tar.bz2
gentoo-2-bd10212524d23c3c2bd3828fcf666c712a516568.zip
EAPI bump. Fix building against sys-libs/ncurses[tinfo]. Fix theme support. Remove short <longdescription>. Reinstate joke.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/slurm/files')
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-gentoo.patch (renamed from net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch)13
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-theme.patch16
2 files changed, 24 insertions, 5 deletions
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch b/net-analyzer/slurm/files/slurm-0.3.3-gentoo.patch
index e61687b37fe8..bd97a10c1e81 100644
--- a/net-analyzer/slurm/files/slurm-0.3.3-asneeded.patch
+++ b/net-analyzer/slurm/files/slurm-0.3.3-gentoo.patch
@@ -1,6 +1,6 @@
--- a/configure.in
+++ b/configure.in
-@@ -40,41 +40,15 @@
+@@ -40,31 +40,6 @@
fi
AC_DEFINE(OSTYPE, ["${OSTYPE}"], [The operating system to build for])
@@ -32,14 +32,17 @@
# add Slowlaris -R and libraries to LDFLAGS
if test ${OSTYPE} = "solaris" ; then
LDFLAGS="${LDFLAGS} ${SOLLDFLAGS} -lnsl -lsocket -lkstat"
- fi
-
--AC_CHECK_LIB(fridge, vanilla_coke, echo "WTF?!", echo "Warning: No vanilla coke found in fridge.";echo "We highly suggest that you rectify this situation immediatly.")
+@@ -74,7 +49,12 @@
ncurses_support="no"
curses_support="no"
color_support="no"
-AC_CHECK_LIB(ncurses, use_default_colors, LDFLAGS="$LDFLAGS -lncurses"; CFLAGS="$CFLAGS -D_HAVE_NCURSES -D_HAVE_NCURSES_COLOR"; color_support="yes"; ncurses_support="yes", AC_CHECK_LIB(ncurses, use_default_colors, LDFLAGS="$LDFLAGS -lncurses"; CFLAGS="$CFLAGS -D_HAVE_NCURSES"; ncurses_support="yes"; echo "NO TRANSPARENCY SUPPORT in this ncurses lib", AC_CHECK_LIB(curses, initscr, LDFLAGS="$LDFLAGS -lcurses"; CFLAGS="$CFLAGS -D_HAVE_CURSES"; curses_support="yes"; echo "NO TRANSPARENCY SUPPORT in curses lib")))
-+AC_CHECK_LIB(ncurses, use_default_colors, LIBS="-lncurses $LIBS"; CFLAGS="$CFLAGS -D_HAVE_NCURSES -D_HAVE_NCURSES_COLOR"; color_support="yes"; ncurses_support="yes")
++PKG_CHECK_MODULES(ncurses,ncurses,
++ LIBS="$LIBS $ncurses_LIBS"
++ AC_DEFINE(HAVE_NCURSES, 1, [Define if we have ncurses])
++ AC_DEFINE(HAVE_NCURSES_COLOR, 1, [We want color])
++ color_support="yes"; ncurses_support="yes"
++ ,AC_MSG_ERROR([ncurses not found]))
# disable color support on Solaris for now
if test ${OSTYPE} = "solaris" ; then
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-theme.patch b/net-analyzer/slurm/files/slurm-0.3.3-theme.patch
new file mode 100644
index 000000000000..131554ee57f7
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.3.3-theme.patch
@@ -0,0 +1,16 @@
+--- a/theme.c
++++ b/theme.c
+@@ -70,13 +70,7 @@
+ if ((f = fopen(filename, "r")) == NULL)
+ {
+ bzero(&filename, BUFSIZ);
+-#ifdef __NetBSD__
+- snprintf(filename, BUFSIZ, "/usr/pkg/share/slurm/%s.theme", name);
+-#elif __Debian__
+ snprintf(filename, BUFSIZ, "/usr/share/slurm/%s.theme", name);
+-#else
+- snprintf(filename, BUFSIZ, "/usr/local/share/slurm/%s.theme", name);
+-#endif
+ if ((f = fopen(filename, "r")) == NULL)
+ error(ERR_FATAL, "cannot find theme '%s'", name);
+ }