summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-16 23:13:07 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-16 23:13:07 +0000
commit456fb7f2466caae4f40abd81590c49216eabe4ec (patch)
tree4c690d763a2b6bf6acca0fdfd4368ab1c8e285ab /net-analyzer/sniffit/sniffit-0.3.7-r3.ebuild
parentVersion bump. Respect LDFLAGS (bug #335621), CC, CFLAGS. (diff)
downloadgentoo-2-456fb7f2466caae4f40abd81590c49216eabe4ec.tar.gz
gentoo-2-456fb7f2466caae4f40abd81590c49216eabe4ec.tar.bz2
gentoo-2-456fb7f2466caae4f40abd81590c49216eabe4ec.zip
Remove Debian patching as it is mostly replicated and the epatch call was not working anyway.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/sniffit/sniffit-0.3.7-r3.ebuild')
-rw-r--r--net-analyzer/sniffit/sniffit-0.3.7-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/sniffit/sniffit-0.3.7-r3.ebuild b/net-analyzer/sniffit/sniffit-0.3.7-r3.ebuild
new file mode 100644
index 000000000000..6a185718509b
--- /dev/null
+++ b/net-analyzer/sniffit/sniffit-0.3.7-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sniffit/sniffit-0.3.7-r3.ebuild,v 1.1 2010/09/16 23:13:07 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/-/.}.beta"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Interactive Packet Sniffer"
+SRC_URI="http://reptile.rug.ac.be/~coder/${PN}/files/${MY_P}.tar.gz
+ mirror://debian/pool/main/s/${PN}/${PN}_0.3.7.beta-15.diff.gz"
+HOMEPAGE="http://reptile.rug.ac.be/~coder/sniffit/sniffit.html"
+
+DEPEND="net-libs/libpcap
+ >=sys-libs/ncurses-5.2"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+#S="${WORKDIR}"/${P/-/.}.beta
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-misc.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf || die
+}
+
+src_install () {
+ dobin sniffit
+
+ doman sniffit.5 sniffit.8
+ dodoc README* PLUGIN-HOWTO BETA* HISTORY
+}