summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-16 16:53:07 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-16 16:53:07 +0000
commit28b9125b32444ba1cdb3f2fb946d4e605eccd1bd (patch)
treee7b287e17742d6656d56148f6cb4aa30a16889e3 /net-analyzer/squidsites
parentvirtual/glut -> media-libs/glut (diff)
downloadgentoo-2-28b9125b32444ba1cdb3f2fb946d4e605eccd1bd.tar.gz
gentoo-2-28b9125b32444ba1cdb3f2fb946d4e605eccd1bd.tar.bz2
gentoo-2-28b9125b32444ba1cdb3f2fb946d4e605eccd1bd.zip
Respect LDFLAGS (bug #337399). Respect CFLAGS (including upstream -Wall) and do not inject them into the Makefile. Remove package name from DESCRIPTION.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/squidsites')
-rw-r--r--net-analyzer/squidsites/ChangeLog11
-rw-r--r--net-analyzer/squidsites/squidsites-1.01-r1.ebuild36
2 files changed, 45 insertions, 2 deletions
diff --git a/net-analyzer/squidsites/ChangeLog b/net-analyzer/squidsites/ChangeLog
index a7260464b60c..d5678b8280ed 100644
--- a/net-analyzer/squidsites/ChangeLog
+++ b/net-analyzer/squidsites/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/squidsites
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/squidsites/ChangeLog,v 1.11 2008/01/21 14:56:11 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/squidsites/ChangeLog,v 1.12 2010/09/16 16:53:07 jer Exp $
+
+*squidsites-1.01-r1 (16 Sep 2010)
+
+ 16 Sep 2010; Jeroen Roovers <jer@gentoo.org> +squidsites-1.01-r1.ebuild:
+ Respect LDFLAGS (bug #337399). Respect CFLAGS (including upstream -Wall)
+ and do not inject them into the Makefile. Remove package name from
+ DESCRIPTION.
21 Jan 2008; Raúl Porcel <armin76@gentoo.org> squidsites-1.01.ebuild:
Fix ebuild, fix HOMEPAGE
diff --git a/net-analyzer/squidsites/squidsites-1.01-r1.ebuild b/net-analyzer/squidsites/squidsites-1.01-r1.ebuild
new file mode 100644
index 000000000000..3a0ee015a4da
--- /dev/null
+++ b/net-analyzer/squidsites/squidsites-1.01-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/squidsites/squidsites-1.01-r1.ebuild,v 1.1 2010/09/16 16:53:07 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+IUSE=""
+DESCRIPTION="a tool that parses Squid access log file and generates a report of the most visited sites."
+HOMEPAGE="http://www.stefanopassiglia.com/misc.htm"
+SRC_URI="http://www.stefanopassiglia.com/downloads/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=""
+RDEPEND=""
+S="${WORKDIR}/src"
+
+src_prepare() {
+ # Respect CFLAGS
+ sed -i Makefile \
+ -e '/^CCFLAGS=/s|-g|$(CFLAGS) $(LDFLAGS)|' \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ cd "${WORKDIR}"
+ dobin src/squidsites
+ dodoc Authors Bugs ChangeLog GNU-Manifesto.html README
+}