summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-09 14:40:14 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-09 14:40:14 +0000
commit029ac35b29c95111baa8888746bd870c266d6249 (patch)
tree701257713944c8cbf2f5a4fac44002a15f24cf8c /net-analyzer/tcptrace
parentOld. (diff)
downloadgentoo-2-029ac35b29c95111baa8888746bd870c266d6249.tar.gz
gentoo-2-029ac35b29c95111baa8888746bd870c266d6249.tar.bz2
gentoo-2-029ac35b29c95111baa8888746bd870c266d6249.zip
Fix cross-compiling by Bertrand Jacquin (bug #374085). Set RDEPEND. Show notes only on first install.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/tcptrace')
-rw-r--r--net-analyzer/tcptrace/ChangeLog11
-rw-r--r--net-analyzer/tcptrace/files/tcptrace-6.6.7-cross-compile.patch50
-rw-r--r--net-analyzer/tcptrace/tcptrace-6.6.7-r1.ebuild44
3 files changed, 103 insertions, 2 deletions
diff --git a/net-analyzer/tcptrace/ChangeLog b/net-analyzer/tcptrace/ChangeLog
index 8765b0930bb1..382f87e066f8 100644
--- a/net-analyzer/tcptrace/ChangeLog
+++ b/net-analyzer/tcptrace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/tcptrace
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcptrace/ChangeLog,v 1.23 2010/07/26 22:56:17 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcptrace/ChangeLog,v 1.24 2013/06/09 14:40:14 jer Exp $
+
+*tcptrace-6.6.7-r1 (09 Jun 2013)
+
+ 09 Jun 2013; Jeroen Roovers <jer@gentoo.org> +tcptrace-6.6.7-r1.ebuild,
+ +files/tcptrace-6.6.7-cross-compile.patch:
+ Fix cross-compiling by Bertrand Jacquin (bug #374085). Set RDEPEND. Show
+ notes only on first install.
26 Jul 2010; Jeroen Roovers <jer@gentoo.org> tcptrace-6.6.7.ebuild:
Set -DBSD_SOURCE by Nico Baggus (bug #325277).
diff --git a/net-analyzer/tcptrace/files/tcptrace-6.6.7-cross-compile.patch b/net-analyzer/tcptrace/files/tcptrace-6.6.7-cross-compile.patch
new file mode 100644
index 000000000000..a5b9ba0c009b
--- /dev/null
+++ b/net-analyzer/tcptrace/files/tcptrace-6.6.7-cross-compile.patch
@@ -0,0 +1,50 @@
+--- a/configure.in
++++ b/configure.in
+@@ -3,8 +3,6 @@
+
+ AC_CANONICAL_SYSTEM
+
+-AC_LBL_C_INIT(V_CCOPT, V_INCLS)
+-
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_MAKE_SET
+@@ -43,13 +41,12 @@
+ dnl check for the IPv6 routines inet_pton
+ AC_CHECK_FUNCS(inet_pton)
+
+-AC_MSG_CHECKING(how to print unsigned long long)
+-AC_SUBST(FS_ULL)
+ dnl AC_TRY_RUN is a test program that performs a run-time test to find out
+ dnl the correct syntax to print unsigned long long ints in printf stmts.
+ dnl If strcmp returns 0, we are on an enironment that uses %llu, otherwise
+ dnl we are on a MacOSX environment that uses %qu
+-AC_TRY_RUN([
++AC_CACHE_CHECK([how to print unsigned long long], ac_cv_unsigned_long_long_printf_format,
++ [AC_TRY_RUN([
+ #include <stdio.h>
+
+ #define NIX "%llu"
+@@ -63,11 +60,17 @@
+ exit (0);
+ else
+ exit (1);
+-}],
+-AC_DEFINE(USE_LLU)
+-AC_MSG_RESULT(%llu),
+-AC_MSG_RESULT(%qu),
+-AC_MSG_ERROR(can not run test program while cross compiling))
++}
++ ],
++ ac_cv_unsigned_long_long_printf_format=%llu,
++ ac_cv_unsigned_long_long_printf_format=%qu,
++ [AS_ECHO_N(["cross-comiling, assuming "])]
++ ac_cv_unsigned_long_long_printf_format=%llu
++ )]
++)
++AS_IF([test $ac_cv_unsigned_long_long_printf_format = %llu],
++ AC_DEFINE(USE_LLU)
++)
+
+ dnl Grab standard includes under weird Linux versions
+ dnl case "$target_os" in
diff --git a/net-analyzer/tcptrace/tcptrace-6.6.7-r1.ebuild b/net-analyzer/tcptrace/tcptrace-6.6.7-r1.ebuild
new file mode 100644
index 000000000000..0db6c42977b4
--- /dev/null
+++ b/net-analyzer/tcptrace/tcptrace-6.6.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcptrace/tcptrace-6.6.7-r1.ebuild,v 1.1 2013/06/09 14:40:14 jer Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A Tool for analyzing network packet dumps"
+HOMEPAGE="http://www.tcptrace.org/"
+SRC_URI="
+ http://www.tcptrace.org/download/${P}.tar.gz
+ http://www.tcptrace.org/download/old/6.6/${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cross-compile.patch
+ eautoreconf
+ append-flags -D_BSD_SOURCE
+}
+
+src_install() {
+ dobin tcptrace xpl2gpl
+
+ newman tcptrace.man tcptrace.1
+ dodoc CHANGES COPYRIGHT FAQ README* THANKS WWW
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Note: tcptrace outputs its graphs in the xpl (xplot)"
+ elog "format. Since xplot is unavailable, you will have to"
+ elog "use the included xpl2gpl utility to convert it to"
+ elog "the gnuplot format."
+ fi
+}