summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-10-12 06:13:02 +0000
committerMichael Weber <xmw@gentoo.org>2012-10-12 06:13:02 +0000
commit25e216d6a2ce7693e33507a68177fea806ea7db3 (patch)
tree6aca767d32c74dd91114ca70a7bdce48634222f9 /net-analyzer/thc-ipv6
parentRemove apache 2.4 mask (diff)
downloadgentoo-2-25e216d6a2ce7693e33507a68177fea806ea7db3.tar.gz
gentoo-2-25e216d6a2ce7693e33507a68177fea806ea7db3.tar.bz2
gentoo-2-25e216d6a2ce7693e33507a68177fea806ea7db3.zip
Version bump (thanks Anton Bolshakov, bug 437866)
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/thc-ipv6')
-rw-r--r--net-analyzer/thc-ipv6/ChangeLog8
-rw-r--r--net-analyzer/thc-ipv6/files/thc-ipv6-2.0-Makefile.patch22
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-2.0.ebuild33
3 files changed, 62 insertions, 1 deletions
diff --git a/net-analyzer/thc-ipv6/ChangeLog b/net-analyzer/thc-ipv6/ChangeLog
index 80576f58081d..16a04e915544 100644
--- a/net-analyzer/thc-ipv6/ChangeLog
+++ b/net-analyzer/thc-ipv6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/thc-ipv6
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thc-ipv6/ChangeLog,v 1.6 2012/07/09 12:17:14 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thc-ipv6/ChangeLog,v 1.7 2012/10/12 06:13:02 xmw Exp $
+
+*thc-ipv6-2.0 (12 Oct 2012)
+
+ 12 Oct 2012; Michael Weber <xmw@gentoo.org> +thc-ipv6-2.0.ebuild,
+ +files/thc-ipv6-2.0-Makefile.patch:
+ Version bump (thanks Anton Bolshakov, bug 437866)
*thc-ipv6-1.9 (09 Jul 2012)
diff --git a/net-analyzer/thc-ipv6/files/thc-ipv6-2.0-Makefile.patch b/net-analyzer/thc-ipv6/files/thc-ipv6-2.0-Makefile.patch
new file mode 100644
index 000000000000..0d46c2773b88
--- /dev/null
+++ b/net-analyzer/thc-ipv6/files/thc-ipv6-2.0-Makefile.patch
@@ -0,0 +1,22 @@
+--- thc-ipv6-2.0/Makefile
++++ thc-ipv6-2.0/Makefile
+@@ -2,8 +2,9 @@
+ #CFLAGS?=-Wall -ggdb
+ CFLAGS?=-O2
+ LDFLAGS+=-lpcap -lssl -lcrypto
+-PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_router26 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 thcping6 covert_send6 covert_send6d
++PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_router26 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d
+ LIBS=thc-ipv6-lib.o
++STRIP=strip
+
+ PREFIX=/usr/local
+ MANPREFIX=${PREFIX}/share/man
+@@ -20,7 +21,7 @@
+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ strip: all
+- strip $(PROGRAMS) dnsdict6 thcping6
++ $(STRIP) $(PROGRAMS) dnsdict6 thcping6
+
+ install: all strip
+ install -m0755 -d ${DESTDIR}${PREFIX}/bin
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-2.0.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-2.0.ebuild
new file mode 100644
index 000000000000..1b197e02d376
--- /dev/null
+++ b/net-analyzer/thc-ipv6/thc-ipv6-2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/thc-ipv6/thc-ipv6-2.0.ebuild,v 1.1 2012/10/12 06:13:02 xmw Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+HOMEPAGE="http://freeworld.thc.org/thc-ipv6/"
+SRC_URI="http://freeworld.thc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" STRIP="true" install
+ dodoc CHANGES HOWTO-INJECT README
+}