summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-12 10:14:02 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-12 10:14:02 +0000
commit12b420f147c079911e21ce0cc90ab2b67136e841 (patch)
tree63c4305073639e0a616cf370da0fd08b411854ea /net-analyzer/ttcp
parentDrop Andrew John Hughes as maintainer as discussed with him in #gentoo-java (diff)
downloadgentoo-2-12b420f147c079911e21ce0cc90ab2b67136e841.tar.gz
gentoo-2-12b420f147c079911e21ce0cc90ab2b67136e841.tar.bz2
gentoo-2-12b420f147c079911e21ce0cc90ab2b67136e841.zip
Revision bump: bump EAPI to 4, add fix for bug #336145, thanks to Seth Robertson and Jeroen Roovers
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/ttcp')
-rw-r--r--net-analyzer/ttcp/ChangeLog10
-rw-r--r--net-analyzer/ttcp/ttcp-1.12-r2.ebuild38
2 files changed, 46 insertions, 2 deletions
diff --git a/net-analyzer/ttcp/ChangeLog b/net-analyzer/ttcp/ChangeLog
index 1dd6ac03accc..20c7522f7ba4 100644
--- a/net-analyzer/ttcp/ChangeLog
+++ b/net-analyzer/ttcp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ttcp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttcp/ChangeLog,v 1.21 2011/02/06 07:51:32 leio Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttcp/ChangeLog,v 1.22 2012/10/12 10:14:02 pinkbyte Exp $
+
+*ttcp-1.12-r2 (12 Oct 2012)
+
+ 12 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +ttcp-1.12-r2.ebuild:
+ Revision bump: bump EAPI to 4, add fix for bug #336145, thanks to Seth
+ Robertson and Jeroen Roovers
06 Feb 2011; Mart Raudsepp <leio@gentoo.org> ttcp-1.12.ebuild:
Drop to ~mips
diff --git a/net-analyzer/ttcp/ttcp-1.12-r2.ebuild b/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
new file mode 100644
index 000000000000..d7779f517ef5
--- /dev/null
+++ b/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttcp/ttcp-1.12-r2.ebuild,v 1.1 2012/10/12 10:14:02 pinkbyte Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to test TCP and UDP throughput"
+HOMEPAGE="
+ http://ftp.arl.mil/~mike/ttcp.html
+ http://www.netcore.fi/pekkas/linux/ipv6/
+"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ http://www.netcore.fi/pekkas/linux/ipv6/${PN}.c
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ default
+ cp "${DISTDIR}/${PN}.c" "${S}/${PN}.c" || die "mv failed"
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o "${PN}" "${PN}".c || die "compile failed"
+}
+
+src_install() {
+ dobin "${PN}"
+ newman sgi-"${PN}".1 "${PN}".1
+}