summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-03-01 12:52:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-03-01 12:52:52 +0000
commit33f197b974e471d88b9aad4c1e8661966848a168 (patch)
tree0db110cdb658ff8c452b355633b816d22a774abe /net-analyzer
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-33f197b974e471d88b9aad4c1e8661966848a168.tar.gz
gentoo-2-33f197b974e471d88b9aad4c1e8661966848a168.tar.bz2
gentoo-2-33f197b974e471d88b9aad4c1e8661966848a168.zip
Bump to 3.3.3, fixes #277405 #282501 #296157
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/metasploit/ChangeLog11
-rw-r--r--net-analyzer/metasploit/files/msfweb3.3.confd10
-rw-r--r--net-analyzer/metasploit/files/msfweb3.3.initd20
-rw-r--r--net-analyzer/metasploit/metasploit-3.3.3.ebuild (renamed from net-analyzer/metasploit/metasploit-3.2_p6750.ebuild)31
4 files changed, 46 insertions, 26 deletions
diff --git a/net-analyzer/metasploit/ChangeLog b/net-analyzer/metasploit/ChangeLog
index cef98e32a40e..44a1c9f352b9 100644
--- a/net-analyzer/metasploit/ChangeLog
+++ b/net-analyzer/metasploit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/metasploit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.48 2009/09/26 23:05:40 a3li Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.49 2010/03/01 12:52:52 patrick Exp $
+
+*metasploit-3.3.3 (01 Mar 2010)
+
+ 01 Mar 2010; Patrick Lauer <patrick@gentoo.org> +files/msfweb3.3.confd,
+ -metasploit-3.2_p6750.ebuild, +files/msfweb3.3.initd,
+ +metasploit-3.3.3.ebuild:
+ Bump to 3.3.3, fixes #277405 #282501 #296157
26 Sep 2009; Alex Legler <a3li@gentoo.org>
-metasploit-3.1_p5699-r1.ebuild:
diff --git a/net-analyzer/metasploit/files/msfweb3.3.confd b/net-analyzer/metasploit/files/msfweb3.3.confd
new file mode 100644
index 000000000000..b0cf87e6dfaf
--- /dev/null
+++ b/net-analyzer/metasploit/files/msfweb3.3.confd
@@ -0,0 +1,10 @@
+# Config file for /etc/init.d/metasploit
+
+# Bind to the following IP instead of the loopback address
+IPADDR=127.0.0.1
+
+# Bind to the following TCP port instead of default 55555
+PORT=55555
+
+# All options
+MSF_OPTS="-a $IPADDR -p $PORT"
diff --git a/net-analyzer/metasploit/files/msfweb3.3.initd b/net-analyzer/metasploit/files/msfweb3.3.initd
new file mode 100644
index 000000000000..430fc65ba7c1
--- /dev/null
+++ b/net-analyzer/metasploit/files/msfweb3.3.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/files/msfweb3.3.initd,v 1.1 2010/03/01 12:52:51 patrick Exp $
+
+PIDFILE=/var/run/msfweb3.3.pid
+
+start() {
+ ebegin "Starting msfweb3.3"
+ start-stop-daemon --start --quiet --background --startas msfweb3.3 --exec /usr/lib/metasploit3.3/msfweb \
+ --pidfile ${PIDFILE} --make-pidfile -- ${MSF_OPTS}
+ eend $?
+ einfo "Note: msfweb3.3 is started but needs some before it serves clients."
+}
+
+stop() {
+ ebegin "Stopping msfweb"
+ start-stop-daemon --stop --quiet -s 9 --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/net-analyzer/metasploit/metasploit-3.2_p6750.ebuild b/net-analyzer/metasploit/metasploit-3.3.3.ebuild
index 0d30625f787e..d3c6c44e79e6 100644
--- a/net-analyzer/metasploit/metasploit-3.2_p6750.ebuild
+++ b/net-analyzer/metasploit/metasploit-3.3.3.ebuild
@@ -1,28 +1,15 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-3.2_p6750.ebuild,v 1.4 2009/09/26 22:56:04 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-3.3.3.ebuild,v 1.1 2010/03/01 12:52:52 patrick Exp $
-MY_P=${PN/metasploit/framework}-${PV}
-
-# Metasploit uses subversion as a *normal* update mechanism for stable branches
-# of the package. This ebuild uses _p<number> inside $PV to install updated up
-# to revision <number> version of framework. For more information, take a look
-# at bug #195924.
-if [[ "${PV}" =~ (_p)([0-9]+) ]] ; then
- inherit subversion
- SRC_URI=""
- MTSLPT_REV=${BASH_REMATCH[2]}
- ESVN_REPO_URI="https://metasploit.com/svn/framework3/branches/framework-${PV%_p*}/@${MTSLPT_REV}"
-else
- SRC_URI="http://sugar.metasploit.com/releases/${MY_P}.tar.gz"
-fi
+SRC_URI="http://www.metasploit.com/releases/framework-${PV}.tar.bz2"
DESCRIPTION="Advanced open-source framework for developing, testing, and using vulnerability exploit code"
HOMEPAGE="http://www.metasploit.org/"
LICENSE="BSD"
-SLOT="3.2"
-KEYWORDS="amd64 ppc ~sparc x86"
+SLOT="3.3"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="gtk sqlite postgres"
# Note we use bundled gems (see data/msfweb/vendor/rails/) as upstream voted for
@@ -36,7 +23,7 @@ RDEPEND="dev-lang/ruby
dev-ruby/activerecord )"
DEPEND=""
-S=${WORKDIR}/${MY_P}
+S=${WORKDIR}/msf3
src_install() {
if [[ "${SRC_URI}" != "" ]] ; then
@@ -55,7 +42,7 @@ src_install() {
dosym /usr/share/doc/${PF}/documentation /usr/lib/${PN}${SLOT}/documentation
dodir /usr/bin/
- use gtk || rm msfgui3.2
+ use gtk || rm msfgui
for file in msf*; do
dosym /usr/lib/${PN}${SLOT}/${file} /usr/bin/${file}${SLOT}
done
@@ -89,9 +76,5 @@ pkg_postinst() {
elog "each time you reemerge ${PN} it'll be updated to get all possible"
elog "updates for framework-${PV%_p*} branch."
elog "You can do similar things in paludis using /etc/paludis/bashrc."
- else
- ewarn "${PN} version you installed is for testing purposes only"
- ewarn "as it's impossible to update it. For day by day work use"
- ewarn "different version."
fi
}