summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2008-05-14 02:41:32 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2008-05-14 02:41:32 +0000
commit39c224c286805d3c191f76288f7cb3130b159a95 (patch)
tree41e7ef3a5373e94f8f9af035b9798eb2cf528898 /net-analyzer
parent1.4.2 version bump for bug 216306. Thanks to Bram Schoenmakers <me at (diff)
downloadgentoo-2-39c224c286805d3c191f76288f7cb3130b159a95.tar.gz
gentoo-2-39c224c286805d3c191f76288f7cb3130b159a95.tar.bz2
gentoo-2-39c224c286805d3c191f76288f7cb3130b159a95.zip
0.2.2 version bump for bug 213857. Thanks to Toei Rei <gbugs at stargazer dot at>.
Added netmon as a herd. (Portage version: 2.1.4.4)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nepenthes/ChangeLog11
-rw-r--r--net-analyzer/nepenthes/metadata.xml5
-rw-r--r--net-analyzer/nepenthes/nepenthes-0.2.2.ebuild68
3 files changed, 78 insertions, 6 deletions
diff --git a/net-analyzer/nepenthes/ChangeLog b/net-analyzer/nepenthes/ChangeLog
index 0ecd8b54f774..62895d125ccd 100644
--- a/net-analyzer/nepenthes/ChangeLog
+++ b/net-analyzer/nepenthes/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nepenthes
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/ChangeLog,v 1.15 2007/08/29 19:05:08 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/ChangeLog,v 1.16 2008/05/14 02:41:32 vanquirius Exp $
+
+*nepenthes-0.2.2 (13 May 2008)
+
+ 13 May 2008; Marcelo Goes <vanquirius@gentoo.org> metadata.xml,
+ +nepenthes-0.2.2.ebuild:
+ 0.2.2 version bump for bug 213857. Thanks to Toei Rei <gbugs at stargazer
+ dot at>. Added netmon as a herd.
29 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing kaiowas from metadata due to his retirement (see #61930 for
diff --git a/net-analyzer/nepenthes/metadata.xml b/net-analyzer/nepenthes/metadata.xml
index 5a627aade080..32b26e94f9ec 100644
--- a/net-analyzer/nepenthes/metadata.xml
+++ b/net-analyzer/nepenthes/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- </maintainer>
+ <herd>netmon</herd>
<longdescription lang="en">
Nepenthes is a low interaction honeypot that captures worms by emulating
known vulnerabilities.
diff --git a/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild b/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
new file mode 100644
index 000000000000..b6202ac8882d
--- /dev/null
+++ b/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild,v 1.1 2008/05/14 02:41:32 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="Nepenthes is a low interaction honeypot that captures worms by emulating known vulnerabilities"
+HOMEPAGE="http://nepenthes.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="selinux"
+
+DEPEND="net-misc/curl
+ sys-apps/file
+ dev-libs/libpcre
+ net-libs/adns"
+
+RDEPEND=""
+#RDEPEND=" selinux? ( sec-policy/selinux-nepenthes )"
+
+pkg_setup() {
+ enewgroup nepenthes
+ enewuser nepenthes -1 -1 /dev/null nepenthes
+}
+
+src_compile() {
+ local myconf="--sysconfdir=/etc --localstatedir=/var/lib/nepenthes --enable-capabilities"
+ econf "${myconf}" || die
+ sed -i 's|var/cache|/var/lib/cache|' "${S}"/modules/shellcode-signatures/shellcode-signatures.cpp
+ emake || die "make failed"
+}
+
+src_install() {
+
+ einstall || die "make install failed"
+
+ for i in "${D}"/etc/nepenthes/*; do
+ sed -i \
+ -e 's|"var/binaries|"/var/lib/nepenthes/binaries|' \
+ -e 's|"var/hexdumps|"/var/lib/nepenthes/hexdumps|' \
+ -e 's|"var/cache/nepenthes|"/var/lib/nepenthes/cache|' \
+ -e 's|"var/log|"/var/log/nepenthes|' \
+ -e 's|"lib/nepenthes|"/usr/lib/nepenthes|' \
+ -e 's|"etc|"/etc|' $i
+ done
+
+ dodoc doc/README doc/README.VFS AUTHORS
+ dosbin nepenthes-core/src/nepenthes || die "dosbin failed"
+ rm "${D}"/usr/bin/nepenthes
+ rm "${D}"/usr/share/doc/README
+ rm "${D}"/usr/share/doc/README.VFS
+ rm "${D}"/usr/share/doc/logo-shaded.svg
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ diropts -m 755 -o nepenthes -g nepenthes
+ keepdir /var/log/nepenthes
+ keepdir /var/lib/nepenthes
+ keepdir /var/lib/nepenthes/binaries
+ keepdir /var/lib/nepenthes/hexdumps
+ keepdir /var/lib/nepenthes/cache
+ keepdir /var/lib/nepenthes/cache/geolocation
+
+}