summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-01-21 12:53:44 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-01-21 12:53:44 +0000
commit3a7a4e7d600c43833b11c45a36fa9264a54703c5 (patch)
treebc0375e2753a6d1162ca10a5d96a1ff45c336d0e /net-analyzer
parentVersion bump. bug #202988. Add local binary USE flag to workaround memory req... (diff)
downloadgentoo-2-3a7a4e7d600c43833b11c45a36fa9264a54703c5.tar.gz
gentoo-2-3a7a4e7d600c43833b11c45a36fa9264a54703c5.tar.bz2
gentoo-2-3a7a4e7d600c43833b11c45a36fa9264a54703c5.zip
Add gtk and nls USE-flags, add patch from upstream, bug #195926
(Portage version: 2.1.4)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pinger/ChangeLog6
-rw-r--r--net-analyzer/pinger/files/disable_gtk.patch19
-rw-r--r--net-analyzer/pinger/pinger-0.32c.ebuild29
3 files changed, 50 insertions, 4 deletions
diff --git a/net-analyzer/pinger/ChangeLog b/net-analyzer/pinger/ChangeLog
index a4bc179b4314..44b6ddc871f7 100644
--- a/net-analyzer/pinger/ChangeLog
+++ b/net-analyzer/pinger/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/pinger
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/ChangeLog,v 1.8 2008/01/20 18:52:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/ChangeLog,v 1.9 2008/01/21 12:53:43 armin76 Exp $
+
+ 21 Jan 2008; Raúl Porcel <armin76@gentoo.org> +files/disable_gtk.patch,
+ pinger-0.32c.ebuild:
+ Add gtk and nls USE-flags, add patch from upstream, bug #195926
*pinger-0.32c (20 Jan 2008)
diff --git a/net-analyzer/pinger/files/disable_gtk.patch b/net-analyzer/pinger/files/disable_gtk.patch
new file mode 100644
index 000000000000..bef664bf5fac
--- /dev/null
+++ b/net-analyzer/pinger/files/disable_gtk.patch
@@ -0,0 +1,19 @@
+--- pinger-0.32c-orig/configure.in 2008-01-21 09:43:32.000000000 +0100
++++ pinger-0.32c/configure.in 2008-01-21 09:43:35.000000000 +0100
+@@ -56,13 +56,15 @@
+
+ AC_ARG_ENABLE(gtk, [ --enable-gtk enable GTK+ support],
+ [if test "$enableval" = no; then no_gtk=yes; fi])
+- AC_MSG_CHECKING([for GTK+ support])
++AC_MSG_CHECKING([for GTK+ support])
+ AC_MSG_RESULT($enableval)
+ dnl Check for additional external libraries etc..
++if test x$no_gtk != xyes; then
+ AM_PATH_GTK_2_0(2.0.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$LIBS $GTK_LIBS"; HAVE_GTK_2=1;
+ AC_DEFINE([HAVE_GTK_2], 1, Found GTK 2),
+ HAVE_GTK_2=0)
++fi
+ AC_CHECK_LIB(ncurses, initscr, HAVE_CURSES=1; LIBS="$LIBS -lncurses";
+ AC_DEFINE([HAVE_LIBNCURSES], [1], found ncurses library))
+ AC_CHECK_LIB(intl, libintl_gettext, LIBS="$LIBS -lintl")
diff --git a/net-analyzer/pinger/pinger-0.32c.ebuild b/net-analyzer/pinger/pinger-0.32c.ebuild
index 9c37b9958742..a02c482e5197 100644
--- a/net-analyzer/pinger/pinger-0.32c.ebuild
+++ b/net-analyzer/pinger/pinger-0.32c.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/pinger-0.32c.ebuild,v 1.1 2008/01/20 18:52:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/pinger-0.32c.ebuild,v 1.2 2008/01/21 12:53:43 armin76 Exp $
+
+inherit eutils autotools
DESCRIPTION="Cyclic multi ping utility for selected adresses using GTK/ncurses."
HOMEPAGE="http://aa.vslib.cz/silk/projekty/pinger/index.php"
@@ -9,13 +11,34 @@ SRC_URI="http://aa.vslib.cz/silk/projekty/pinger/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="gtk nls"
DEPEND=">=dev-util/pkgconfig-0.12
>=x11-libs/gtk+-2.4.0
sys-libs/ncurses"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/disable_gtk.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ ! use nls && myconf="${myconf} --disable-nls"
+
+ econf \
+ $(use_enable gtk) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
src_install() {
- make install DESTDIR="${D}"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS BUGS ChangeLog NEWS README
+
+ ! use gtk && rm "${D}"/usr/bin/gtkpinger
}