summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-22 17:29:06 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-22 17:29:06 +0000
commit3c49f1179b7171c53be371c74b52ac0c3ab63349 (patch)
tree6bcaca883e774a0239173e76055357c50d2624fc /net-analyzer
parentKeyworded on alpha, bug #218437 (diff)
downloadgentoo-2-3c49f1179b7171c53be371c74b52ac0c3ab63349.tar.gz
gentoo-2-3c49f1179b7171c53be371c74b52ac0c3ab63349.tar.bz2
gentoo-2-3c49f1179b7171c53be371c74b52ac0c3ab63349.zip
Version bump. Fixes also building failure with GCC 4.3. Thanks to Peter Alfredsen wrt #218909.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nload/ChangeLog11
-rw-r--r--net-analyzer/nload/files/nload-0.7.1-gcc43.patch31
-rw-r--r--net-analyzer/nload/nload-0.6.0.ebuild20
-rw-r--r--net-analyzer/nload/nload-0.7.1.ebuild29
4 files changed, 69 insertions, 22 deletions
diff --git a/net-analyzer/nload/ChangeLog b/net-analyzer/nload/ChangeLog
index 164afad6d9c3..66b9bb17fcd5 100644
--- a/net-analyzer/nload/ChangeLog
+++ b/net-analyzer/nload/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nload
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/ChangeLog,v 1.24 2007/09/23 18:37:44 philantrop Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/ChangeLog,v 1.25 2008/04/22 17:29:05 drac Exp $
+
+*nload-0.7.1 (22 Apr 2008)
+
+ 22 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ +files/nload-0.7.1-gcc43.patch, -nload-0.6.0.ebuild, +nload-0.7.1.ebuild:
+ Version bump. Fixes also building failure with GCC 4.3. Thanks to Peter
+ Alfredsen wrt #218909.
23 Sep 2007; Wulf C. Krueger <philantrop@gentoo.org>
nload-0.6.0-r2.ebuild:
diff --git a/net-analyzer/nload/files/nload-0.7.1-gcc43.patch b/net-analyzer/nload/files/nload-0.7.1-gcc43.patch
new file mode 100644
index 000000000000..c51e1d934818
--- /dev/null
+++ b/net-analyzer/nload/files/nload-0.7.1-gcc43.patch
@@ -0,0 +1,31 @@
+diff -NrU5 nload-0.7.1.orig/src/device.cpp nload-0.7.1/src/device.cpp
+--- nload-0.7.1.orig/src/device.cpp 2008-02-02 17:14:34.000000000 +0100
++++ nload-0.7.1/src/device.cpp 2008-04-22 08:08:40.000000000 +0200
+@@ -19,10 +19,11 @@
+ #include "devreader.h"
+ #include "graph.h"
+ #include "setting.h"
+ #include "settingstore.h"
+ #include "window.h"
++#include <climits>
+
+ #include <iomanip>
+
+ using namespace std;
+
+diff -NrU5 nload-0.7.1.orig/src/main.cpp nload-0.7.1/src/main.cpp
+--- nload-0.7.1.orig/src/main.cpp 2008-02-27 21:22:35.000000000 +0100
++++ nload-0.7.1/src/main.cpp 2008-04-22 08:11:26.000000000 +0200
+@@ -50,10 +50,12 @@
+
+ #include <ctype.h>
+ #include <time.h>
+ #include <curses.h>
+ #include <signal.h>
++#include <cstring>
++
+ #undef clear
+ #undef erase
+ #undef refresh
+
+ #define STANDARD_AVERAGE_WINDOW 300
diff --git a/net-analyzer/nload/nload-0.6.0.ebuild b/net-analyzer/nload/nload-0.6.0.ebuild
deleted file mode 100644
index 7f7a49a79ddf..000000000000
--- a/net-analyzer/nload/nload-0.6.0.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/nload-0.6.0.ebuild,v 1.11 2007/07/11 23:49:24 mr_bones_ Exp $
-
-DESCRIPTION="console application which monitors network traffic and bandwidth usage in real time"
-SRC_URI="mirror://sourceforge/nload/${P}.tar.gz"
-HOMEPAGE="http://roland-riegel.de/nload/index_en.html"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
-
-DEPEND=">=sys-libs/ncurses-5.2"
-
-src_install () {
- #make DESTDIR=${D} install
- einstall || die
- dodoc README INSTALL ChangeLog AUTHORS
-}
diff --git a/net-analyzer/nload/nload-0.7.1.ebuild b/net-analyzer/nload/nload-0.7.1.ebuild
new file mode 100644
index 000000000000..49891fc4da12
--- /dev/null
+++ b/net-analyzer/nload/nload-0.7.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/nload-0.7.1.ebuild,v 1.1 2008/04/22 17:29:05 drac Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="console application which monitors network traffic and bandwidth usage in real time"
+HOMEPAGE="http://roland-riegel.de/nload/index_en.html"
+SRC_URI="mirror://sourceforge/nload/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.6.0-prevent-stripping.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README
+}