summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-06-29 20:42:47 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-06-29 20:42:47 +0000
commit5f738a3b976c6781a9e70ecd678e5e9a67d600a7 (patch)
treef13522e95e4b2f9cdcbecd628b51f529b1512bf4 /net-analyzer
parentadd kerberos use keyword (diff)
downloadgentoo-2-5f738a3b976c6781a9e70ecd678e5e9a67d600a7.tar.gz
gentoo-2-5f738a3b976c6781a9e70ecd678e5e9a67d600a7.tar.bz2
gentoo-2-5f738a3b976c6781a9e70ecd678e5e9a67d600a7.zip
net-snmp 5.0.1
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/ChangeLog15
-rw-r--r--net-analyzer/net-snmp/files/digest-net-snmp-5.0.11
-rw-r--r--net-analyzer/net-snmp/files/net-snmpd.rc629
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.0.1.ebuild55
4 files changed, 100 insertions, 0 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
new file mode 100644
index 000000000000..516dc8778394
--- /dev/null
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for net-analyzer/net-snmp
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.1 2002/06/29 20:42:47 blocke Exp $
+
+*net-snmp-5.0.1 (29 Jun 2002)
+
+ 29 Jun 2002; Bruce A. Locke <blocke@shivan.org> net-snmp-5.0.1.ebuild:
+
+ ucd-snmp has been renamed to net-snmp and this release appears to be
+ source incompatible with ucd-snmp
+
+ Known Issue: The new optional perl module support is disabled (due to
+ configure/make issues) until someone who is familiar with the functionality
+ can contribute a patch.
+
diff --git a/net-analyzer/net-snmp/files/digest-net-snmp-5.0.1 b/net-analyzer/net-snmp/files/digest-net-snmp-5.0.1
new file mode 100644
index 000000000000..94686d8f7435
--- /dev/null
+++ b/net-analyzer/net-snmp/files/digest-net-snmp-5.0.1
@@ -0,0 +1 @@
+MD5 f209cff622b4ffee830d54b68985d859 net-snmp-5.0.1.tar.gz 2128267
diff --git a/net-analyzer/net-snmp/files/net-snmpd.rc6 b/net-analyzer/net-snmp/files/net-snmpd.rc6
new file mode 100644
index 000000000000..0a384858b3e0
--- /dev/null
+++ b/net-analyzer/net-snmp/files/net-snmpd.rc6
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/files/net-snmpd.rc6,v 1.1 2002/06/29 20:42:47 blocke Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /usr/share/snmp/snmpd.conf ] ; then
+ eerror "You need an /usr/share/snmp/snmpd.conf to run snmpd"
+ eerror "There is an example config in /usr/share/docs/net-snmp"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting net-snmpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/snmpd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping net-snmpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/snmpd
+ eend $?
+}
diff --git a/net-analyzer/net-snmp/net-snmp-5.0.1.ebuild b/net-analyzer/net-snmp/net-snmp-5.0.1.ebuild
new file mode 100644
index 000000000000..520e9183c5c5
--- /dev/null
+++ b/net-analyzer/net-snmp/net-snmp-5.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.0.1.ebuild,v 1.1 2002/06/29 20:42:47 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Software for generating and retrieving SNMP data"
+SRC_URI="mirror://sourceforge/net-snmp/${P}.tar.gz"
+HOMEPAGE="http://net-snmp.sourceforge.net/"
+
+DEPEND="virtual/glibc <sys-libs/db-2
+ >=sys-libs/zlib-1.1.4
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ kerberos? ( >=app-crypt/krb5-1.2.5 )"
+
+LICENSE="as-is"
+SLOT="0"
+
+src_compile() {
+ local myconf disable_sec_services
+
+ use ssl || myconf="${myconf} --enable-internal-md5 --with-openssl=no"
+ use tcpd && myconf="${myconf} --with-libwrap" || myconf="${myconf} --with-libwrap=no"
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --disable-ipv6"
+ use ipv6 || myconf="${myconf} --with-out-transports=\"TCPIPv6 UDPIPv6\""
+ use kerberos && myconf="${myconf} --with-security-modules=\"usm ksm\""
+
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --host="${CHOST}" \
+ --with-zlib \
+ --enable-shared \
+ --with-sys-location="Unknown" \
+ --with-sys-contact="root@Unknown" \
+ --with-default-snmp-version="3" \
+ --with-logfile=/var/log/net-snmpd.log \
+ --with-persistent-directory=/var/lib/net-snmp \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+
+ einstall exec_prefix=${D}/usr \
+ persistentdir=${D}/var/lib/net-snmp || die
+
+ dodir /var/lib/net-snmp
+
+ dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO EXAMPLE.conf.def
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/net-snmpd.rc6 net-snmpd
+}