summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-09 17:39:49 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-09 17:39:49 +0000
commit6295d263ea815804341fb49ccfe9c58ca1e50ecf (patch)
tree34666d9ca9429ae2e0f11d628c191f49a62f4ed7 /net-analyzer
parentUpdate oldfind removal to include program prefix #469084 by Christian Bricart. (diff)
downloadgentoo-2-6295d263ea815804341fb49ccfe9c58ca1e50ecf.tar.gz
gentoo-2-6295d263ea815804341fb49ccfe9c58ca1e50ecf.tar.bz2
gentoo-2-6295d263ea815804341fb49ccfe9c58ca1e50ecf.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/httping-2.3.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 08a0553aa144..1e6775554e66 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.101 2013/05/07 14:45:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.102 2013/05/09 17:39:49 radhermit Exp $
+
+*httping-2.3.1 (09 May 2013)
+
+ 09 May 2013; Tim Harder <radhermit@gentoo.org> +httping-2.3.1.ebuild:
+ Version bump.
*httping-2.3 (07 May 2013)
diff --git a/net-analyzer/httping/httping-2.3.1.ebuild b/net-analyzer/httping/httping-2.3.1.ebuild
new file mode 100644
index 000000000000..3d84e4059957
--- /dev/null
+++ b/net-analyzer/httping/httping-2.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-2.3.1.ebuild,v 1.1 2013/05/09 17:39:49 radhermit Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug fftw ncurses ssl tfo"
+
+RDEPEND="
+ fftw? ( sci-libs/fftw:3.0 )
+ ncurses? ( >=sys-libs/ncurses-5 )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.1-flags.patch
+}
+
+src_configure() {
+ # not an autotools script
+ echo > makefile.inc || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ FW=$(usex fftw) \
+ DEBUG=$(usex debug) \
+ NC=$(usex ncurses) \
+ SSL=$(usex ssl) \
+ TFO=$(usex tfo)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+}