summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-22 15:30:31 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-22 15:30:31 +0000
commit6f25ddb06e94061b3af708ec39e146f1e34fb69b (patch)
tree9a4088fdc22a2ee889928c829b5e3c605b7d1fbd /net-analyzer
parentx86 stable, bug #247485 (diff)
downloadgentoo-2-6f25ddb06e94061b3af708ec39e146f1e34fb69b.tar.gz
gentoo-2-6f25ddb06e94061b3af708ec39e146f1e34fb69b.tar.bz2
gentoo-2-6f25ddb06e94061b3af708ec39e146f1e34fb69b.zip
Updated patch to handle more points of failure. Remove old.
(Portage version: 2.2_rc15/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch26
-rw-r--r--net-analyzer/wireshark/wireshark-1.0.3.ebuild167
3 files changed, 31 insertions, 168 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 28be27ffb794..d88480bafba5 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.133 2008/11/15 17:42:03 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.134 2008/11/22 15:30:31 pva Exp $
+
+ 22 Nov 2008; Peter Volkov <pva@gentoo.org>
+ files/wireshark-1.1.1-misc-warnings.patch, -wireshark-1.0.3.ebuild:
+ Updated patch to handle more points of failure. Remove old.
15 Nov 2008; Tobias Scherbaum <dertobi123@gentoo.org>
wireshark-1.0.4.ebuild:
diff --git a/net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch b/net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch
index 8a5e26a0a4e9..8e6d339b7c69 100644
--- a/net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch
+++ b/net-analyzer/wireshark/files/wireshark-1.1.1-misc-warnings.patch
@@ -132,3 +132,29 @@
volatile gboolean is_802_2;
proto_tree *volatile vlan_tree;
+=== modified file 'epan/dissectors/packet-scsi.h'
+--- epan/dissectors/packet-scsi.h 2008-11-22 14:42:31 +0000
++++ epan/dissectors/packet-scsi.h 2008-11-22 14:45:00 +0000
+@@ -241,7 +241,7 @@
+ */
+ #define TRY_SCSI_CDB_ALLOC_LEN(pinfo, tvb, offset, length) \
+ { \
+- gboolean short_packet; \
++ volatile gboolean short_packet; \
+ tvbuff_t *new_tvb; \
+ guint32 end_data_offset=0; \
+ \
+
+=== modified file 'epan/dissectors/packet-x11.c'
+--- epan/dissectors/packet-x11.c 2008-11-22 14:42:31 +0000
++++ epan/dissectors/packet-x11.c 2008-11-22 14:50:41 +0000
+@@ -4066,7 +4066,7 @@
+ conversation_t *conversation;
+ x11_conv_data_t *volatile state;
+ int length;
+- tvbuff_t *next_tvb;
++ tvbuff_t *volatile next_tvb;
+
+ while (tvb_reported_length_remaining(tvb, offset) != 0) {
+ /*
+
diff --git a/net-analyzer/wireshark/wireshark-1.0.3.ebuild b/net-analyzer/wireshark/wireshark-1.0.3.ebuild
deleted file mode 100644
index 41618c3c1d2a..000000000000
--- a/net-analyzer/wireshark/wireshark-1.0.3.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.0.3.ebuild,v 1.5 2008/09/10 14:14:04 tester Exp $
-
-EAPI=1
-WANT_AUTOMAKE="1.9"
-inherit autotools libtool flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="A network protocol analyzer formerly known as ethereal"
-HOMEPAGE="http://www.wireshark.org/"
-
-# _rc versions has different download location.
-[[ -n ${PV#*_rc} && ${PV#*_rc} != ${PV} ]] && {
-SRC_URI="http://www.wireshark.org/download/prerelease/${PN}-${PV/_rc/pre}.tar.gz";
-S=${WORKDIR}/${PN}-${PV/_rc/pre} ; } || \
-SRC_URI="http://www.wireshark.org/download/src/all-versions/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="adns gtk ipv6 lua portaudio gnutls gcrypt zlib kerberos threads profile smi +pcap pcre +caps selinux"
-
-RDEPEND="zlib? ( sys-libs/zlib )
- smi? ( net-libs/libsmi )
- gtk? ( >=dev-libs/glib-2.0.4
- =x11-libs/gtk+-2*
- x11-libs/pango
- dev-libs/atk )
- !gtk? ( =dev-libs/glib-1.2* )
- gnutls? ( net-libs/gnutls )
- gcrypt? ( dev-libs/libgcrypt )
- pcap? ( net-libs/libpcap )
- pcre? ( dev-libs/libpcre )
- caps? ( sys-libs/libcap )
- adns? ( net-libs/adns )
- kerberos? ( virtual/krb5 )
- portaudio? ( media-libs/portaudio )
- lua? ( >=dev-lang/lua-5.1 )
- selinux? ( sec-policy/selinux-wireshark )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.15.0
- dev-lang/perl
- sys-devel/bison
- sys-devel/flex
- sys-apps/sed"
-
-pkg_setup() {
- if ! use gtk; then
- ewarn "USE=-gtk will mean no gui called wireshark will be created and"
- ewarn "only command line utils are available"
- fi
-
- # Add group for users allowed to sniff.
- enewgroup wireshark || die "Failed to create wireshark group"
-}
-
-src_unpack() {
- unpack ${A}
-
- # Try to drop --as-needed patches for 1.0.1. All problems are supposed to be
- # fixed there...
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.99.7-asneeded.patch
- epatch "${FILESDIR}"/${PN}-0.99.8-as-needed.patch
-
- cd "${S}"/epan
- epatch "${FILESDIR}"/wireshark-except-double-free.diff
-
- cd "${S}"
- eautoreconf
-}
-
-src_compile() {
- # optimization bug, see bug #165340, bug #40660
- if [[ $(gcc-version) == 3.4 ]] ; then
- elog "Found gcc 3.4, forcing -O3 into CFLAGS"
- replace-flags -O? -O3
- elif [[ $(gcc-version) == 3.3 || $(gcc-version) == 3.2 ]] ; then
- elog "Found <=gcc-3.3, forcing -O into CFLAGS"
- replace-flags -O? -O
- fi
-
- # see bug #133092; bugs.wireshark.org/bugzilla/show_bug.cgi?id=1001
- # our hardened toolchain bug
- filter-flags -fstack-protector
-
- # profile and -fomit-frame-pointer are incompatible, bug #215806
- use profile && filter-flags -fomit-frame-pointer
-
- local myconf
- if use gtk; then
- einfo "Building with gtk support"
- else
- einfo "Building without gtk support"
- myconf="${myconf} --disable-wireshark"
- fi
-
- # Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
- # --with-ssl to ./configure. (Mimics code from acinclude.m4).
- if use kerberos; then
- case `krb5-config --libs` in
- *-lcrypto*) myconf="${myconf} --with-ssl" ;;
- esac
- fi
-
- # dumpcap requires libcap, setuid-install requires dumpcap
- econf $(use_enable gtk gtk2) \
- $(use_enable profile profile-build) \
- $(use_with gnutls) \
- $(use_with gcrypt) \
- $(use_enable gtk wireshark) \
- $(use_enable ipv6) \
- $(use_enable threads) \
- $(use_with lua) \
- $(use_with adns) \
- $(use_with kerberos krb5) \
- $(use_with smi libsmi) \
- $(use_with pcap) \
- $(use_with zlib) \
- $(use_with pcre) \
- $(use_with portaudio) \
- $(use_with caps libcap) \
- $(use_enable pcap setuid-install) \
- --sysconfdir=/etc/wireshark \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- fowners 0:wireshark /usr/bin/tshark
- fperms 6550 /usr/bin/tshark
- use pcap && fowners 0:wireshark /usr/bin/dumpcap
- use pcap && fperms 6550 /usr/bin/dumpcap
-
- insinto /usr/include/wiretap
- doins wiretap/wtap.h
-
- # FAQ is not required as is installed from help/faq.txt
- dodoc AUTHORS ChangeLog NEWS README{,bsd,linux,macos,vmware} doc/randpkt.txt
-
- if use gtk ; then
- insinto /usr/share/icons/hicolor/16x16/apps
- newins image/hi16-app-wireshark.png wireshark.png
- insinto /usr/share/icons/hicolor/32x32/apps
- newins image/hi32-app-wireshark.png wireshark.png
- insinto /usr/share/icons/hicolor/48x48/apps
- newins image/hi48-app-wireshark.png wireshark.png
- insinto /usr/share/applications
- doins wireshark.desktop
- fi
-}
-
-pkg_postinst() {
- echo
- ewarn "With version 0.99.7, all function calls that require elevated privileges"
- ewarn "have been moved out of the GUI to dumpcap. WIRESHARK CONTAINS OVER ONE"
- ewarn "POINT FIVE MILLION LINES OF SOURCE CODE. DO NOT RUN THEM AS ROOT."
- ewarn
- ewarn "NOTE: To run wireshark as normal user you have to add yourself into"
- ewarn "wireshark group. This security measure ensures that only trusted"
- ewarn "users allowed to sniff your traffic."
- echo
-}