summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-07-19 21:49:25 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-07-19 21:49:25 +0000
commit761793a8db183a6359eea702334a6d1ffdddcb33 (patch)
treef25f2fedbb21f75cbc33a30bc5277f2991daa5a5 /net-analyzer
parentMigrated to Generation 2. (diff)
downloadgentoo-2-761793a8db183a6359eea702334a6d1ffdddcb33.tar.gz
gentoo-2-761793a8db183a6359eea702334a6d1ffdddcb33.tar.bz2
gentoo-2-761793a8db183a6359eea702334a6d1ffdddcb33.zip
added patch to include gcrypt libraries to solve bug #141021.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog7
-rw-r--r--net-analyzer/wireshark/files/wireshark-0.99.2-libgcrypt-asneeded.patch11
-rw-r--r--net-analyzer/wireshark/wireshark-0.99.2.ebuild10
3 files changed, 26 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 082e13f1d236..ecf6080142bd 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.10 2006/07/19 15:33:31 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.11 2006/07/19 21:49:25 dragonheart Exp $
+
+ 19 Jul 2006; Daniel Black <dragonheart@gentoo.org>
+ +files/wireshark-0.99.2-libgcrypt-asneeded.patch, wireshark-0.99.2.ebuild:
+ added patch to include gcrypt libraries to solve bug #141021. Thanks to
+ Alberto Ornaghi for the bug report
19 Jul 2006; Simon Stelling <blubb@gentoo.org> wireshark-0.99.2.ebuild:
stable wrt bug 140856
diff --git a/net-analyzer/wireshark/files/wireshark-0.99.2-libgcrypt-asneeded.patch b/net-analyzer/wireshark/files/wireshark-0.99.2-libgcrypt-asneeded.patch
new file mode 100644
index 000000000000..04d4fad075c4
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-0.99.2-libgcrypt-asneeded.patch
@@ -0,0 +1,11 @@
+--- wireshark-0.99.2/epan/Makefile.am.orig 2006-07-20 07:08:41.000000000 +1000
++++ wireshark-0.99.2/epan/Makefile.am 2006-07-20 07:17:00.000000000 +1000
+@@ -84,7 +84,7 @@
+ #
+ # Add the object files for missing routines, if any.
+ #
+-libwireshark_la_LIBADD = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la @ADNS_LIBS@ @LIBGNUTLS_LIBS@ @KRB5_LIBS@ @SNMP_LIBS@ @SSL_LIBS@ -lm
++libwireshark_la_LIBADD = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la @ADNS_LIBS@ @LIBGNUTLS_LIBS@ @KRB5_LIBS@ @SNMP_LIBS@ @SSL_LIBS@ @LIBGCRYPT_LIBS@ -lm
+ libwireshark_la_DEPENDENCIES = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la
+
+ tvbtest: tvbtest.o tvbuff.o except.o strutil.o
diff --git a/net-analyzer/wireshark/wireshark-0.99.2.ebuild b/net-analyzer/wireshark/wireshark-0.99.2.ebuild
index d5b11cc3ce63..9291227b5dc4 100644
--- a/net-analyzer/wireshark/wireshark-0.99.2.ebuild
+++ b/net-analyzer/wireshark/wireshark-0.99.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-0.99.2.ebuild,v 1.5 2006/07/19 15:33:31 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-0.99.2.ebuild,v 1.6 2006/07/19 21:49:25 dragonheart Exp $
inherit libtool flag-o-matic eutils autotools libtool
@@ -50,6 +50,14 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-libgcrypt-asneeded.patch
+ cd "${S}"
+ AT_M4DIR="${S}/aclocal-fallback" eautoreconf
+ #elibtoolize
+}
+
src_compile() {
replace-flags -O? -O