summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-29 03:53:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-29 03:53:20 +0000
commit8ed364a40cac271931cfd903c686e3917e4399aa (patch)
tree9f5157780ce0211ed8bd1d23a08ac5e247c038e7 /net-analyzer
parentremove DESCRIPTION variable wrt bug #428304 (diff)
downloadgentoo-2-8ed364a40cac271931cfd903c686e3917e4399aa.tar.gz
gentoo-2-8ed364a40cac271931cfd903c686e3917e4399aa.tar.bz2
gentoo-2-8ed364a40cac271931cfd903c686e3917e4399aa.zip
Update my freeipmi_ plugin and use it to replace the other two originals (which it replaces entirely).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/munin/ChangeLog8
-rw-r--r--net-analyzer/munin/munin-2.0.3-r1.ebuild253
2 files changed, 260 insertions, 1 deletions
diff --git a/net-analyzer/munin/ChangeLog b/net-analyzer/munin/ChangeLog
index 88a0ba5deb0b..eee4c90270de 100644
--- a/net-analyzer/munin/ChangeLog
+++ b/net-analyzer/munin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/munin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.85 2012/07/28 00:44:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.86 2012/07/29 03:53:20 flameeyes Exp $
+
+*munin-2.0.3-r1 (29 Jul 2012)
+
+ 29 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +munin-2.0.3-r1.ebuild:
+ Update my freeipmi_ plugin and use it to replace the other two originals
+ (which it replaces entirely).
28 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml,
munin-2.0.3.ebuild:
diff --git a/net-analyzer/munin/munin-2.0.3-r1.ebuild b/net-analyzer/munin/munin-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..f91dbc863877
--- /dev/null
+++ b/net-analyzer/munin/munin-2.0.3-r1.ebuild
@@ -0,0 +1,253 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.3-r1.ebuild,v 1.1 2012/07/29 03:53:20 flameeyes Exp $
+
+EAPI=4
+
+PATCHSET=6
+
+inherit eutils user java-pkg-opt-2
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Munin Server Monitoring Tool"
+HOMEPAGE="http://munin-monitoring.org/"
+SRC_URI="mirror://sourceforge/munin/${MY_P}.tar.gz
+ http://dev.gentoo.org/~flameeyes/${PN}/${P}-patches-${PATCHSET}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="asterisk irc java memcached minimal mysql postgres ssl test +cgi ipv6 syslog ipmi http"
+REQUIRED_USE="cgi? ( !minimal )"
+
+# Upstream's listing of required modules is NOT correct!
+# Some of the postgres plugins use DBD::Pg, while others call psql directly.
+# Some of the mysql plugins use DBD::mysql, while others call mysqladmin directly.
+# We replace the original ipmi plugisn with the freeipmi_ plugin which at least works.
+DEPEND_COM="dev-lang/perl
+ sys-process/procps
+ asterisk? ( dev-perl/Net-Telnet )
+ irc? ( dev-perl/Net-IRC )
+ mysql? ( virtual/mysql
+ dev-perl/Cache-Cache
+ dev-perl/DBD-mysql )
+ ssl? ( dev-perl/Net-SSLeay )
+ postgres? ( dev-perl/DBD-Pg dev-db/postgresql-base )
+ memcached? ( dev-perl/Cache-Memcached )
+ cgi? ( dev-perl/FCGI )
+ syslog? ( virtual/perl-Sys-Syslog )
+ ipmi? (
+ >=sys-libs/freeipmi-1.1.6-r1
+ virtual/awk
+ )
+ http? ( dev-perl/libwww-perl )
+ dev-perl/DBI
+ dev-perl/DateManip
+ dev-perl/File-Copy-Recursive
+ dev-perl/Log-Log4perl
+ dev-perl/Net-CIDR
+ dev-perl/Net-Netmask
+ dev-perl/Net-SNMP
+ dev-perl/net-server[ipv6(-)?]
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-MIME-Base64
+ virtual/perl-Storable
+ virtual/perl-Text-Balanced
+ virtual/perl-Time-HiRes
+ !minimal? (
+ dev-perl/HTML-Template
+ dev-perl/IO-Socket-INET6
+ >=net-analyzer/rrdtool-1.3[perl]
+ )"
+
+# Keep this seperate, as previous versions have had other deps here
+DEPEND="${DEPEND_COM}
+ virtual/perl-Module-Build
+ java? ( >=virtual/jdk-1.5 )
+ test? (
+ dev-perl/Test-LongString
+ dev-perl/Test-Differences
+ dev-perl/Test-MockModule
+ dev-perl/File-Slurp
+ dev-perl/IO-stringy
+ dev-perl/IO-Socket-INET6
+ )"
+RDEPEND="${DEPEND_COM}
+ java? ( >=virtual/jre-1.5 )
+ !minimal? (
+ virtual/cron
+ media-fonts/dejavu
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup munin
+ enewuser munin 177 -1 /var/lib/munin munin
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/patches/*.patch
+ mv b/plugins/node.d/freeipmi_.in plugins/node.d/
+
+ java-pkg-opt-2_src_prepare
+}
+
+src_configure() {
+ local cgidir='$(DESTDIR)/var/www/localhost/cgi-bin'
+ use cgi || cgidir="${T}/useless/cgi-bin"
+
+ cat - >> "${S}"/Makefile.config <<EOF
+PREFIX=\$(DESTDIR)/usr
+CONFDIR=\$(DESTDIR)/etc/munin
+DOCDIR=${T}/useless/doc
+MANDIR=\$(PREFIX)/share/man
+LIBDIR=\$(PREFIX)/libexec/munin
+HTMLDIR=\$(DESTDIR)/var/www/localhost/htdocs/munin
+CGIDIR=${cgidir}
+DBDIR=\$(DESTDIR)/var/lib/munin
+LOGDIR=\$(DESTDIR)/var/log/munin
+PERLSITELIB=$(perl -V:vendorlib | cut -d"'" -f2)
+JCVALID=$(usex java yes no)
+EOF
+}
+
+# parallel make and install need to be fixed before, and I haven't
+# gotten around to do so yet.
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ local dirs="
+ /var/log/munin/
+ /var/lib/munin/plugin-state/
+ /etc/munin/plugin-conf.d/
+ /etc/munin/plugins/"
+ keepdir ${dirs}
+ fowners munin:munin ${dirs}
+ use minimal || dirs+=" /etc/munin/munin-conf.d/"
+
+ local install_targets="install-common-prime install-node-prime install-plugins-prime"
+ use java && install_targets+=" install-plugins-java"
+ use minimal || install_targets=install
+
+ # parallel install doesn't work and it's also pointless to have this
+ # run in parallel for now (because it uses internal loops).
+ emake -j1 DESTDIR="${D}" ${install_targets}
+
+ # remove the plugins for non-Gentoo package managers
+ rm "${D}"/usr/libexec/munin/plugins/{apt{,_all},yum} || die
+
+ insinto /etc/munin/plugin-conf.d/
+ newins "${FILESDIR}"/${PN}-1.3.2-plugins.conf munin-node
+
+ # make sure we've got everything in the correct directory
+ newinitd "${FILESDIR}"/munin-node_init.d_2.0.2 munin-node
+ newconfd "${FILESDIR}"/munin-node_conf.d_1.4.6-r2 munin-node
+ dodoc README ChangeLog INSTALL build/resources/apache*
+
+ # bug 254968
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/logrotate.d-munin munin
+
+ dosym freeipmi_ /usr/libexec/munin/plugins/ipmi_
+ dosym freeipmi_ /usr/libexec/munin/plugins/ipmi_sensor_
+
+ if use syslog; then
+ sed -i -e '/log_file/s| .*| Sys::Syslog|' \
+ "${D}"/etc/munin/munin-node.conf || die
+ fi
+
+ if ! use minimal; then
+ exeinto /etc/local.d/
+ newexe "${FILESDIR}"/localstart-munin 50munin.start
+
+ # remove font files so that we don't have to keep them around
+ rm "${D}"/usr/libexec/${PN}/*.ttf || die
+
+ if use cgi; then
+ sed -i -e '/#graph_strategy cgi/s:^#::' "${D}"/etc/munin/munin.conf || die
+ else
+ sed -i -e '/#graph_strategy cgi/s:#graph_strategy cgi:graph_strategy cron:' "${D}"/etc/munin/munin.conf || die
+ fi
+
+ dodir /usr/share/${PN}
+ cat - >> "${D}"/usr/share/${PN}/crontab <<EOF
+# Force the shell to bash
+SHELL=/bin/bash
+# Mail reports to root@, not munin@
+MAILTO=root
+
+# This runs the munin task every 5 minutes.
+*/5 * * * * /usr/bin/munin-cron
+
+# Alternatively, this route works differently
+# Update once a minute (for busy sites)
+#*/1 * * * * /usr/libexec/munin/munin-update
+## Check for limit excess every 2 minutes
+#*/2 * * * * /usr/libexec/munin/munin-limits
+## Update graphs every 5 minutes
+#*/5 * * * * nice /usr/libexec/munin/munin-graph
+## Update HTML pages every 15 minutes
+#*/15 * * * * nice /usr/libexec/munin/munin-html
+EOF
+
+ cat - >> "${D}"/usr/share/${PN}/fcrontab <<EOF
+# Mail reports to root@, not munin@, only execute one at a time
+!mailto(root),serial(true)
+
+# This runs the munin task every 5 minutes.
+@ 5 /usr/bin/munin-cron
+
+# Alternatively, this route works differently
+# Update once a minute (for busy sites)
+#@ 1 /usr/libexec/munin/munin-update
+## Check for limit excess every 2 minutes
+#@ 2 /usr/libexec/munin/munin-limits
+## Update graphs every 5 minutes
+#@ 5 nice /usr/libexec/munin/munin-graph
+## Update HTML pages every 15 minutes
+#@ 15 nice /usr/libexec/munin/munin-html
+EOF
+
+ # remove .htaccess file
+ find "${D}" -name .htaccess -delete || die
+ fi
+}
+
+pkg_config() {
+ if use minimal; then
+ einfo "Nothing to do."
+ return 0
+ fi
+
+ einfo "Press enter to install the default crontab for the munin master"
+ einfo "installation from /usr/share/${PN}/f?crontab"
+ einfo "If you have a large site, you may wish to customize it."
+ read
+
+ if has_version sys-process/fcron; then
+ fcrontab - -u munin < /usr/share/${PN}/fcrontab
+ else
+ # dcron is very fussy about syntax
+ # the following is the only form that works in BOTH dcron and vixie-cron
+ crontab - -u munin < /usr/share/${PN}/crontab
+ fi
+}
+
+pkg_postinst() {
+ elog "Please follow the munin documentation to set up the plugins you"
+ elog "need, afterwards start munin-node via /etc/init.d/munin-node."
+ if ! use minimal; then
+ elog "To have munin's cronjob automatically configured for you if this is"
+ elog "your munin master installation, please:"
+ elog "emerge --config net-analyzer/munin"
+ fi
+ elog ""
+ elog "Further information about setting up Munin in Gentoo can be found"
+ elog "in the Gentoo Wiki: https://wiki.gentoo.org/wiki/Munin"
+}