summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-11-01 04:17:10 +0000
committerJeroen Roovers <jer@gentoo.org>2010-11-01 04:17:10 +0000
commit93e254c149bc33e68a82af09d925ce1b447d5cda (patch)
treecdbca53e552b113e0a70b91ca9afffa6a0938ea6 /net-analyzer
parentrevbump (diff)
downloadgentoo-2-93e254c149bc33e68a82af09d925ce1b447d5cda.tar.gz
gentoo-2-93e254c149bc33e68a82af09d925ce1b447d5cda.tar.bz2
gentoo-2-93e254c149bc33e68a82af09d925ce1b447d5cda.zip
Clean up patch (remove LIBTOOL dep and unset CFLAGS in configure.in, extend it (Makefile.am) so we can simply use emake install without trying to install empty/non-existent files, and do not set CFLAGS again (src/Makefile.am). Bug #343333.
(Portage version: 2.1.9.23/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/upnpscan/ChangeLog11
-rw-r--r--net-analyzer/upnpscan/files/upnpscan-0.4-cflags.patch59
-rw-r--r--net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild (renamed from net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild)18
3 files changed, 58 insertions, 30 deletions
diff --git a/net-analyzer/upnpscan/ChangeLog b/net-analyzer/upnpscan/ChangeLog
index b2def22562b8..6d74ec153ec9 100644
--- a/net-analyzer/upnpscan/ChangeLog
+++ b/net-analyzer/upnpscan/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/upnpscan
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/ChangeLog,v 1.8 2010/10/30 09:24:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/ChangeLog,v 1.9 2010/11/01 04:17:09 jer Exp $
+
+*upnpscan-0.4-r2 (01 Nov 2010)
+
+ 01 Nov 2010; Jeroen Roovers <jer@gentoo.org> -upnpscan-0.4-r1.ebuild,
+ +upnpscan-0.4-r2.ebuild, files/upnpscan-0.4-cflags.patch:
+ Clean up patch (remove LIBTOOL dep and unset CFLAGS in configure.in,
+ extend it (Makefile.am) so we can simply use emake install without trying
+ to install empty/non-existent files, and do not set CFLAGS again
+ (src/Makefile.am). Bug #343333.
30 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org>
upnpscan-0.4-r1.ebuild:
diff --git a/net-analyzer/upnpscan/files/upnpscan-0.4-cflags.patch b/net-analyzer/upnpscan/files/upnpscan-0.4-cflags.patch
index f7632d7f005b..46be9888ec7c 100644
--- a/net-analyzer/upnpscan/files/upnpscan-0.4-cflags.patch
+++ b/net-analyzer/upnpscan/files/upnpscan-0.4-cflags.patch
@@ -1,20 +1,51 @@
---- upnpscan/src/Makefile.in.orig 2005-06-23 17:03:51.000000000 +0200
-+++ upnpscan/src/Makefile.in 2009-01-15 08:42:52.000000000 +0100
-@@ -82,7 +82,6 @@
- AWK = @AWK@
- CC = @CC@
- CCDEPMODE = @CCDEPMODE@
--CFLAGS = @CFLAGS@
- CPP = @CPP@
- CPPFLAGS = @CPPFLAGS@
- CXX = @CXX@
-@@ -181,8 +180,7 @@
+--- a/configure.in 2005-06-23 17:02:57.000000000 +0200
++++ b/configure.in 2010-11-01 04:44:44.000000000 +0100
+@@ -8,12 +8,10 @@
+ AM_CONFIG_HEADER(config.h)
+
+ AC_ISC_POSIX
+-CFLAGS=""
+ AC_SUBST(CFLAGS)
+ AC_PROG_CC
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
+-AM_PROG_LIBTOOL
+
+ dnl Checks for programs.
+
+--- a/Makefile.am 2005-06-23 12:32:13.000000000 +0200
++++ b/Makefile.am 2010-11-01 04:46:41.000000000 +0100
+@@ -5,20 +5,6 @@
+
+ SUBDIRS = src
+
+-upnpscandocdir = ${prefix}/doc/upnpscan
+-upnpscandoc_DATA = \
+- README\
+- COPYING\
+- AUTHORS\
+- ChangeLog\
+- INSTALL\
+- NEWS\
+- TODO
+-
+-EXTRA_DIST = $(upnpscandoc_DATA)
+-
+-
+-
+ # Copy all the spec files. Of cource, only one is actually used.
+ dist-hook:
+ for specfile in *.spec; do \
+--- a/src/Makefile.am 2005-06-21 22:57:32.000000000 +0200
++++ b/src/Makefile.am 2010-11-01 04:53:22.000000000 +0100
+@@ -7,10 +7,6 @@
+ INCLUDES =\
-I../include
- AM_CFLAGS = \
+-AM_CFLAGS =\
- -Wall\
- -g
-+ -Wall
+-
+ bin_PROGRAMS = upnpscan
upnpscan_SOURCES = \
- upnpscan.c\
diff --git a/net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild b/net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild
index cda64a1c31b6..997579708f85 100644
--- a/net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild
+++ b/net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild,v 1.2 2010/10/30 09:24:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild,v 1.1 2010/11/01 04:17:09 jer Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="http://www.cqure.net/tools/${PN}-v${PV}-src.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static"
+IUSE=""
S="${WORKDIR}/${PN}"
@@ -22,18 +22,6 @@ src_prepare() {
eautoreconf
}
-src_configure() {
- if use static ; then
- econf || die
- else
- econf --enable-static=no || die
- fi
-}
-
-src_compile() {
- emake CFLAGS="${CFLAGS}" || die
-}
-
src_install() {
- dobin "${S}"/src/upnpscan || die
+ emake DESTDIR="${D}" install || die
}