summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-04-12 20:03:43 +0000
committerJeroen Roovers <jer@gentoo.org>2014-04-12 20:03:43 +0000
commite304f4578f86c0f5113604804934826799108ea9 (patch)
tree9a6129e4c02de5de4e3e0525b360ca207bc67bf4 /net-analyzer
parentStable for amd64 wrt bug #502640 (diff)
downloadgentoo-2-e304f4578f86c0f5113604804934826799108ea9.tar.gz
gentoo-2-e304f4578f86c0f5113604804934826799108ea9.tar.bz2
gentoo-2-e304f4578f86c0f5113604804934826799108ea9.zip
Use checkpath instead of keepdir, hard-code PIDFILE as it is not a useful configuration option (bug #483590 by Reuben Farrelly).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/flow-tools/ChangeLog11
-rwxr-xr-xnet-analyzer/flow-tools/files/flowcapture.confd9
-rwxr-xr-xnet-analyzer/flow-tools/files/flowcapture.initd3
3 files changed, 13 insertions, 10 deletions
diff --git a/net-analyzer/flow-tools/ChangeLog b/net-analyzer/flow-tools/ChangeLog
index 121cbc121e80..68451392de67 100644
--- a/net-analyzer/flow-tools/ChangeLog
+++ b/net-analyzer/flow-tools/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-analyzer/flow-tools
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flow-tools/ChangeLog,v 1.66 2013/02/26 15:41:31 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flow-tools/ChangeLog,v 1.67 2014/04/12 20:03:43 jer Exp $
+
+ 12 Apr 2014; Jeroen Roovers <jer@gentoo.org> files/flowcapture.confd,
+ files/flowcapture.initd:
+ Use checkpath instead of keepdir, hard-code PIDFILE as it is not a useful
+ configuration option (bug #483590 by Reuben Farrelly).
26 Feb 2013; Jeroen Roovers <jer@gentoo.org> flow-tools-0.68.5.1-r2.ebuild:
- Fix default pidfile path. Replace chown withth fowners and chmod with fperms,
+ Fix default pidfile path. Replace chown with fowners and chmod with fperms,
replace /var/run with /run (bug #458944 by Reuben Farrelly).
26 Feb 2013; Jeroen Roovers <jer@gentoo.org> -flow-tools-0.68.5.1-r1.ebuild,
diff --git a/net-analyzer/flow-tools/files/flowcapture.confd b/net-analyzer/flow-tools/files/flowcapture.confd
index 105069f6ed66..82ce38a4bc73 100755
--- a/net-analyzer/flow-tools/files/flowcapture.confd
+++ b/net-analyzer/flow-tools/files/flowcapture.confd
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Config file for /etc/init.d/flowcap
@@ -11,9 +11,6 @@ LOCALIP=0
# You probably don't want to change this, but in case you do - nest level
NEST=0
-# pid file location
-PIDFILE=/var/run/flowcapture.pid
-
# port to listen on
PORT=2055
@@ -43,6 +40,6 @@ WORKDIR=/var/lib/flows/ft
USER=flows
# This pulls in the options above
-FLOW_OPTS="-p $PIDFILE -w $WORKDIR $LOCALIP/$REMOTEIP/$PORT -V $FLOW_VER -E $SIZE -n $ROTATIONS -N $NEST -R $ROTATE_PROG"
+FLOW_OPTS="-p /run/flows/flowcapture.pid -w $WORKDIR $LOCALIP/$REMOTEIP/$PORT -V $FLOW_VER -E $SIZE -n $ROTATIONS -N $NEST -R $ROTATE_PROG"
# Use below only if you have sorted out the STAT_INT problem
-#FLOW_OPTS="-p $PIDFILE -w $WORKDIR $LOCALIP/$REMOTEIP/$PORT -S $STAT_INT -V $FLOW_VER -E $SIZE -n $ROTATIONS -N $NEST -R $ROTATE_PROG"
+#FLOW_OPTS="-p /run/flows/flowcapture.pid -w $WORKDIR $LOCALIP/$REMOTEIP/$PORT -S $STAT_INT -V $FLOW_VER -E $SIZE -n $ROTATIONS -N $NEST -R $ROTATE_PROG"
diff --git a/net-analyzer/flow-tools/files/flowcapture.initd b/net-analyzer/flow-tools/files/flowcapture.initd
index 9a2c1a6df044..6c78f0fdf99d 100755
--- a/net-analyzer/flow-tools/files/flowcapture.initd
+++ b/net-analyzer/flow-tools/files/flowcapture.initd
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -8,6 +8,7 @@ depend() {
start() {
ebegin "Starting flow-capture"
+ checkpath -d -o flows /run/flows
start-stop-daemon --start --user ${USER} --exec /usr/bin/flow-capture \
--pidfile ${PIDFILE}.${PORT} \
-- ${FLOW_OPTS} >/dev/null 2>&1