summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-11-27 18:17:45 +0000
committerAlin Năstac <mrness@gentoo.org>2006-11-27 18:17:45 +0000
commitdfe1d68b32291d23c3f61237f619777d29e04418 (patch)
tree55b3efb8ec774aa1defb63cf336e1194e0512937 /net-dialup/gnuradius
parentFix HOMEPAGE/SRC_URI, thanks to Samuli Suominen. (diff)
downloadgentoo-2-dfe1d68b32291d23c3f61237f619777d29e04418.tar.gz
gentoo-2-dfe1d68b32291d23c3f61237f619777d29e04418.tar.bz2
gentoo-2-dfe1d68b32291d23c3f61237f619777d29e04418.zip
Version bumped and marked stable wrt security bug #156376.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'net-dialup/gnuradius')
-rw-r--r--net-dialup/gnuradius/ChangeLog8
-rw-r--r--net-dialup/gnuradius/files/digest-gnuradius-1.43
-rw-r--r--net-dialup/gnuradius/files/gnuradius-1.4-gcc41.patch23
-rw-r--r--net-dialup/gnuradius/gnuradius-1.4.ebuild62
4 files changed, 95 insertions, 1 deletions
diff --git a/net-dialup/gnuradius/ChangeLog b/net-dialup/gnuradius/ChangeLog
index 4f73440338cf..3b59b9e43f39 100644
--- a/net-dialup/gnuradius/ChangeLog
+++ b/net-dialup/gnuradius/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/gnuradius
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/gnuradius/ChangeLog,v 1.10 2006/11/23 20:30:38 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gnuradius/ChangeLog,v 1.11 2006/11/27 18:17:45 mrness Exp $
+
+*gnuradius-1.4 (27 Nov 2006)
+
+ 27 Nov 2006; Alin Năstac <mrness@gentoo.org>
+ +files/gnuradius-1.4-gcc41.patch, +gnuradius-1.4.ebuild:
+ Version bumped and marked stable wrt security bug #156376.
23 Nov 2006; Francesco Riosa <vivo@gentoo.org> gnuradius-1.3-r2.ebuild:
dev-db/mysql => virtual/mysql
diff --git a/net-dialup/gnuradius/files/digest-gnuradius-1.4 b/net-dialup/gnuradius/files/digest-gnuradius-1.4
new file mode 100644
index 000000000000..fc443214dc84
--- /dev/null
+++ b/net-dialup/gnuradius/files/digest-gnuradius-1.4
@@ -0,0 +1,3 @@
+MD5 ef7c70f694da57a319068df6735f2953 radius-1.4.tar.gz 2341479
+RMD160 5d483800f8bb8b0dc4f967b7d7bd86a03799e1da radius-1.4.tar.gz 2341479
+SHA256 e598ed8b9cbea3ffaffb43e06345b1b15dc770cdcc30ecb577af2347d7bae1a1 radius-1.4.tar.gz 2341479
diff --git a/net-dialup/gnuradius/files/gnuradius-1.4-gcc41.patch b/net-dialup/gnuradius/files/gnuradius-1.4-gcc41.patch
new file mode 100644
index 000000000000..d22aec90b612
--- /dev/null
+++ b/net-dialup/gnuradius/files/gnuradius-1.4-gcc41.patch
@@ -0,0 +1,23 @@
+diff -Nru radius-1.4.orig/include/radiusd.h radius-1.4/include/radiusd.h
+--- radius-1.4.orig/include/radiusd.h 2006-09-08 10:37:33.000000000 +0300
++++ radius-1.4/include/radiusd.h 2006-11-27 19:14:32.715040847 +0200
+@@ -339,7 +339,6 @@
+ extern int max_threads;
+ extern int num_threads;
+ #ifdef USE_SERVER_GUILE
+-extern unsigned scheme_gc_interval;
+ extern u_int scheme_task_timeout;
+ #endif
+ #ifdef USE_SNMP
+diff -Nru radius-1.4.orig/radiusd/log.c radius-1.4/radiusd/log.c
+--- radius-1.4.orig/radiusd/log.c 2006-08-17 00:15:57.000000000 +0300
++++ radius-1.4/radiusd/log.c 2006-11-27 19:14:32.715040847 +0200
+@@ -184,7 +184,7 @@
+ if (rewrite_invoke(String,
+ &val,
+ hook_name,
+- req,
++ (grad_request_t *)req,
+ "isi",
+ req->code,
+ grad_nas_request_to_name(req,
diff --git a/net-dialup/gnuradius/gnuradius-1.4.ebuild b/net-dialup/gnuradius/gnuradius-1.4.ebuild
new file mode 100644
index 000000000000..77b552f0c0a9
--- /dev/null
+++ b/net-dialup/gnuradius/gnuradius-1.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gnuradius/gnuradius-1.4.ebuild,v 1.1 2006/11/27 18:17:45 mrness Exp $
+
+inherit libtool eutils
+
+MY_P="${P#gnu}"
+
+DESCRIPTION="GNU radius authentication server"
+HOMEPAGE="http://www.gnu.org/software/radius/radius.html"
+SRC_URI="mirror://gnu/radius/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="guile mysql postgres odbc dbm nls snmp pam static debug readline"
+
+DEPEND="!net-dialup/freeradius
+ !net-dialup/cistronradius
+ guile? ( >=dev-util/guile-1.4 )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
+ readline? ( sys-libs/readline )
+ dbm? ( sys-libs/gdbm )
+ snmp? ( net-analyzer/net-snmp )
+ pam? ( sys-libs/pam )"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+}
+
+src_compile() {
+ elibtoolize --reverse-deps
+
+ local myconf="--enable-client \
+ `use_with guile` \
+ `use_with guile server-guile` \
+ `use_with mysql` \
+ `use_with postgres` \
+ `use_with odbc` \
+ `use_with readline` \
+ `use_enable dbm` \
+ `use_enable nls` \
+ `use_enable snmp` \
+ `use_enable pam` \
+ `use_enable debug` \
+ `use_enable static` "
+
+ econf ${myconf} || die "configuration failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "installation failed"
+}