summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-04-14 11:46:01 +0000
committerAlin Năstac <mrness@gentoo.org>2007-04-14 11:46:01 +0000
commit4479b18e13e017bf6ae553d6328ca3ae997108d7 (patch)
tree63f0ba41310505a42f5969a4d5ced26f1f641ce7 /net-dialup/lrzsz
parentamd64 (diff)
downloadgentoo-2-4479b18e13e017bf6ae553d6328ca3ae997108d7.tar.gz
gentoo-2-4479b18e13e017bf6ae553d6328ca3ae997108d7.tar.bz2
gentoo-2-4479b18e13e017bf6ae553d6328ca3ae997108d7.zip
Fix implicit declaration warnings
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-dialup/lrzsz')
-rw-r--r--net-dialup/lrzsz/ChangeLog8
-rw-r--r--net-dialup/lrzsz/files/lrzsz-implicit-decl.patch22
-rw-r--r--net-dialup/lrzsz/lrzsz-0.12.20-r1.ebuild5
3 files changed, 31 insertions, 4 deletions
diff --git a/net-dialup/lrzsz/ChangeLog b/net-dialup/lrzsz/ChangeLog
index c60aa28afd11..1144b7ff45a3 100644
--- a/net-dialup/lrzsz/ChangeLog
+++ b/net-dialup/lrzsz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/lrzsz
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/lrzsz/ChangeLog,v 1.6 2006/07/08 23:27:12 kumba Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/lrzsz/ChangeLog,v 1.7 2007/04/14 11:46:01 mrness Exp $
+
+ 14 Apr 2007; Alin Năstac <mrness@gentoo.org>
+ +files/lrzsz-implicit-decl.patch, lrzsz-0.12.20-r1.ebuild:
+ Fix implicit declaration warnings.
09 Jul 2006; Joshua Kinard <kumba@gentoo.org> lrzsz-0.12.20-r1.ebuild:
Marked stable on mips.
diff --git a/net-dialup/lrzsz/files/lrzsz-implicit-decl.patch b/net-dialup/lrzsz/files/lrzsz-implicit-decl.patch
new file mode 100644
index 000000000000..315f2e4f0e28
--- /dev/null
+++ b/net-dialup/lrzsz/files/lrzsz-implicit-decl.patch
@@ -0,0 +1,22 @@
+diff -Nru lrzsz-0.12.20.orig/lib/long-options.c lrzsz-0.12.20/lib/long-options.c
+--- lrzsz-0.12.20.orig/lib/long-options.c 1998-04-26 16:22:35.000000000 +0300
++++ lrzsz-0.12.20/lib/long-options.c 2007-04-14 14:42:34.000000000 +0300
+@@ -22,6 +22,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <getopt.h>
+ #include "long-options.h"
+
+diff -Nru lrzsz-0.12.20.orig/src/lsyslog.c lrzsz-0.12.20/src/lsyslog.c
+--- lrzsz-0.12.20.orig/src/lsyslog.c 1998-12-29 19:27:46.000000000 +0200
++++ lrzsz-0.12.20/src/lsyslog.c 2007-04-14 14:43:10.000000000 +0300
+@@ -22,6 +22,7 @@
+ #ifdef ENABLE_SYSLOG
+ #include "zglobal.h"
+ #include <pwd.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #endif
diff --git a/net-dialup/lrzsz/lrzsz-0.12.20-r1.ebuild b/net-dialup/lrzsz/lrzsz-0.12.20-r1.ebuild
index 5a54447b0616..1aed0062a91c 100644
--- a/net-dialup/lrzsz/lrzsz-0.12.20-r1.ebuild
+++ b/net-dialup/lrzsz/lrzsz-0.12.20-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/lrzsz/lrzsz-0.12.20-r1.ebuild,v 1.8 2006/09/16 21:09:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/lrzsz/lrzsz-0.12.20-r1.ebuild,v 1.9 2007/04/14 11:46:01 mrness Exp $
inherit flag-o-matic eutils
@@ -16,6 +16,7 @@ IUSE="nls"
src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${PN}-makefile-smp.patch
+ epatch "${FILESDIR}"/${PN}-implicit-decl.patch
}
src_compile() {