summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-05-12 21:25:14 +0000
committerAlin Năstac <mrness@gentoo.org>2006-05-12 21:25:14 +0000
commitc3ee31ef54c3829e51a68ec2816d7851cfa9622e (patch)
tree19e4680d5570c85a74ad7c917c30687b8d0ec159 /net-dialup/pptpd/files
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-c3ee31ef54c3829e51a68ec2816d7851cfa9622e.tar.gz
gentoo-2-c3ee31ef54c3829e51a68ec2816d7851cfa9622e.tar.bz2
gentoo-2-c3ee31ef54c3829e51a68ec2816d7851cfa9622e.zip
Version bump. Fix segfault when -C option is specified on command line (#132898).
(Portage version: 2203-svn)
Diffstat (limited to 'net-dialup/pptpd/files')
-rw-r--r--net-dialup/pptpd/files/digest-pptpd-1.3.21
-rw-r--r--net-dialup/pptpd/files/pptpd-1.3.2-connections-arg.patch15
-rw-r--r--net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch51
3 files changed, 67 insertions, 0 deletions
diff --git a/net-dialup/pptpd/files/digest-pptpd-1.3.2 b/net-dialup/pptpd/files/digest-pptpd-1.3.2
new file mode 100644
index 000000000000..6d47c06bd69d
--- /dev/null
+++ b/net-dialup/pptpd/files/digest-pptpd-1.3.2
@@ -0,0 +1 @@
+MD5 4e4eb2fd2d96cb86b88d18318b3108dc pptpd-1.3.2.tar.gz 235467
diff --git a/net-dialup/pptpd/files/pptpd-1.3.2-connections-arg.patch b/net-dialup/pptpd/files/pptpd-1.3.2-connections-arg.patch
new file mode 100644
index 000000000000..ab5920566a05
--- /dev/null
+++ b/net-dialup/pptpd/files/pptpd-1.3.2-connections-arg.patch
@@ -0,0 +1,15 @@
+diff -Nru pptpd-1.3.2.orig/pptpd.c pptpd-1.3.2/pptpd.c
+--- pptpd-1.3.2.orig/pptpd.c 2005-12-29 11:59:49.000000000 +0200
++++ pptpd-1.3.2/pptpd.c 2006-05-12 23:44:15.000000000 +0300
+@@ -149,9 +149,9 @@
+ while (1) {
+ int option_index = 0;
+ #ifdef BCRELAY
+- char *optstring = "b:c:de:fhil:o:p:s:t:vwCD";
++ char *optstring = "b:c:de:fhil:o:p:s:t:vwC:D";
+ #else
+- char *optstring = "c:de:fhil:o:p:s:t:vwCD";
++ char *optstring = "c:de:fhil:o:p:s:t:vwC:D";
+ #endif
+
+ static struct option long_options[] =
diff --git a/net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch b/net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch
new file mode 100644
index 000000000000..c2359d9bf15d
--- /dev/null
+++ b/net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch
@@ -0,0 +1,51 @@
+diff -Nru pptpd-1.3.2.orig/Makefile.am pptpd-1.3.2/Makefile.am
+--- pptpd-1.3.2.orig/Makefile.am 2006-04-18 06:22:17.000000000 +0300
++++ pptpd-1.3.2/Makefile.am 2006-05-13 00:01:40.666690750 +0300
+@@ -11,7 +11,7 @@
+ ## warning with -Wmissing-prototypes).
+ ## -Wmissing-prototypes removed (eg, Linux 2.2.6 headers
+ ## aren't up to it).
+-CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
++CFLAGS += -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
+ #CFLAGS = -O2 -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"'
+ #CFLAGS = -O2 -fno-builtin -Wall -ansi -pedantic -Wmissing-prototypes -Werror -DSBINDIR='"$(sbindir)"'
+
+diff -Nru pptpd-1.3.2.orig/plugins/Makefile pptpd-1.3.2/plugins/Makefile
+--- pptpd-1.3.2.orig/plugins/Makefile 2004-05-21 12:26:37.000000000 +0300
++++ pptpd-1.3.2/plugins/Makefile 2006-05-13 00:01:40.666690750 +0300
+@@ -1,6 +1,5 @@
+ CC = gcc
+-COPTS = -O2 -g
+-CFLAGS = $(COPTS) -I.. -I../../include -fPIC
++CFLAGS += -I.. -I../../include -fPIC
+ LDFLAGS = -shared
+ INSTALL = install -o root
+ prefix = /usr/local
+diff -Nru pptpd-1.3.2.orig/pptpgre.c pptpd-1.3.2/pptpgre.c
+--- pptpd-1.3.2.orig/pptpgre.c 2006-03-28 00:39:05.000000000 +0300
++++ pptpd-1.3.2/pptpgre.c 2006-05-13 00:05:12.462064250 +0300
+@@ -405,9 +405,9 @@
+ }
+ /* check for out-of-order sequence number */
+ if (seq_greater(seq, gre.seq_recv)) {
+- if (pptpctrl_debug)
++ /* if (pptpctrl_debug)
+ syslog(LOG_DEBUG, "GRE: accepting packet #%d",
+- seq);
++ seq); */
+ stats.rx_accepted++;
+ gre.seq_recv = seq;
+ return cb(cl, buffer + ip_len + headersize, payload_len);
+diff -Nru pptpd-1.3.2.orig/pqueue.c pptpd-1.3.2/pqueue.c
+--- pptpd-1.3.2.orig/pqueue.c 2005-08-03 11:53:22.000000000 +0300
++++ pptpd-1.3.2/pqueue.c 2006-05-13 00:01:40.666690750 +0300
+@@ -12,7 +12,8 @@
+ #define DEBUG_ON 0
+ #endif
+
+-#define DEBUG_CMD(_a) if (DEBUG_ON) { _a }
++/* #define DEBUG_CMD(_a) if (DEBUG_ON) { _a } */
++#define DEBUG_CMD(_a)
+
+ #define MIN_CAPACITY 128 /* min allocated buffer for a packet */
+