summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-02-05 17:25:05 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-02-05 17:25:05 +0000
commitd08f3298e7b04c89ad55d308c7f6f8518fcdb38f (patch)
tree46a160aa63a770dfe61e08362877a8f0cffda9d1 /net-dns/dnsmasq
parentVersion bump (diff)
downloadgentoo-2-d08f3298e7b04c89ad55d308c7f6f8518fcdb38f.tar.gz
gentoo-2-d08f3298e7b04c89ad55d308c7f6f8518fcdb38f.tar.bz2
gentoo-2-d08f3298e7b04c89ad55d308c7f6f8518fcdb38f.zip
Version bump.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/ChangeLog7
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.37.ebuild59
-rw-r--r--net-dns/dnsmasq/files/digest-dnsmasq-2.373
3 files changed, 68 insertions, 1 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 32e13f3defbf..ec7031a2a7e1 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.109 2007/01/26 03:56:26 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.110 2007/02/05 17:25:05 chutzpah Exp $
+
+*dnsmasq-2.37 (05 Feb 2007)
+
+ 05 Feb 2007; Patrick McLean <chutzpah@gentoo.org> +dnsmasq-2.37.ebuild:
+ Version bump.
26 Jan 2007; Patrick McLean <chutzpah@gentoo.org> dnsmasq-2.36.ebuild:
Add isc "USE" flag (bug #152876).
diff --git a/net-dns/dnsmasq/dnsmasq-2.37.ebuild b/net-dns/dnsmasq/dnsmasq-2.37.ebuild
new file mode 100644
index 000000000000..74b700b11cbf
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.37.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.37.ebuild,v 1.1 2007/02/05 17:25:05 chutzpah Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus isc resolvconf tftp"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51
+ dbus? ( sys-apps/dbus )
+ resolvconf? ( net-dns/resolvconf-gentoo )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-fbsd-config.patch"
+}
+
+src_compile() {
+ use tftp || append-flags -DNO_TFTP
+ use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h
+ use isc && sed -i '$ a #define HAVE_ISC_READER' src/config.h
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ make \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install || die
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use resolvconf ; then
+ exeinto /etc/resolvconf/update.d
+ newexe ${FILESDIR}/resolvconf.dnsmasq dnsmasq
+ fi
+}
diff --git a/net-dns/dnsmasq/files/digest-dnsmasq-2.37 b/net-dns/dnsmasq/files/digest-dnsmasq-2.37
new file mode 100644
index 000000000000..4458920232fd
--- /dev/null
+++ b/net-dns/dnsmasq/files/digest-dnsmasq-2.37
@@ -0,0 +1,3 @@
+MD5 e105a41cdf5adb8b615f0a06eb17ecb9 dnsmasq-2.37.tar.gz 271316
+RMD160 0561e4876c397ac80587a5f20a821ff0776c23cb dnsmasq-2.37.tar.gz 271316
+SHA256 6ddf6be81d5974a2cbe4c9c3b130e5b746c6415165b1d82ad390150ecd614385 dnsmasq-2.37.tar.gz 271316