summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-08-27 17:03:58 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-08-27 17:03:58 +0000
commit125e752768d8f9e9f5d1ddc38913463296818da2 (patch)
treec4c4d87a9e7ae7c44d674a271971288f4f1749f1 /net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
parentbumped EAPI to 5 ; committed direct to stable as there are no other changes a... (diff)
downloadgentoo-2-125e752768d8f9e9f5d1ddc38913463296818da2.tar.gz
gentoo-2-125e752768d8f9e9f5d1ddc38913463296818da2.tar.bz2
gentoo-2-125e752768d8f9e9f5d1ddc38913463296818da2.zip
bumped EAPI to 5 to support upgrades of dev-lang/perl when inheriting perl-module ; bumped EAPI to 4 to avoid deprecated EAPI otherwise.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild')
-rw-r--r--net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild b/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
new file mode 100644
index 000000000000..0bd2c37257f3
--- /dev/null
+++ b/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild,v 1.1 2014/08/27 17:03:58 axs Exp $
+
+EAPI=5
+
+inherit eutils perl-module
+
+DESCRIPTION="Fingerprinting DNS servers"
+HOMEPAGE="https://github.com/kirei/fpdns/"
+
+MY_P="${PN}-${PV##*_pre}"
+SRC_URI="https://github.com/kirei/fpdns/archive/20130404.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-perl/Net-DNS-0.74"
+
+S="${WORKDIR}"/"${MY_P}"
+
+src_prepare() {
+ ## fixes https://github.com/kirei/fpdns/issues/6
+ epatch "${FILESDIR}/${P}.ro-header.patch"
+}
+
+src_install() {
+ newbin apps/fpdns fpdns
+ insinto "${VENDOR_LIB}"/Net/DNS/
+ doins lib/Net/DNS/Fingerprint.pm
+}