summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2011-07-30 09:59:11 +0000
committerSven Wegener <swegener@gentoo.org>2011-07-30 09:59:11 +0000
commit5e3ea51a7619f57402a957dc1409b97e0f27c5f7 (patch)
tree92b5691772184b623106d9ccb6ae9ad0c4a708f5 /net-dns
parentBump, remove old (diff)
downloadgentoo-2-5e3ea51a7619f57402a957dc1409b97e0f27c5f7.tar.gz
gentoo-2-5e3ea51a7619f57402a957dc1409b97e0f27c5f7.tar.bz2
gentoo-2-5e3ea51a7619f57402a957dc1409b97e0f27c5f7.zip
Require newer boost and completely disable lua support for now.
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/ChangeLog6
-rw-r--r--net-dns/pdns/files/pdns-3.0-lua-config.patch25
-rw-r--r--net-dns/pdns/pdns-3.0.ebuild13
3 files changed, 40 insertions, 4 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
index 15e638557b2f..1e77870ca250 100644
--- a/net-dns/pdns/ChangeLog
+++ b/net-dns/pdns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/pdns
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.67 2011/07/23 22:26:16 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.68 2011/07/30 09:59:10 swegener Exp $
+
+ 30 Jul 2011; Sven Wegener <swegener@gentoo.org> pdns-3.0.ebuild,
+ +files/pdns-3.0-lua-config.patch:
+ Require newer boost and completely disable lua support for now.
*pdns-3.0 (23 Jul 2011)
diff --git a/net-dns/pdns/files/pdns-3.0-lua-config.patch b/net-dns/pdns/files/pdns-3.0-lua-config.patch
new file mode 100644
index 000000000000..86e0b434777f
--- /dev/null
+++ b/net-dns/pdns/files/pdns-3.0-lua-config.patch
@@ -0,0 +1,25 @@
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 2250)
++++ configure.ac (working copy)
+@@ -26,7 +26,7 @@
+
+ dnl Check for lua
+ AC_MSG_CHECKING(if with lua)
+-AC_ARG_WITH(lua, AC_HELP_STRING([--with-lua],[lua]), WITH_LUA=$withval],[WITH_LUA=yes])
++AC_ARG_WITH(lua, AC_HELP_STRING([--with-lua],[lua]), [WITH_LUA=$withval],[WITH_LUA=yes])
+
+ AC_MSG_RESULT($WITH_LUA)
+ if test "$WITH_LUA" != "no"; then
+Index: pdns/lua-pdns-recursor.cc
+===================================================================
+--- pdns/lua-pdns-recursor.cc (revision 2250)
++++ pdns/lua-pdns-recursor.cc (working copy)
+@@ -1,6 +1,6 @@
+ #include "lua-pdns-recursor.hh"
+
+-#if !defined(PDNS_ENABLE_LUA) && !defined(LIBDIR)
++#if !defined(HAVE_LUA) || !defined(LIBDIR)
+
+ // stub implementation
+
diff --git a/net-dns/pdns/pdns-3.0.ebuild b/net-dns/pdns/pdns-3.0.ebuild
index 2185b184c6cb..e17449fbb97e 100644
--- a/net-dns/pdns/pdns-3.0.ebuild
+++ b/net-dns/pdns/pdns-3.0.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-3.0.ebuild,v 1.1 2011/07/23 22:26:16 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-3.0.ebuild,v 1.2 2011/07/30 09:59:10 swegener Exp $
EAPI=2
-inherit eutils multilib
+
+inherit eutils multilib autotools
DESCRIPTION="The PowerDNS Daemon"
SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
@@ -20,10 +21,15 @@ RDEPEND="mysql? ( virtual/mysql )
sqlite? ( =dev-db/sqlite-2.8* )
sqlite3? ( =dev-db/sqlite-3* )
opendbx? ( dev-db/opendbx )
- >=dev-libs/boost-1.31"
+ >=dev-libs/boost-1.34"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-lua-config.patch
+ eautoreconf
+}
+
src_configure() {
local modules="pipe geo" myconf=""
@@ -45,6 +51,7 @@ src_configure() {
--with-pgsql-lib=/usr/$(get_libdir) \
--with-mysql-lib=/usr/$(get_libdir) \
--with-sqlite-lib=/usr/$(get_libdir) \
+ --without-lua \
$(use_enable static static-binaries) \
${myconf} \
|| die "econf failed"