summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-07-08 17:08:53 +0000
committerMichael Weber <xmw@gentoo.org>2013-07-08 17:08:53 +0000
commit979d1c97253da0e0ed3868b1cb0849add832fa1c (patch)
treea969daf4d69ba659f5a8050af3b6ea8ad9cc088c /net-dns
parentDrop boost-1.53 mask, bug #474876. (diff)
downloadgentoo-2-979d1c97253da0e0ed3868b1cb0849add832fa1c.tar.gz
gentoo-2-979d1c97253da0e0ed3868b1cb0849add832fa1c.tar.bz2
gentoo-2-979d1c97253da0e0ed3868b1cb0849add832fa1c.zip
Version bump by Michael Orlitzky (bug 475348).
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/rbldnsd/ChangeLog8
-rw-r--r--net-dns/rbldnsd/files/confd-0.99721
-rw-r--r--net-dns/rbldnsd/files/initd-0.99729
-rw-r--r--net-dns/rbldnsd/rbldnsd-0.997.ebuild60
4 files changed, 117 insertions, 1 deletions
diff --git a/net-dns/rbldnsd/ChangeLog b/net-dns/rbldnsd/ChangeLog
index b38ed4c987d7..880aa6a86334 100644
--- a/net-dns/rbldnsd/ChangeLog
+++ b/net-dns/rbldnsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/rbldnsd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/ChangeLog,v 1.22 2013/06/02 10:59:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/ChangeLog,v 1.23 2013/07/08 17:08:53 xmw Exp $
+
+*rbldnsd-0.997 (08 Jul 2013)
+
+ 08 Jul 2013; Michael Weber <xmw@gentoo.org> +files/confd-0.997,
+ +files/initd-0.997, +rbldnsd-0.997.ebuild:
+ Version bump by Michael Orlitzky (bug 475348).
02 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #328951
diff --git a/net-dns/rbldnsd/files/confd-0.997 b/net-dns/rbldnsd/files/confd-0.997
new file mode 100644
index 000000000000..f20b3acdcf53
--- /dev/null
+++ b/net-dns/rbldnsd/files/confd-0.997
@@ -0,0 +1,21 @@
+# The addresses on which to listen, as a bash array. The syntax is
+# "host:port", where the port defaults to 53.
+LISTEN=( "127.0.0.1" "192.168.0.1" )
+
+# A list of RBL zones, as a bash array. For the correct syntax, please
+# see the rbldnsd(8) man page. The following $ZONES will look for
+# files named "badguys.example.com" and "spammers.example.net" (in the
+# appropriate format) under /var/db/rbldnsd, and use those same names
+# for the blacklists contained therein.
+ZONES=( "badguys.example.com:ip4set:badguys.example.com"
+ "spammers.example.net:ip4tset:spammers.example.net" )
+
+# Add any additional options for the rbldnsd daemon below. The -a and
+# -vv below are suggested for performance/security reasons. They are
+# described in the man page.
+#
+# The rootdir (-r) and PID (-p) options are passed automatically, with
+# rootdir set to /var/db/rbldnsd (where you should put your zone
+# files). The daemon will run as the rbldns user, which was created by
+# portage.
+OPTIONS="-a -vv"
diff --git a/net-dns/rbldnsd/files/initd-0.997 b/net-dns/rbldnsd/files/initd-0.997
new file mode 100644
index 000000000000..272b1903a06f
--- /dev/null
+++ b/net-dns/rbldnsd/files/initd-0.997
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/files/initd-0.997,v 1.1 2013/07/08 17:08:52 xmw Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting rbldnsd"
+
+ start-stop-daemon --start --quiet --pidfile /run/rbldnsd.pid \
+ --exec /usr/sbin/rbldnsd -- \
+ -r /var/db/rbldnsd \
+ -p /run/rbldnsd.pid \
+ ${LISTEN[@]/#/-b} \
+ ${OPTIONS} \
+ "${ZONES[@]}"
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rbldnsd"
+ start-stop-daemon --stop --quiet --pidfile /run/rbldnsd.pid \
+ --exec /usr/sbin/rbldnsd
+ eend $?
+}
diff --git a/net-dns/rbldnsd/rbldnsd-0.997.ebuild b/net-dns/rbldnsd/rbldnsd-0.997.ebuild
new file mode 100644
index 000000000000..c15195774b99
--- /dev/null
+++ b/net-dns/rbldnsd/rbldnsd-0.997.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/rbldnsd-0.997.ebuild,v 1.1 2013/07/08 17:08:53 xmw Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit eutils toolchain-funcs user python-single-r1
+
+DESCRIPTION="DNS server designed to serve blacklist zones"
+HOMEPAGE="http://www.corpit.ru/mjt/rbldnsd.html"
+SRC_URI="http://www.corpit.ru/mjt/rbldnsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 test zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS}
+ dev-python/pydns:2[${PYTHON_USEDEP}] )"
+
+src_configure() {
+ # The ./configure file is handwritten and doesn't support a `make
+ # install` target, so there are no --prefix options. The econf
+ # function appends those automatically, so we can't use it.
+ ./configure \
+ $(use_enable ipv6) \
+ $(use_enable zlib) \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
+src_test() {
+ emake check \
+ CC="$(tc-getCC)" \
+ PYTHON="${PYTHON}"
+}
+
+src_install() {
+ dosbin rbldnsd
+ doman rbldnsd.8
+ keepdir /var/db/rbldnsd
+ dodoc CHANGES* TODO NEWS README*
+ newinitd "${FILESDIR}"/initd-${PV} rbldnsd
+ newconfd "${FILESDIR}"/confd-${PV} rbldnsd
+}
+
+pkg_postinst() {
+ enewgroup rbldns
+ enewuser rbldns -1 -1 /var/db/rbldnsd rbldns
+ chown rbldns:rbldns /var/db/rbldnsd
+}