summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-04-03 17:34:47 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-04-03 17:34:47 +0000
commitcbe2bda75857ef3a25c58238c1cb21c19625118f (patch)
tree6a1015e1d496dd5fdfc071c3f8119608aed67082 /net-dns
parentRemove older. Use prune_libtool_files. (diff)
downloadgentoo-2-cbe2bda75857ef3a25c58238c1cb21c19625118f.tar.gz
gentoo-2-cbe2bda75857ef3a25c58238c1cb21c19625118f.tar.bz2
gentoo-2-cbe2bda75857ef3a25c58238c1cb21c19625118f.zip
Version bump to latest.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/ChangeLog7
-rw-r--r--net-dns/knot/knot-1.2.0.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-dns/knot/ChangeLog b/net-dns/knot/ChangeLog
index 32e4996e3481..1cfcb9dbb8ff 100644
--- a/net-dns/knot/ChangeLog
+++ b/net-dns/knot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/knot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.17 2013/01/04 13:27:28 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.18 2013/04/03 17:34:47 scarabeus Exp $
+
+*knot-1.2.0 (03 Apr 2013)
+
+ 03 Apr 2013; Tomáš Chvátal <scarabeus@gentoo.org> +knot-1.2.0.ebuild:
+ Version bump to latest.
04 Jan 2013; Tomáš Chvátal <scarabeus@gentoo.org> knot-1.1.3.ebuild:
We can actually be eapi5.
diff --git a/net-dns/knot/knot-1.2.0.ebuild b/net-dns/knot/knot-1.2.0.ebuild
new file mode 100644
index 000000000000..ec131f71a87a
--- /dev/null
+++ b/net-dns/knot/knot-1.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/knot-1.2.0.ebuild,v 1.1 2013/04/03 17:34:46 scarabeus Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="http://www.knot-dns.cz/"
+SRC_URI="http://public.nic.cz/files/knot-dns/${P/_/-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/openssl
+ dev-libs/userspace-rcu
+"
+# sys-libs/glibc
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ virtual/yacc
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-move-pidfile-to-var.patch
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --libexecdir="${EPREFIX}/usr/libexec/${PN}" \
+ --disable-lto \
+ --enable-recvmmsg \
+ $(use_enable debug debug server,zones,xfr,packet,dname,rr,ns,hash,compiler) \
+ $(use_enable debug debuglevel details)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/knot.init" knot-dns
+}
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]] ; then
+ elog "Remember to recompile all zones after update. Run:"
+ elog " # knotc stop"
+ elog " # knotc compile"
+ elog " # knotc start"
+ fi
+}