summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-12-29 07:27:25 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-12-29 07:27:25 +0000
commitfee45c5ed712d250ed56460ba12d824822c6ab1a (patch)
tree46515f4586e240b5c327e13649858494f96387c8 /net-dns
parentVersion bump (diff)
downloadgentoo-2-fee45c5ed712d250ed56460ba12d824822c6ab1a.tar.gz
gentoo-2-fee45c5ed712d250ed56460ba12d824822c6ab1a.tar.bz2
gentoo-2-fee45c5ed712d250ed56460ba12d824822c6ab1a.zip
Removed dependency on openrc (bug #533820). Removed old version. Let the ebuild create the cachedir if it's not already available
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdnsd/ChangeLog7
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild15
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.9a.ebuild119
3 files changed, 19 insertions, 122 deletions
diff --git a/net-dns/pdnsd/ChangeLog b/net-dns/pdnsd/ChangeLog
index 26f02f4ae588..ddd3fbca1176 100644
--- a/net-dns/pdnsd/ChangeLog
+++ b/net-dns/pdnsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/pdnsd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.125 2014/05/03 20:34:27 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.126 2014/12/29 07:27:25 polynomial-c Exp $
+
+ 29 Dec 2014; Lars Wendler <polynomial-c@gentoo.org> -pdnsd-1.2.9a.ebuild,
+ pdnsd-1.2.9a-r1.ebuild:
+ Removed dependency on openrc (bug #533820). Removed old version. Let the
+ ebuild create the cachedir if it's not already available.
03 May 2014; Mikle Kolyada <zlogene@gentoo.org> pdnsd-1.2.9a-r1.ebuild:
alpha/arm/ia64/ppc/sparc stable wrt bug #509380
diff --git a/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild b/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild
index d1104c13d283..2406ab821fc0 100644
--- a/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild,v 1.3 2014/05/03 20:34:27 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.9a-r1.ebuild,v 1.4 2014/12/29 07:27:25 polynomial-c Exp $
EAPI=5
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc ~s390 sparc x86"
IUSE="debug ipv6 isdn +urandom test"
-RDEPEND="sys-apps/openrc"
+RDEPEND=""
DEPEND="test? ( net-dns/bind-tools )"
pkg_setup() {
@@ -118,4 +118,15 @@ pkg_postinst() {
elog "The online interface will be listed in /etc/conf.d/pdnsd-online"
elog ""
elog "Sample config file in /etc/pdnsd/pdnsd.conf.sample"
+
+ # The tmpfiles.d configuration does not come into effect before the
+ # next reboot so create the cachedir now.
+ local cachedir="/var/cache/pdnsd"
+ if [[ ! -d ${cachedir} ]] ; then
+ mkdir ${cachedir} || eerror "Failed to create cache"
+ fi
+ chown pdnsd:pdnsd ${cachedir} \
+ || eerror "Failed to set ownership for cachedir"
+ chmod 0750 ${cachedir} \
+ || eerror "Failed to set permissions for cachedir"
}
diff --git a/net-dns/pdnsd/pdnsd-1.2.9a.ebuild b/net-dns/pdnsd/pdnsd-1.2.9a.ebuild
deleted file mode 100644
index d1327ad3eb80..000000000000
--- a/net-dns/pdnsd/pdnsd-1.2.9a.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.9a.ebuild,v 1.10 2014/01/18 19:53:50 ago Exp $
-
-EAPI=5
-
-inherit user
-
-DESCRIPTION="Proxy DNS server with permanent caching"
-HOMEPAGE="http://members.home.nl/p.a.rombouts/pdnsd/"
-SRC_URI="http://members.home.nl/p.a.rombouts/pdnsd/releases/${P}-par.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ~s390 sparc x86"
-IUSE="debug ipv6 isdn +urandom test"
-
-RDEPEND="sys-apps/openrc"
-DEPEND="test? ( net-dns/bind-tools )"
-
-pkg_setup() {
- enewgroup pdnsd
- enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
-}
-
-src_configure() {
- local myconf=""
- use debug && myconf="${myconf} --with-debug=3"
- use urandom && myconf="${myconf} --with-random-device=/dev/urandom"
-
- econf \
- --disable-dependency-tracking \
- --sysconfdir=/etc/pdnsd \
- --with-cachedir=/var/cache/pdnsd \
- --with-default-id=pdnsd \
- $(use_enable ipv6) $(use_enable ipv6 ipv6-startup) \
- $(use_enable isdn) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO README.par
- docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
- docinto html ; dohtml doc/html/*
- docinto txt ; dodoc doc/txt/*
- newdoc doc/pdnsd.conf pdnsd.conf.sample
-
- newinitd "${FILESDIR}/pdnsd.rc7" pdnsd
- newinitd "${FILESDIR}/pdnsd.online.2" pdnsd-online
-
- mkdir "${T}"/confd || die
-
- cat - > "${T}"/confd/pdnsd-online <<EOF
-# Make sure to change the rc_need variable to the service for the
-# interface that connects you to the dns servers.
-#
-# For instance if you use a PPP connection on ppp0 to connect, set
-# rc_need="net.ppp0"
-
-rc_need="net.lo"
-EOF
-
- # Don't try to do the smart thing and add the --help output here:
- # it will cause the file to be etc-updated if the help text
- # changes and fails when cross-compiling.
- cat - > "${T}"/confd/pdnsd <<EOF
-# Command line options, check pdnsd --help for a list of valid
-# parameters. Note that most of the options that can be given at
-# command-line are also available as configuration parameters in
-# /etc/pdnsd/pdnsd.conf
-PDNSDCONFIG=""
-EOF
-
- doconfd "${T}"/confd/*
-
- # gentoo resolvconf support
- exeinto /etc/resolvconf/update.d
- newexe "${FILESDIR}/pdnsd.resolvconf-r1" pdnsd
-}
-
-src_test() {
- fail_kill() {
- kill -9 $(<"${T}"/pid)
- die "$1"
- }
-
- mkdir "${T}/pdnsd" || die
- echo -n -e "pd12\0\0\0\0" > "${T}/pdnsd/pdnsd.cache"
- IPS=$(grep ^nameserver /etc/resolv.conf | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
- sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \
- > "${T}/pdnsd.conf.test"
- src/pdnsd -c "${T}/pdnsd.conf.test" -g -s -d -p "${T}/pid" || die "couldn't start daemon"
- sleep 3
-
- find "${T}" -ls
- [ -s "${T}/pid" ] || die "empty or no pid file created"
- [ -S "${T}/pdnsd/pdnsd.status" ] || fail_kill "no socket created"
- src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" server all up || fail_kill "failed to start the daemon"
- src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" status || fail_kill "failed to communicate with the daemon"
- sleep 3
-
- dig @127.0.0.1 -p 33455 localhost > "${T}"/dig.output 2>&1
- cat "${T}"/dig.output || die
- fgrep -q "status: NOERROR" "${T}"/dig.output || fail_kill "www.gentoo.org lookup failed"
-
- kill $(<"${T}/pid") || fail_kill "failed to terminate daemon"
-}
-
-pkg_postinst() {
- elog
- elog "Add pdnsd to your default runlevel - rc-update add pdnsd default"
- elog ""
- elog "Add pdnsd-online to your online runlevel."
- elog "The online interface will be listed in /etc/conf.d/pdnsd-online"
- elog ""
- elog "Sample config file in /etc/pdnsd/pdnsd.conf.sample"
-}