summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-09-15 13:51:39 +0000
committerPeter Volkov <pva@gentoo.org>2010-09-15 13:51:39 +0000
commitb1ee403ce6be7cfdccd6da9ebfa50ab64c406d82 (patch)
treef8a222d3ddf5734832719cd514e148b35db8febd /net-firewall/arptables
parentVersion bump (diff)
downloadgentoo-2-b1ee403ce6be7cfdccd6da9ebfa50ab64c406d82.tar.gz
gentoo-2-b1ee403ce6be7cfdccd6da9ebfa50ab64c406d82.tar.bz2
gentoo-2-b1ee403ce6be7cfdccd6da9ebfa50ab64c406d82.zip
Respect LDFLAGS, bug #335375, thank Diego E. 'Flameeyes' Pettenò for report.
(Portage version: 2.1.9.5/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/arptables')
-rw-r--r--net-firewall/arptables/ChangeLog9
-rw-r--r--net-firewall/arptables/arptables-0.0.3.4-r1.ebuild36
-rw-r--r--net-firewall/arptables/files/arptables-0.0.3.4-ldflags.patch13
3 files changed, 57 insertions, 1 deletions
diff --git a/net-firewall/arptables/ChangeLog b/net-firewall/arptables/ChangeLog
index 20f86d4c03fa..e3bb042796ca 100644
--- a/net-firewall/arptables/ChangeLog
+++ b/net-firewall/arptables/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/arptables
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/arptables/ChangeLog,v 1.15 2010/03/16 07:57:29 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/arptables/ChangeLog,v 1.16 2010/09/15 13:51:39 pva Exp $
+
+*arptables-0.0.3.4-r1 (15 Sep 2010)
+
+ 15 Sep 2010; Peter Volkov <pva@gentoo.org> +arptables-0.0.3.4-r1.ebuild,
+ +files/arptables-0.0.3.4-ldflags.patch:
+ Respect LDFLAGS, bug #335375, thank Diego E. 'Flameeyes' Pettenò for
+ report.
*arptables-0.0.3.4 (16 Mar 2010)
diff --git a/net-firewall/arptables/arptables-0.0.3.4-r1.ebuild b/net-firewall/arptables/arptables-0.0.3.4-r1.ebuild
new file mode 100644
index 000000000000..bf0cf3584d8d
--- /dev/null
+++ b/net-firewall/arptables/arptables-0.0.3.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/arptables/arptables-0.0.3.4-r1.ebuild,v 1.1 2010/09/15 13:51:39 pva Exp $
+
+EAPI="2"
+inherit versionator eutils
+
+MY_P=${PN}-v$(replace_version_separator 3 - )
+
+DESCRIPTION="set up, maintain, and inspect the tables of ARP rules in the Linux kernel"
+HOMEPAGE="http://ebtables.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ebtables/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
+src_compile() {
+ # -O0 does not work and at least -O2 is required, bug #240752
+ emake CC="$(tc-getCC)" COPT_FLAGS="-O2 ${CFLAGS//-O0/-O2}" || die "make failed"
+ sed -ie 's:__EXEC_PATH__:/sbin:g' arptables-save arptables-restore \
+ || die "sed failed"
+}
+
+src_install() {
+ into /
+ dosbin arptables arptables-restore arptables-save || die
+ doman arptables.8 || die
+}
diff --git a/net-firewall/arptables/files/arptables-0.0.3.4-ldflags.patch b/net-firewall/arptables/files/arptables-0.0.3.4-ldflags.patch
new file mode 100644
index 000000000000..b5ced69c504b
--- /dev/null
+++ b/net-firewall/arptables/files/arptables-0.0.3.4-ldflags.patch
@@ -0,0 +1,13 @@
+=== modified file 'Makefile'
+--- Makefile 2010-09-15 11:51:49 +0000
++++ Makefile 2010-09-15 11:52:56 +0000
+@@ -31,7 +31,7 @@
+ $(CC) $(CFLAGS) -c -o $@ $<
+
+ arptables: arptables-standalone.o arptables.o libarptc/libarptc.o $(EXT_OBJS)
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ $(DESTDIR)$(MANDIR)/man8/arptables.8: arptables.8
+ mkdir -p $(@D)
+