summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-02-15 15:20:49 +0000
committerMarinus Schraal <foser@gentoo.org>2003-02-15 15:20:49 +0000
commit309d49f6914c077de9a70a2000c6185454c70113 (patch)
treea6159ebabc845d8ffe0fc579e402a6dac44e9005 /net-firewall/firestarter
parentsoribada is no longer used (diff)
downloadgentoo-2-309d49f6914c077de9a70a2000c6185454c70113.tar.gz
gentoo-2-309d49f6914c077de9a70a2000c6185454c70113.tar.bz2
gentoo-2-309d49f6914c077de9a70a2000c6185454c70113.zip
Added gcc2 compiling problems patch
Diffstat (limited to 'net-firewall/firestarter')
-rw-r--r--net-firewall/firestarter/ChangeLog5
-rw-r--r--net-firewall/firestarter/files/firestarter-0.9.1-gcc2_fixes.patch53
-rw-r--r--net-firewall/firestarter/firestarter-0.9.1.ebuild10
3 files changed, 66 insertions, 2 deletions
diff --git a/net-firewall/firestarter/ChangeLog b/net-firewall/firestarter/ChangeLog
index d9d67d8a1505..66264e8ff257 100644
--- a/net-firewall/firestarter/ChangeLog
+++ b/net-firewall/firestarter/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for net-firewall/firestarter
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Author: José Alberto Suárez López <bass@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/ChangeLog,v 1.3 2003/02/13 20:40:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/ChangeLog,v 1.4 2003/02/15 15:20:49 foser Exp $
*firestarter-0.9.1 (31 Jan 2003)
+ 15 Feb 2003; foser <foser@gentoo.org> firestarter-0.9.1.ebuild :
+ Added gcc2 fixes patch kindly provided by <michael.sterrett@coat.com> (#15461)
+
09 Feb 2003; Martin Holzer <mholzer@gentoo.org> :
Moved from net-misc to net-firewall
diff --git a/net-firewall/firestarter/files/firestarter-0.9.1-gcc2_fixes.patch b/net-firewall/firestarter/files/firestarter-0.9.1-gcc2_fixes.patch
new file mode 100644
index 000000000000..38c6e5bde8a5
--- /dev/null
+++ b/net-firewall/firestarter/files/firestarter-0.9.1-gcc2_fixes.patch
@@ -0,0 +1,53 @@
+--- firestarter.c.orig 2003-02-10 15:21:45.000000000 -0800
++++ firestarter.c 2003-02-10 15:20:25.000000000 -0800
+@@ -58,6 +58,7 @@
+ stop_firewall (void)
+ {
+ gint retval;
++ gchar *error;
+ gchar *sbin;
+ gchar *command = NULL;
+
+@@ -86,7 +87,7 @@
+ } else {
+ retval = WEXITSTATUS (retval);
+
+- gchar *error = g_strdup (_("Failed to stop the firewall\n\n"));
++ error = g_strdup (_("Failed to stop the firewall\n\n"));
+ if (!CONSOLE)
+ error = g_strconcat ("<span weight=\"bold\" size=\"larger\">", error, "</span>", NULL);
+
+@@ -112,6 +113,7 @@
+ start_firewall (void)
+ {
+ gint retval;
++ gchar *error;
+ gchar *command = g_strjoin (NULL, "/bin/sh ",
+ FIRESTARTER_RULES_DIR "/firestarter/firewall.sh",
+ NULL);
+@@ -126,7 +128,7 @@
+ } else {
+ retval = WEXITSTATUS (retval);
+
+- gchar *error = g_strdup (_("Failed to start the firewall\n\n"));
++ error = g_strdup (_("Failed to start the firewall\n\n"));
+ if (!CONSOLE)
+ error = g_strconcat ("<span weight=\"bold\" size=\"larger\">", error, "</span>", NULL);
+
+@@ -165,6 +167,7 @@
+ {
+ gint retval;
+ gchar *sbin;
++ gchar *error;
+ gchar *command;
+
+ if (!CONSOLE) {
+@@ -191,7 +194,7 @@
+ } else {
+ retval = WEXITSTATUS (retval);
+
+- gchar *error = g_strdup (_("Failed to enter halted firewall mode\n\n"));
++ error = g_strdup (_("Failed to enter halted firewall mode\n\n"));
+ if (!CONSOLE)
+ error = g_strconcat ("<span weight=\"bold\" size=\"larger\">", error, "</span>", NULL);
+
diff --git a/net-firewall/firestarter/firestarter-0.9.1.ebuild b/net-firewall/firestarter/firestarter-0.9.1.ebuild
index 55c7a0335a35..886c6e17c109 100644
--- a/net-firewall/firestarter/firestarter-0.9.1.ebuild
+++ b/net-firewall/firestarter/firestarter-0.9.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/firestarter-0.9.1.ebuild,v 1.2 2003/02/13 13:58:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/firestarter-0.9.1.ebuild,v 1.3 2003/02/15 15:20:49 foser Exp $
+
+inherit gnome2 eutils
IUSE="nls"
@@ -22,6 +24,12 @@ DEPEND="${RDEPEND}
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src ; epatch ${FILESDIR}/${P}-gcc2_fixes.patch
+}
+
src_compile() {
local myconf
use nls \