summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-23 20:32:15 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-23 20:32:15 +0000
commitb4a6a88ace108fc405ff0c63111153e915b75e16 (patch)
treecbba8e547529dc07e4ae14a4d8792f3d6918a171 /net-firewall/iptables/iptables-1.4.5.ebuild
parentRemove virtual/libc (diff)
downloadgentoo-2-b4a6a88ace108fc405ff0c63111153e915b75e16.tar.gz
gentoo-2-b4a6a88ace108fc405ff0c63111153e915b75e16.tar.bz2
gentoo-2-b4a6a88ace108fc405ff0c63111153e915b75e16.zip
Version bump #285519 by init_6.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/iptables/iptables-1.4.5.ebuild')
-rw-r--r--net-firewall/iptables/iptables-1.4.5.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-firewall/iptables/iptables-1.4.5.ebuild b/net-firewall/iptables/iptables-1.4.5.ebuild
new file mode 100644
index 000000000000..fc7ca1a7b0e4
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.5.ebuild,v 1.1 2009/09/23 20:32:15 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/os-headers"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ epatch_user
+}
+
+src_compile() {
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+ emake V=1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ fi
+}