summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-06-12 22:22:25 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-06-12 22:22:25 +0000
commita9a190191c9f14ae7fb78acf1369f514d3e06a70 (patch)
treea77d8f879241ee3c8032257c31b2d33ea7b5e172 /net-firewall/pglinux
parentremoved old ebuild (diff)
downloadgentoo-2-a9a190191c9f14ae7fb78acf1369f514d3e06a70.tar.gz
gentoo-2-a9a190191c9f14ae7fb78acf1369f514d3e06a70.tar.bz2
gentoo-2-a9a190191c9f14ae7fb78acf1369f514d3e06a70.zip
version bump, remove old
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/pglinux')
-rw-r--r--net-firewall/pglinux/ChangeLog8
-rw-r--r--net-firewall/pglinux/pglinux-2.2.0.ebuild (renamed from net-firewall/pglinux/pglinux-2.1.3_p20120519.ebuild)37
2 files changed, 32 insertions, 13 deletions
diff --git a/net-firewall/pglinux/ChangeLog b/net-firewall/pglinux/ChangeLog
index d753ba785615..825b3ae53585 100644
--- a/net-firewall/pglinux/ChangeLog
+++ b/net-firewall/pglinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/pglinux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/pglinux/ChangeLog,v 1.4 2012/05/21 15:10:29 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/pglinux/ChangeLog,v 1.5 2012/06/12 22:22:24 hasufell Exp $
+
+*pglinux-2.2.0 (12 Jun 2012)
+
+ 12 Jun 2012; Julian Ospald <hasufell@gentoo.org>
+ -pglinux-2.1.3_p20120519.ebuild, +pglinux-2.2.0.ebuild:
+ version bump, remove old
21 May 2012; Julian Ospald <hasufell@gentoo.org>
pglinux-2.1.3_p20120519.ebuild:
diff --git a/net-firewall/pglinux/pglinux-2.1.3_p20120519.ebuild b/net-firewall/pglinux/pglinux-2.2.0.ebuild
index a6dfca91b138..e6a7cd56313d 100644
--- a/net-firewall/pglinux/pglinux-2.1.3_p20120519.ebuild
+++ b/net-firewall/pglinux/pglinux-2.2.0.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/pglinux/pglinux-2.1.3_p20120519.ebuild,v 1.2 2012/05/21 15:10:29 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/pglinux/pglinux-2.2.0.ebuild,v 1.1 2012/06/12 22:22:24 hasufell Exp $
EAPI=4
-inherit linux-info
+inherit gnome2-utils linux-info
+
+MY_P="pgl-${PV}"
DESCRIPTION="Privacy oriented firewall application"
HOMEPAGE="https://sourceforge.net/projects/peerguardian/"
-SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+SRC_URI="mirror://sourceforge/peerguardian/${MY_P}.tar.gz"
LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86"
@@ -23,7 +25,9 @@ COMMON_DEPEND="
qt4? ( sys-auth/polkit-qt
x11-libs/qt-core:4
x11-libs/qt-dbus:4
- x11-libs/qt-gui:4 )"
+ x11-libs/qt-gui:4
+ || ( kde-base/kdesu x11-libs/gksu x11-misc/ktsuss )
+ )"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
sys-devel/libtool:2"
@@ -51,27 +55,36 @@ CONFIG_CHECK="~NETFILTER_NETLINK
~IP_NF_IPTABLES
~IP_NF_TARGET_REJECT"
+S=${WORKDIR}/${MY_P}
+
src_configure() {
econf \
--localstatedir=/var \
- $(use_enable cron) \
- $(use_enable dbus) \
+ --docdir=/usr/share/doc/${PF} \
$(use_enable logrotate) \
+ $(use_enable cron) \
$(use_enable networkmanager) \
$(use_enable zlib) \
+ $(use_enable dbus) \
+ --disable-lowmem \
+ --with-iconsdir=/usr/share/icons/hicolor/128x128/apps \
$(use_with qt4)
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
elog "optional dependencies:"
elog " app-arch/p7zip (needed for blocklists packed as .7z)"
elog " app-arch/unzip (needed for blocklists packed as .zip)"
elog " virtual/mta (needed to send informational (blocklist updates) and"
elog " warning mails (if pglcmd.wd detects a problem.))"
- if use qt4 ; then
- elog "You need one of the following graphical su/sudo:"
- elog " x11-misc/ktsuss"
- elog " x11-libs/gksu"
- elog " kde-base/kdesu"
- fi
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
}