summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2013-11-10 17:37:51 +0000
committerConstanze Hausner <constanze@gentoo.org>2013-11-10 17:37:51 +0000
commit0f085505b9408293a29769720879119e7de0ad56 (patch)
tree923a5bbb23c5d1c7fb22a9c4a441204704bef9bb /net-firewall/shorewall6-lite
parentVersion bump; Thanks to Thomas D. (diff)
downloadgentoo-2-0f085505b9408293a29769720879119e7de0ad56.tar.gz
gentoo-2-0f085505b9408293a29769720879119e7de0ad56.tar.bz2
gentoo-2-0f085505b9408293a29769720879119e7de0ad56.zip
Version bump; Thanks to Thomas D.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key BB80F419010E3EC3)
Diffstat (limited to 'net-firewall/shorewall6-lite')
-rw-r--r--net-firewall/shorewall6-lite/ChangeLog10
-rw-r--r--net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.confd15
-rw-r--r--net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.initd82
-rw-r--r--net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.systemd17
-rw-r--r--net-firewall/shorewall6-lite/files/4.5.21.2/shorewallrc23
-rw-r--r--net-firewall/shorewall6-lite/shorewall6-lite-4.5.21.2.ebuild107
6 files changed, 253 insertions, 1 deletions
diff --git a/net-firewall/shorewall6-lite/ChangeLog b/net-firewall/shorewall6-lite/ChangeLog
index ed17dbee8108..da95ee16d6a2 100644
--- a/net-firewall/shorewall6-lite/ChangeLog
+++ b/net-firewall/shorewall6-lite/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-firewall/shorewall6-lite
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6-lite/ChangeLog,v 1.67 2013/10/21 13:00:20 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6-lite/ChangeLog,v 1.68 2013/11/10 17:37:51 constanze Exp $
+
+*shorewall6-lite-4.5.21.2 (10 Nov 2013)
+
+ 10 Nov 2013; Constanze Hausner <constanze@gentoo.org>
+ +files/4.5.21.2/shorewall6-lite.confd, +files/4.5.21.2/shorewall6-lite.initd,
+ +files/4.5.21.2/shorewallrc, +shorewall6-lite-4.5.21.2.ebuild,
+ +files/4.5.21.2/shorewall6-lite.systemd:
+ Version bump; Thanks to Thomas D.
21 Oct 2013; Chema Alonso <nimiux@gentoo.org>
shorewall6-lite-4.5.18-r1.ebuild:
diff --git a/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.confd b/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.confd
new file mode 100644
index 000000000000..e5957167b5b9
--- /dev/null
+++ b/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.confd
@@ -0,0 +1,15 @@
+# Global start/restart/stop options
+#
+OPTIONS=""
+
+# Start options
+#
+STARTOPTIONS=""
+
+# Stop options
+#
+STOPOPTIONS=""
+
+# Restart options
+#
+RESTARTOPTIONS=""
diff --git a/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.initd b/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.initd
new file mode 100644
index 000000000000..791fcdd583da
--- /dev/null
+++ b/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.initd
@@ -0,0 +1,82 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.initd,v 1.1 2013/11/10 17:37:51 constanze Exp $
+
+description='The Shoreline Firewall 6 Lite, more commonly known as "Shorewall6 Lite", is'
+description="${description} a high-level tool for configuring Netfilter."
+
+extra_commands="clear"
+extra_started_commands="reset"
+
+description_clear="Clear will remove all rules and chains installed by"
+description_clear="${description_clear} Shorewall6 Lite. The firewall is"
+description_clear="${description_clear} then wide open and unprotected."
+
+description_reset="All the packet and byte counters in the firewall are reset."
+
+depend() {
+ need net
+ provide firewall
+ after ulogd
+}
+
+status() {
+ local _retval
+ /sbin/shorewall6-lite status 1>/dev/null
+ _retval=$?
+ if [ ${_retval} = '0' ]; then
+ einfo 'status: started'
+ mark_service_started "${SVCNAME}"
+ return 0
+ else
+ einfo 'status: stopped'
+ mark_service_stopped "${SVCNAME}"
+ return 3
+ fi
+}
+
+start() {
+ ebegin "Starting shorewall6-lite"
+ /sbin/shorewall6-lite ${OPTIONS} start ${STARTOPTIONS} 1>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping shorewall6-lite"
+ /sbin/shorewall6-lite ${OPTIONS} stop ${STOPOPTIONS} 1>/dev/null
+ eend $?
+}
+
+restart() {
+ # shorewall comes with its own control script that includes a
+ # restart function, so refrain from calling svc_stop/svc_start
+ # here. Note that this comment is required to fix bug 55576;
+ # runscript.sh greps this script... (09 Jul 2004 agriffis)
+
+ ebegin "Restarting shorewall6-lite"
+ /sbin/shorewall6-lite status 1>/dev/null
+ if [ $? != 0 ] ; then
+ svc_start
+ else
+ /sbin/shorewall6-lite ${OPTIONS} restart ${RESTARTOPTIONS} 1>/dev/null
+ fi
+ eend $?
+}
+
+clear() {
+ # clear will remove all the rules and bring the system to an unfirewalled
+ # state. (21 Nov 2004 eldad)
+
+ ebegin "Clearing all shorewall6-lite rules and setting policy to ACCEPT"
+ /sbin/shorewall6-lite ${OPTIONS} clear 1>/dev/null
+ eend $?
+}
+
+reset() {
+ # reset the packet and byte counters in the firewall
+
+ ebegin "Resetting the packet and byte counters in shorewall6-lite"
+ /sbin/shorewall6-lite ${OPTIONS} reset 1>/dev/null
+ eend $?
+}
diff --git a/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.systemd b/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.systemd
new file mode 100644
index 000000000000..5af21b6c19bd
--- /dev/null
+++ b/net-firewall/shorewall6-lite/files/4.5.21.2/shorewall6-lite.systemd
@@ -0,0 +1,17 @@
+#
+# The Shoreline Firewall 6 Lite (Shorewall6-Lite) Packet Filtering Firewall - V4.5
+#
+[Unit]
+Description=Shorewall IPv6 firewall lite
+Documentation=man:shorewall6-lite(8) http://www.shorewall.net/Documentation_Index.html
+After=network.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+EnvironmentFile=/etc/conf.d/shorewall6-lite
+ExecStart=/sbin/shorewall6-lite $OPTIONS start $STARTOPTIONS
+ExecStop=/sbin/shorewall6-lite $OPTIONS stop $STOPOPTIONS
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-firewall/shorewall6-lite/files/4.5.21.2/shorewallrc b/net-firewall/shorewall6-lite/files/4.5.21.2/shorewallrc
new file mode 100644
index 000000000000..46f5eb9a3603
--- /dev/null
+++ b/net-firewall/shorewall6-lite/files/4.5.21.2/shorewallrc
@@ -0,0 +1,23 @@
+#
+# Gentoo Shorewall 4.5 rc file
+#
+BUILD= #Default is to detect the build system
+HOST=gentoo #Gentoo GNU Linux
+PREFIX=@GENTOO_PORTAGE_EPREFIX@/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=@GENTOO_PORTAGE_EPREFIX@/etc #Directory where subsystem configurations are installed
+SBINDIR=@GENTOO_PORTAGE_EPREFIX@/sbin #Directory where system administration programs are installed
+MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
+INITDIR=${CONFDIR}/init.d #Directory where SysV init scripts are installed.
+INITFILE=${PRODUCT} #Name of the product's installed SysV init script
+INITSOURCE=init.gentoo.sh #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD=@GENTOO_PORTAGE_EPREFIX@/usr/lib/systemd/system #Directory where .service files are installed (systems running systemd only)
+SERVICEFILE=gentoo.service #Name of the distributed file to be installed as systemd service file
+SYSCONFFILE=default.gentoo #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR=${CONFDIR}/conf.d #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARLIB=@GENTOO_PORTAGE_EPREFIX@/var/lib #Directory where product variable data is stored.
+VARDIR=${VARLIB}/${PRODUCT} #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall6-lite/shorewall6-lite-4.5.21.2.ebuild b/net-firewall/shorewall6-lite/shorewall6-lite-4.5.21.2.ebuild
new file mode 100644
index 000000000000..180fc775874e
--- /dev/null
+++ b/net-firewall/shorewall6-lite/shorewall6-lite-4.5.21.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6-lite/shorewall6-lite-4.5.21.2.ebuild,v 1.1 2013/11/10 17:37:51 constanze Exp $
+
+EAPI="5"
+
+inherit eutils linux-info prefix systemd versionator
+
+MY_URL_PREFIX=
+case ${P} in
+ *_beta* | \
+ *_rc*)
+ MY_URL_PREFIX='development/'
+ ;;
+esac
+
+MY_PV=${PV/_rc/-RC}
+MY_PV=${MY_PV/_beta/-Beta}
+MY_P=${PN}-${MY_PV}
+MY_P_DOCS=shorewall-docs-html-${MY_PV}
+
+MY_MAJOR_RELEASE_NUMBER=$(get_version_component_range 1-2)
+MY_MAJORMINOR_RELEASE_NUMBER=$(get_version_component_range 1-3)
+
+DESCRIPTION="An iptables-based firewall whose config is handled by a normal Shorewall6."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="
+ http://www1.shorewall.net/pub/shorewall/${MY_URL_PREFIX}${MY_MAJOR_RELEASE_NUMBER}/shorewall-${MY_MAJORMINOR_RELEASE_NUMBER}/${MY_P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/shorewall/${MY_URL_PREFIX}${MY_MAJOR_RELEASE_NUMBER}/shorewall-${MY_MAJORMINOR_RELEASE_NUMBER}/${MY_P_DOCS}.tar.bz2 )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="=net-firewall/shorewall-core-${PVR}"
+RDEPEND="
+ ${DEPEND}
+ >=net-firewall/iptables-1.4.20[ipv6]
+ sys-apps/iproute2[-minimal]
+ dev-perl/Socket6
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_pretend() {
+ local CONFIG_CHECK="~NF_CONNTRACK ~NF_CONNTRACK_IPV6"
+
+ local ERROR_CONNTRACK="${PN} requires NF_CONNTRACK support."
+
+ local ERROR_CONNTRACK_IPV6="${PN} requires NF_CONNTRACK_IPV6 support."
+
+ check_extra_config
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/${PVR}/shorewallrc "${S}"/shorewallrc.gentoo || die "Copying shorewallrc failed"
+ eprefixify "${S}"/shorewallrc.gentoo
+
+ cp "${FILESDIR}"/${PVR}/${PN}.confd "${S}"/default.gentoo || die "Copying ${PN}.confd failed"
+ cp "${FILESDIR}"/${PVR}/${PN}.initd "${S}"/init.gentoo.sh || die "Copying ${PN}.initd failed"
+ cp "${FILESDIR}"/${PVR}/${PN}.systemd "${S}"/gentoo.service || die "Copying ${PN}.systemd failed"
+
+ epatch_user
+}
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ DESTDIR="${D}" ./install.sh shorewallrc.gentoo || die "install.sh failed"
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "Before you can use ${PN}, you need to provide a configuration, which you can"
+ elog "create using ${CATEGORY}/shorewall6 (the full version, including the compiler)."
+ elog ""
+ elog "To activate ${PN} on system start, please add ${PN} to your default runlevel:"
+ elog ""
+ elog " # rc-update add ${PN} default"
+ fi
+
+ if ! has_version ${CATEGORY}/shorewall-init; then
+ elog ""
+ elog "Starting with shorewall6-lite-4.5.21.2, Gentoo also offers ${CATEGORY}/shorewall-init,"
+ elog "which we recommend to install, to protect your firewall at system boot."
+ elog ""
+ elog "To read more about shorewall-init, please visit"
+ elog " http://www.shorewall.net/Shorewall-init.html"
+ fi
+}