summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2009-08-02 17:50:24 +0000
committerCédric Krier <cedk@gentoo.org>2009-08-02 17:50:24 +0000
commit5211c77cba052d1df60730f68faeba073d0ad36c (patch)
treed71756b4c41cdc7741b44fea5352aae2c67cee22 /net-firewall
parentFix QtCore rpath logic. Install full html docs ( bug #280055 ) (diff)
downloadgentoo-2-5211c77cba052d1df60730f68faeba073d0ad36c.tar.gz
gentoo-2-5211c77cba052d1df60730f68faeba073d0ad36c.tar.bz2
gentoo-2-5211c77cba052d1df60730f68faeba073d0ad36c.zip
Version bump and add fix for gnutls >= 2.7.1 for bug #279581
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nufw/ChangeLog8
-rw-r--r--net-firewall/nufw/files/nufw-2.2.21-fix-gnutls.patch24
-rw-r--r--net-firewall/nufw/nufw-2.2.21.ebuild109
3 files changed, 140 insertions, 1 deletions
diff --git a/net-firewall/nufw/ChangeLog b/net-firewall/nufw/ChangeLog
index 047b17710a10..76111ac4f99e 100644
--- a/net-firewall/nufw/ChangeLog
+++ b/net-firewall/nufw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/nufw
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/ChangeLog,v 1.32 2009/01/17 14:34:46 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/ChangeLog,v 1.33 2009/08/02 17:50:24 cedk Exp $
+
+*nufw-2.2.21 (02 Aug 2009)
+
+ 02 Aug 2009; Cédric Krier <cedk@gentoo.org> +nufw-2.2.21.ebuild,
+ +files/nufw-2.2.21-fix-gnutls.patch:
+ Version bump and add fix for gnutls >= 2.7.1 for bug #279581
*nufw-2.2.20 (17 Jan 2009)
diff --git a/net-firewall/nufw/files/nufw-2.2.21-fix-gnutls.patch b/net-firewall/nufw/files/nufw-2.2.21-fix-gnutls.patch
new file mode 100644
index 000000000000..0700c84b06d8
--- /dev/null
+++ b/net-firewall/nufw/files/nufw-2.2.21-fix-gnutls.patch
@@ -0,0 +1,24 @@
+diff -ru nufw-2.2.21~/configure.ac nufw-2.2.21/configure.ac
+--- nufw-2.2.21~/configure.ac 2009-08-02 19:39:52.000000000 +0200
++++ nufw-2.2.21/configure.ac 2009-08-02 19:42:38.000000000 +0200
+@@ -87,6 +87,7 @@
+ #AM_CHECK_PATH([libgcrypt], [gcry_md_open],AC_DEFINE([HAVE_LIBRARY_GCRYPT],[1],[Gcrypt lib flag]), check_gcrypt=no,[-L/usr/local/lib])
+ #AM_CHECK_PATH(libgnutls], [gnutls_init],AC_DEFINE([HAVE_LIBRARY_GNUTLS],[1],[Gnutls lib flag]), check_gnutls=no)
+
++PKG_PROG_PKG_CONFIG
+
+ NEED_LIBGCRYPT_VERSION=1.2.0
+ AM_PATH_LIBGCRYPT("$NEED_LIBGCRYPT_VERSION")
+@@ -99,11 +100,7 @@
+ fi
+
+ NEED_LIBGNUTLS_VERSION=1.0.16
+-AM_PATH_LIBGNUTLS("$NEED_LIBGNUTLS_VERSION")
+-if test "x$LIBGNUTLS_LIBS" = "x"; then
+- AC_MSG_ERROR([libgnutls is needed.
+- See www.gnu.org/software/gnutls/ .])
+-fi
++PKG_CHECK_MODULES(GNUTLS, gnutls >= $NEED_LIBGNUTLS_VERSION,,exit)
+
+ #Configure database support, depending on user input
+ AC_ARG_WITH(prelude-log,
diff --git a/net-firewall/nufw/nufw-2.2.21.ebuild b/net-firewall/nufw/nufw-2.2.21.ebuild
new file mode 100644
index 000000000000..76faec48d95e
--- /dev/null
+++ b/net-firewall/nufw/nufw-2.2.21.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/nufw-2.2.21.ebuild,v 1.1 2009/08/02 17:50:24 cedk Exp $
+
+inherit autotools ssl-cert eutils pam
+
+DESCRIPTION="An enterprise grade authenticating firewall based on netfilter"
+HOMEPAGE="http://www.nufw.org/"
+SRC_URI="http://www.nufw.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug ldap mysql pam pam_nuauth plaintext postgres prelude \
+unicode nfqueue nfconntrack static syslog test"
+
+DEPEND=">=dev-libs/glib-2
+ dev-libs/libgcrypt
+ >=dev-libs/cyrus-sasl-2
+ net-firewall/iptables
+ >=net-libs/gnutls-1.1
+ ldap? ( >=net-nds/openldap-2 )
+ mysql? ( virtual/mysql )
+ pam? ( sys-libs/pam )
+ pam_nuauth? ( sys-libs/pam )
+ postgres? ( virtual/postgresql-server )
+ nfqueue? ( net-libs/libnfnetlink
+ net-libs/libnetfilter_queue )
+ nfconntrack? ( net-libs/libnetfilter_conntrack )
+ prelude? ( dev-libs/libprelude )
+ dev-python/ipy"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:^#\(nuauth_tls_key="/etc/nufw/\)nuauth-key.pem:\1nuauth.key:' \
+ -e 's:^#\(nuauth_tls_cert="/etc/nufw/\)nuauth-cert.pem:\1nuauth.pem:' \
+ conf/nuauth.conf || die "sed failed"
+
+ epatch "${FILESDIR}/${P}-fix-gnutls.patch"
+
+ # This tests require inl_tests to be installed. We don't have it now in our
+ # tree so we disable them for now... for more information see tests/README
+ use test && sed -i "s:\(^TESTS=test_all.py\):#\1:" tests/Makefile.am
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-shared \
+ $(use_enable static) \
+ $(use_enable pam_nuauth pam-nufw) \
+ $(use_with prelude prelude-log) \
+ $(use_with mysql mysql-log) \
+ $(use_with mysql mysql-auth) \
+ $(use_with postgres pgsql-log) \
+ $(use_with syslog syslog-log) \
+ $(use_with plaintext plaintext-auth) \
+ --with-mark-group \
+ $(use_with pam system-auth) \
+ $(use_with ldap) \
+ $(use_with nfqueue) \
+ $(use_with nfconntrack) \
+ $(use_with unicode utf8) \
+ $(use_enable debug) \
+ --with-user-mark \
+ --sysconfdir="/etc/nufw" \
+ --localstatedir="/var" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ ewarn "Some tests are skiped! If you wish to run them read tests/README and"
+ ewarn "do that manually."
+ ebeep 5
+ make check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/nufw-init.d nufw
+ newconfd "${FILESDIR}"/nufw-conf.d nufw
+
+ newinitd "${FILESDIR}"/nuauth-init.d nuauth
+ newconfd "${FILESDIR}"/nuauth-conf.d nuauth
+
+ insinto /etc/nufw
+ doins conf/nuauth.conf
+ keepdir /var/run/nuauth
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ docinto scripts
+ dodoc scripts/{clean_conntrack.pl,nuaclgen,nutop,README,ulog_rotate_daily.sh,ulog_rotate_weekly.sh}
+ docinto conf
+ dodoc conf/*.{nufw,schema,conf,dump,xml}
+
+ if use pam; then
+ pamd_mimic system-auth nufw auth account password session
+ fi
+}
+
+pkg_postinst() {
+ install_cert /etc/nufw/{nufw,nuauth}
+}