summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-05-25 20:58:45 +0000
committerMatthias Maier <tamiko@gentoo.org>2015-05-25 20:58:45 +0000
commit53c49a4923bece4990eadd9f73b54975f543031b (patch)
tree19410939bdd3ca4201246ee0b774323bd4156e19 /net-firewall
parentVersion bump. This version isn't locked to Java 6. (diff)
downloadgentoo-2-53c49a4923bece4990eadd9f73b54975f543031b.tar.gz
gentoo-2-53c49a4923bece4990eadd9f73b54975f543031b.tar.bz2
gentoo-2-53c49a4923bece4990eadd9f73b54975f543031b.zip
co-maintain package; version bump; also install man pages, bug #540108 reported by 'dE', also thanks to Jeroen Roovers
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/firewalld/ChangeLog9
-rw-r--r--net-firewall/firewalld/firewalld-0.3.10.ebuild5
-rw-r--r--net-firewall/firewalld/firewalld-0.3.13.ebuild98
-rw-r--r--net-firewall/firewalld/metadata.xml7
4 files changed, 114 insertions, 5 deletions
diff --git a/net-firewall/firewalld/ChangeLog b/net-firewall/firewalld/ChangeLog
index f73f505cf29d..c5137fee5ae6 100644
--- a/net-firewall/firewalld/ChangeLog
+++ b/net-firewall/firewalld/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/firewalld
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/ChangeLog,v 1.16 2015/04/13 06:32:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/ChangeLog,v 1.17 2015/05/25 20:58:45 tamiko Exp $
+
+*firewalld-0.3.13 (25 May 2015)
+
+ 25 May 2015; Matthias Maier <tamiko@gentoo.org> +firewalld-0.3.13.ebuild,
+ firewalld-0.3.10.ebuild, metadata.xml:
+ co-maintain package; version bump; also install man pages, bug #540108
+ reported by 'dE', also thanks to Jeroen Roovers
13 Apr 2015; Ian Delaney <idella4@gentoo.org> firewalld-0.3.10.ebuild:
add py3.4 support, update python_export_best to python_setup, no need for
diff --git a/net-firewall/firewalld/firewalld-0.3.10.ebuild b/net-firewall/firewalld/firewalld-0.3.10.ebuild
index 4aa99438c19b..914c04940880 100644
--- a/net-firewall/firewalld/firewalld-0.3.10.ebuild
+++ b/net-firewall/firewalld/firewalld-0.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/firewalld-0.3.10.ebuild,v 1.2 2015/04/13 06:32:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/firewalld-0.3.10.ebuild,v 1.3 2015/05/25 20:58:45 tamiko Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -56,6 +56,7 @@ src_install() {
emake -C config DESTDIR="${D}" install
emake -C po DESTDIR="${D}" install
emake -C shell-completion DESTDIR="${D}" install
+ emake -C doc DESTDIR="${D}" install
install_python() {
emake -C src DESTDIR="${D}" pythondir="$(python_get_sitedir)" install
@@ -67,8 +68,6 @@ src_install() {
python_replicate_script "${D}/usr/sbin/firewalld"
# Get rid of junk
- rm -f "${D}/etc/rc.d/init.d/firewalld"
- rm -f "${D}/etc/sysconfig/firewalld"
rm -rf "${D}/etc/rc.d/"
rm -rf "${D}/etc/sysconfig/"
diff --git a/net-firewall/firewalld/firewalld-0.3.13.ebuild b/net-firewall/firewalld/firewalld-0.3.13.ebuild
new file mode 100644
index 000000000000..c66d03dfe1dc
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-0.3.13.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/firewalld-0.3.13.ebuild,v 1.1 2015/05/25 20:58:45 tamiko Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+#BACKPORTS=
+
+inherit autotools eutils gnome2-utils python-r1 systemd multilib bash-completion-r1
+
+DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
+HOMEPAGE="http://fedorahosted.org/firewalld"
+SRC_URI="https://fedorahosted.org/released/firewalld/${P}.tar.bz2
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/python-slip-0.2.7[dbus,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-firewall/ebtables
+ net-firewall/iptables[ipv6]
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ gui? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ epatch "${FILESDIR}/${PN}-0.3.10-py3k-compat.patch"
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ python_setup
+
+ econf \
+ --enable-systemd \
+ "$(systemd_with_unitdir 'systemd-unitdir')" \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
+
+src_install() {
+ # manually split up the installation to avoid "file already exists" errors
+ emake -C config DESTDIR="${D}" install
+ emake -C po DESTDIR="${D}" install
+ emake -C shell-completion DESTDIR="${D}" install
+ emake -C doc DESTDIR="${D}" install
+
+ install_python() {
+ emake -C src DESTDIR="${D}" pythondir="$(python_get_sitedir)" install
+ python_optimize
+ }
+ python_foreach_impl install_python
+
+ python_replicate_script "${D}"/usr/bin/firewall-{offline-cmd,cmd,applet,config}
+ python_replicate_script "${D}/usr/sbin/firewalld"
+
+ # Get rid of junk
+ rm -rf "${D}/etc/rc.d/"
+ rm -rf "${D}/etc/sysconfig/"
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -f "${D}/usr/bin/firewall-applet"
+ rm -f "${D}/usr/bin/firewall-config"
+ rm -rf "${D}/usr/share/icons"
+ rm -rf "${D}/usr/share/applications"
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/net-firewall/firewalld/metadata.xml b/net-firewall/firewalld/metadata.xml
index 499286b8714a..773fdd88c2cb 100644
--- a/net-firewall/firewalld/metadata.xml
+++ b/net-firewall/firewalld/metadata.xml
@@ -1,11 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>virtualization</herd>
+ <maintainer>
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ <description>Please assign bugs to me</description>
+ </maintainer>
<maintainer>
<email>cardoe@gentoo.org</email>
<name>Doug Goldstein</name>
</maintainer>
+ <herd>virtualization</herd>
<use>
<flag name='gui'>Builds and installs GUI configurator and GTK+ applet</flag>
</use>