summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2011-03-13 11:47:39 +0000
committerConstanze Hausner <constanze@gentoo.org>2011-03-13 11:47:39 +0000
commit8fc807aea3f73ba574a2b8ab96d39b0210694287 (patch)
treed835cc253291730ff79079de5ef71abba8a38fd3 /net-firewall
parentVersion bump. (diff)
downloadgentoo-2-8fc807aea3f73ba574a2b8ab96d39b0210694287.tar.gz
gentoo-2-8fc807aea3f73ba574a2b8ab96d39b0210694287.tar.bz2
gentoo-2-8fc807aea3f73ba574a2b8ab96d39b0210694287.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/shorewall6-4.4.18.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index df4cac5aa986..a55824285be3 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.28 2011/02/27 14:48:23 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.29 2011/03/13 11:47:39 constanze Exp $
+
+*shorewall6-4.4.18 (13 Mar 2011)
+
+ 13 Mar 2011; Constanze Hausner <constanze@gentoo.org>
+ +shorewall6-4.4.18.ebuild:
+ Version bump.
27 Feb 2011; Tobias Klausmann <klausman@gentoo.org>
shorewall6-4.4.15.1.ebuild:
diff --git a/net-firewall/shorewall6/shorewall6-4.4.18.ebuild b/net-firewall/shorewall6/shorewall6-4.4.18.ebuild
new file mode 100644
index 000000000000..7271b0bc1621
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.4.18.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.4.18.ebuild,v 1.1 2011/03/13 11:47:39 constanze Exp $
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "doinitd failed"
+
+ dodoc releasenotes.txt
+ if use doc; then
+ cp -pR Samples6 "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ elog "If you wish to include DNS names in your IPv6 configuration files,"
+ elog "you must have Perl 5.10+ and must emerge dev-perl/Socket6."
+}