summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-02-24 18:52:27 +0000
committerPeter Volkov <pva@gentoo.org>2008-02-24 18:52:27 +0000
commitb4ff31b017a6ad1c45839089ae44f9a7c04ba45c (patch)
tree21f571e83351d00b4ea2ea8a02eb2868f2204ba6 /net-firewall
parentUnmask linuxwacom. (diff)
downloadgentoo-2-b4ff31b017a6ad1c45839089ae44f9a7c04ba45c.tar.gz
gentoo-2-b4ff31b017a6ad1c45839089ae44f9a7c04ba45c.tar.bz2
gentoo-2-b4ff31b017a6ad1c45839089ae44f9a7c04ba45c.zip
Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-lite/ChangeLog7
-rw-r--r--net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/net-firewall/shorewall-lite/ChangeLog b/net-firewall/shorewall-lite/ChangeLog
index 6e7720bb7ba8..5ab6b745ceff 100644
--- a/net-firewall/shorewall-lite/ChangeLog
+++ b/net-firewall/shorewall-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-lite
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.27 2008/01/27 19:20:28 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.28 2008/02/24 18:52:27 pva Exp $
+
+*shorewall-lite-4.0.9 (24 Feb 2008)
+
+ 24 Feb 2008; <pva@gentoo.org> +shorewall-lite-4.0.9.ebuild:
+ Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
*shorewall-lite-4.0.8 (27 Jan 2008)
diff --git a/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild b/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild
new file mode 100644
index 000000000000..762b6da26475
--- /dev/null
+++ b/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild,v 1.1 2008/02/24 18:52:27 pva Exp $
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-Beta7" # only beta
+MY_P_BETA="" # stable or experimental
+
+MY_P_DOCS="${P/${PN}/shorewall-docs-html}"
+
+MY_P="shorewall-${PV}"
+
+DESCRIPTION="An iptables-based firewall whose config is handled by a normal Shorewall."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${MY_P_DOCS}${MY_P_BETA}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/shorewall-lite
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}/shorewall-lite" shorewall-lite
+
+ dodoc changelog.txt releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo "There are man pages for shorewall-lite(8) and for each"
+ einfo "configuration file."
+ einfo
+ einfo "You should have already generated a firewall script with"
+ einfo "'shorewall compile' on the administrative Shorewall."
+ einfo "Please refer to"
+ einfo "http://www.shorewall.net/CompiledPrograms.html"
+ einfo
+ einfo "If you intend to use the 2.6 IPSEC Support, you must retrieve the"
+ einfo "kernel patches from http://shorewall.net/pub/shorewall/contrib/IPSEC/"
+ einfo "or install kernel 2.6.16+ as well as a recent Netfilter iptables"
+ einfo "and compile it with support for policy match."
+ einfo
+ einfo "Note that /etc/shorewall-lite/shorewall.conf has been renamed"
+ einfo "to /etc/shorewall-lite/shorewall-lite.conf"
+ einfo
+ einfo "Known problems:"
+ einfo "http://shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+}