summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2013-06-02 10:49:07 +0000
committerConstanze Hausner <constanze@gentoo.org>2013-06-02 10:49:07 +0000
commitb626b9355d0d0a5c1af8d179c06ba2d9e62a18c6 (patch)
treecf0abf30b6793bcb4b8b03f4eaee378d2abad12a /net-firewall
parentCleanup; Version bump; Systemd support wrt bug 465950 (diff)
downloadgentoo-2-b626b9355d0d0a5c1af8d179c06ba2d9e62a18c6.tar.gz
gentoo-2-b626b9355d0d0a5c1af8d179c06ba2d9e62a18c6.tar.bz2
gentoo-2-b626b9355d0d0a5c1af8d179c06ba2d9e62a18c6.zip
Cleanup; Version bump; Systemd support wrt bug 465950
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key BB80F419010E3EC3)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/files/shorewall6.systemd20
-rw-r--r--net-firewall/shorewall6/files/shorewallrc21
-rw-r--r--net-firewall/shorewall6/shorewall6-4.5.17.ebuild62
4 files changed, 89 insertions, 22 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index acc1652d8020..476fb7bf19e0 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.67 2013/05/29 15:25:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.68 2013/06/02 10:49:07 constanze Exp $
+
+*shorewall6-4.5.17 (02 Jun 2013)
+
+ 02 Jun 2013; Constanze Hausner <constanze@gentoo.org>
+ +files/shorewall6.systemd, +shorewall6-4.5.17.ebuild, -files/shorewallrc:
+ Cleanup; Version bump; Systemd support wrt bug #465950
29 May 2013; Jeroen Roovers <jer@gentoo.org> shorewall6-4.5.15.ebuild:
Stable for HPPA (bug #470544).
diff --git a/net-firewall/shorewall6/files/shorewall6.systemd b/net-firewall/shorewall6/files/shorewall6.systemd
new file mode 100644
index 000000000000..1c6e95374a80
--- /dev/null
+++ b/net-firewall/shorewall6/files/shorewall6.systemd
@@ -0,0 +1,20 @@
+#
+# The Shoreline Firewall (Shorewall) Packet Filtering Firewall - V4.4
+#
+# Copyright 2011 Jonathan Underwood (jonathan.underwood@gmail.com)
+#
+[Unit]
+Description=Shorewall IPv6 firewall
+After=syslog.target
+After=network.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+EnvironmentFile=/etc/shorewall6
+StandardOutput=syslog
+ExecStart=/sbin/shorewall6 $OPTIONS start
+ExecStop=/sbin/shorewall6 $OPTIONS stop
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-firewall/shorewall6/files/shorewallrc b/net-firewall/shorewall6/files/shorewallrc
deleted file mode 100644
index 4f13769114a4..000000000000
--- a/net-firewall/shorewall6/files/shorewallrc
+++ /dev/null
@@ -1,21 +0,0 @@
-#
-# Gentoo Shorewall 4.5 rc file
-#
-HOST=linux #Generic Linux
-BUILD= #Default is to detect the build system
-PREFIX=/usr #Top-level directory for shared files, libraries, etc.
-SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
-LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
-PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
-CONFDIR=/etc #Directory where subsystem configurations are installed
-SBINDIR=/sbin #Directory where system administration programs are installed
-MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
-INITDIR=etc/init.d #Directory where SysV init scripts are installed.
-INITFILE=$PRODUCT #Name of the product's installed SysV init script
-INITSOURCE=init.sh #Name of the distributed file to be installed as the SysV init script
-ANNOTATED= #If non-zero, annotated configuration files are installed
-SYSTEMD= #Directory where .service files are installed (systems running systemd only)
-SYSCONFFILE= #Name of the distributed file to be installed in $SYSCONFDIR
-SYSCONFDIR= #Directory where SysV init parameter files are installed
-SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
-VARDIR=/var/lib #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall6/shorewall6-4.5.17.ebuild b/net-firewall/shorewall6/shorewall6-4.5.17.ebuild
new file mode 100644
index 000000000000..e15f5864c41f
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.5.17.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.5.17.ebuild,v 1.1 2013/06/02 10:49:07 constanze Exp $
+
+EAPI="4"
+
+inherit linux-info systemd versionator
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}"
+MY_P_DOCS="${MY_PN}-docs-html-${PV}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+RDEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}"
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc_new || die "install.sh failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_newunit "${FILESDIR}"/shorewall6.systemd 'shorewall6.service' || die
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples6
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ dodir /var/lock/subsys
+}