summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-28 17:32:24 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-28 17:32:24 +0000
commite21fb2ed250380e9a9af66009f4f60a5b248de63 (patch)
treebf23232ab4da891835a2029699297f2461df393f /net-firewall
parentfix previous changelog to include ref to bug 225215 (diff)
downloadgentoo-2-e21fb2ed250380e9a9af66009f4f60a5b248de63.tar.gz
gentoo-2-e21fb2ed250380e9a9af66009f4f60a5b248de63.tar.bz2
gentoo-2-e21fb2ed250380e9a9af66009f4f60a5b248de63.zip
Version bump #229185 by Sergey Dryabzhinsky.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/iptables-1.4.1.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 8bd03e40266f..def577dcfd85 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.168 2008/06/14 14:04:51 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.169 2008/06/28 17:32:24 vapier Exp $
+
+*iptables-1.4.1.1 (28 Jun 2008)
+
+ 28 Jun 2008; Mike Frysinger <vapier@gentoo.org> +iptables-1.4.1.1.ebuild:
+ Version bump #229185 by Sergey Dryabzhinsky.
14 Jun 2008; Zac Medico <zmedico@gentoo.org> iptables-1.3.5-r4.ebuild,
iptables-1.3.6.ebuild, iptables-1.3.6-r1.ebuild, iptables-1.3.7.ebuild,
diff --git a/net-firewall/iptables/iptables-1.4.1.1.ebuild b/net-firewall/iptables/iptables-1.4.1.1.ebuild
new file mode 100644
index 000000000000..f6ea829e56d9
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.1.1.ebuild,v 1.1 2008/06/28 17:32:24 vapier Exp $
+
+inherit eutils toolchain-funcs linux-info
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/os-headers"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+
+ local check base=${PORTAGE_CONFIGROOT}/etc/portage/patches
+ for check in {${CATEGORY}/${PF},${CATEGORY}/${P},${CATEGORY}/${PN}}; do
+ EPATCH_SOURCE=${base}/${CTARGET}/${check}
+ [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${CHOST}/${check}
+ [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${check}
+ if [[ -d ${EPATCH_SOURCE} ]] ; then
+ EPATCH_SUFFIX="patch"
+ EPATCH_FORCE="yes" \
+ EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
+ epatch
+ break
+ fi
+ done
+}
+
+src_compile() {
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --without-kernel \
+ --enable-devel \
+ --enable-libipq \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables
+}