summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-09-04 09:11:47 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-09-04 09:11:47 +0000
commiteecd19de6e7b3ddbe7eedf042237d6a2a4bb0bc7 (patch)
tree9b859281eae3b52f90f07d457cf443d6ba4cd170 /net-firewall
parentStable for ppc, wrt bug #481896 (diff)
downloadgentoo-2-eecd19de6e7b3ddbe7eedf042237d6a2a4bb0bc7.tar.gz
gentoo-2-eecd19de6e7b3ddbe7eedf042237d6a2a4bb0bc7.tar.bz2
gentoo-2-eecd19de6e7b3ddbe7eedf042237d6a2a4bb0bc7.zip
Modified version of procfs-fix patch, previous one can cause compile failures on kernels < 3.10
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipt_netflow/ChangeLog7
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-1.8-procfs-fix.patch11
2 files changed, 12 insertions, 6 deletions
diff --git a/net-firewall/ipt_netflow/ChangeLog b/net-firewall/ipt_netflow/ChangeLog
index bcc5d887f092..37bd344af642 100644
--- a/net-firewall/ipt_netflow/ChangeLog
+++ b/net-firewall/ipt_netflow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ipt_netflow
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.10 2013/08/25 15:24:17 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.11 2013/09/04 09:11:47 pinkbyte Exp $
+
+ 04 Sep 2013; Sergey Popov <pinkbyte@gentoo.org>
+ files/ipt_netflow-1.8-procfs-fix.patch:
+ Modified version of procfs-fix patch, previous one can cause compile failures
+ on kernels < 3.10
25 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> ipt_netflow-1.8-r3.ebuild:
Stable on amd64 and x86, wrt bug #481278
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-1.8-procfs-fix.patch b/net-firewall/ipt_netflow/files/ipt_netflow-1.8-procfs-fix.patch
index 3d1c44f8653c..18ab38b5aeef 100644
--- a/net-firewall/ipt_netflow/files/ipt_netflow-1.8-procfs-fix.patch
+++ b/net-firewall/ipt_netflow/files/ipt_netflow-1.8-procfs-fix.patch
@@ -2,19 +2,20 @@ Patch from http://sourceforge.net/p/ipt-netflow/bugs-requests-patches/71/
--- ipt_NETFLOW.c.orig 2013-08-21 13:20:25.606323000 +0400
+++ ipt_NETFLOW.c 2013-08-21 13:23:04.249323000 +0400
-@@ -854,9 +854,14 @@
+@@ -854,9 +854,15 @@
ipt_netflow_find(const struct ipt_netflow_tuple *tuple, unsigned int hash)
{
struct ipt_netflow *nf;
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3,9,0)
-+#define BEFORE390(x,y) x,y
struct hlist_node *pos;
-+#else /* since 3.9.0 */
-+#define BEFORE390(x,y)
+#endif
- hlist_for_each_entry(nf, pos, &ipt_netflow_hash[hash], hlist) {
-+ hlist_for_each_entry(nf, BEFORE390(pos,) &ipt_netflow_hash[hash], hlist) {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3,9,0)
++ hlist_for_each_entry(nf, pos, &ipt_netflow_hash[hash], hlist) {
++#else
++ hlist_for_each_entry(nf, &ipt_netflow_hash[hash], hlist) {
++#endif
if (ipt_netflow_tuple_equal(tuple, &nf->tuple) &&
nf->nr_bytes < FLOW_FULL_WATERMARK) {
NETFLOW_STAT_INC(found);