summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 19:51:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 19:51:36 +0000
commit314ef222df5a5202b24392855e03cf0b27db25aa (patch)
treefead7db9ada06c064851a3dceae8f52f35357af2 /net-fs/davfs2
parentRemove amd64 testing keyword on sys-kernel/hardened-sources-2.6.27-r8 (diff)
downloadgentoo-2-314ef222df5a5202b24392855e03cf0b27db25aa.tar.gz
gentoo-2-314ef222df5a5202b24392855e03cf0b27db25aa.tar.bz2
gentoo-2-314ef222df5a5202b24392855e03cf0b27db25aa.zip
Fix for gcc 4.3.3 / fortify_sources, closes #257823. Patch by <DarkNRG@gmx.de>
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/davfs2')
-rw-r--r--net-fs/davfs2/ChangeLog7
-rw-r--r--net-fs/davfs2/davfs2-1.3.3.ebuild7
-rw-r--r--net-fs/davfs2/files/fortify_sources_fix.patch11
3 files changed, 23 insertions, 2 deletions
diff --git a/net-fs/davfs2/ChangeLog b/net-fs/davfs2/ChangeLog
index 727f8ae901b7..ab2e9090fb91 100644
--- a/net-fs/davfs2/ChangeLog
+++ b/net-fs/davfs2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/davfs2
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.40 2009/01/20 15:43:12 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.41 2009/03/01 19:51:36 patrick Exp $
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/fortify_sources_fix.patch, davfs2-1.3.3.ebuild:
+ Fix for gcc 4.3.3 / fortify_sources, closes #257823. Patch by
+ <DarkNRG@gmx.de>
*davfs2-1.3.3 (20 Jan 2009)
diff --git a/net-fs/davfs2/davfs2-1.3.3.ebuild b/net-fs/davfs2/davfs2-1.3.3.ebuild
index 909d06e41407..387511dbd9ff 100644
--- a/net-fs/davfs2/davfs2-1.3.3.ebuild
+++ b/net-fs/davfs2/davfs2-1.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-1.3.3.ebuild,v 1.1 2009/01/20 15:43:12 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-1.3.3.ebuild,v 1.2 2009/03/01 19:51:36 patrick Exp $
inherit linux-mod eutils
@@ -18,6 +18,11 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
net-misc/neon
sys-libs/zlib"
SLOT="0"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/fortify_sources_fix.patch"
+}
src_compile() {
local myconf
diff --git a/net-fs/davfs2/files/fortify_sources_fix.patch b/net-fs/davfs2/files/fortify_sources_fix.patch
new file mode 100644
index 000000000000..ffc94153cf4d
--- /dev/null
+++ b/net-fs/davfs2/files/fortify_sources_fix.patch
@@ -0,0 +1,11 @@
+--- src/webdav.c.org 2009-02-14 21:30:12.600987622 +0100
++++ src/webdav.c 2009-02-14 21:33:33.020984549 +0100
+@@ -1513,7 +1513,7 @@
+
+ get_context *ctx = (get_context *) userdata;
+ if (ctx->fd == 0)
+- ctx->fd = open(ctx->file, O_WRONLY | O_CREAT | O_TRUNC);
++ ctx->fd = open(ctx->file, O_WRONLY | O_CREAT | O_TRUNC, 0666);
+ if (ctx->fd <= 0) {
+ ne_set_error(session, _("%i can't open cache file"), 0);
+ ctx->error = EIO;