summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-01 14:20:33 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-01 14:20:33 +0000
commit3ba4c0e2d978e8ec64dcf325574d17c4c81228e1 (patch)
treed6630e672e96ab36fdc5740ec9b098e899000c3e /net-fs/tahoe-lafs
parentvanilla-3.10.4 + genpatches-3.10-8 + grsecurity-2.9.1-3.10.4-201307311627 (diff)
downloadgentoo-2-3ba4c0e2d978e8ec64dcf325574d17c4c81228e1.tar.gz
gentoo-2-3ba4c0e2d978e8ec64dcf325574d17c4c81228e1.tar.bz2
gentoo-2-3ba4c0e2d978e8ec64dcf325574d17c4c81228e1.zip
fix hardcoded path to /sbin/ifconfig
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'net-fs/tahoe-lafs')
-rw-r--r--net-fs/tahoe-lafs/ChangeLog8
-rw-r--r--net-fs/tahoe-lafs/files/tahoe-lafs-1.10.0-ifconfig.patch20
-rw-r--r--net-fs/tahoe-lafs/tahoe-lafs-1.10.0-r1.ebuild (renamed from net-fs/tahoe-lafs/tahoe-lafs-1.10.0.ebuild)4
3 files changed, 29 insertions, 3 deletions
diff --git a/net-fs/tahoe-lafs/ChangeLog b/net-fs/tahoe-lafs/ChangeLog
index 96c4a1bde4f4..e13dc59722c3 100644
--- a/net-fs/tahoe-lafs/ChangeLog
+++ b/net-fs/tahoe-lafs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/tahoe-lafs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/tahoe-lafs/ChangeLog,v 1.1 2013/08/01 13:02:05 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/tahoe-lafs/ChangeLog,v 1.2 2013/08/01 14:20:33 hasufell Exp $
+
+*tahoe-lafs-1.10.0-r1 (01 Aug 2013)
+
+ 01 Aug 2013; Julian Ospald <hasufell@gentoo.org> -tahoe-lafs-1.10.0.ebuild,
+ +tahoe-lafs-1.10.0-r1.ebuild, +files/tahoe-lafs-1.10.0-ifconfig.patch:
+ fix hardcoded path to /sbin/ifconfig
*tahoe-lafs-1.10.0 (01 Aug 2013)
diff --git a/net-fs/tahoe-lafs/files/tahoe-lafs-1.10.0-ifconfig.patch b/net-fs/tahoe-lafs/files/tahoe-lafs-1.10.0-ifconfig.patch
new file mode 100644
index 000000000000..c760f60e1cc0
--- /dev/null
+++ b/net-fs/tahoe-lafs/files/tahoe-lafs-1.10.0-ifconfig.patch
@@ -0,0 +1,20 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Aug 1 14:17:10 UTC 2013
+Subject: don't hardcode ifconfig path
+
+--- allmydata-tahoe-1.10.0/src/allmydata/util/iputil.py
++++ allmydata-tahoe-1.10.0/src/allmydata/util/iputil.py
+@@ -177,11 +177,11 @@
+ _win32_re = re.compile('^\s*\d+\.\d+\.\d+\.\d+\s.+\s(?P<address>\d+\.\d+\.\d+\.\d+)\s+(?P<metric>\d+)\s*$', flags=re.M|re.I|re.S)
+
+ # These work in Redhat 6.x and Debian 2.2 potato
+-_linux_path = '/sbin/ifconfig'
++_linux_path = 'ifconfig'
+ _linux_re = re.compile('^\s*inet [a-zA-Z]*:?(?P<address>\d+\.\d+\.\d+\.\d+)\s.+$', flags=re.M|re.I|re.S)
+
+ # NetBSD 1.4 (submitted by Rhialto), Darwin, Mac OS X
+-_netbsd_path = '/sbin/ifconfig'
++_netbsd_path = 'ifconfig'
+ _netbsd_args = ('-a',)
+ _netbsd_re = re.compile('^\s+inet [a-zA-Z]*:?(?P<address>\d+\.\d+\.\d+\.\d+)\s.+$', flags=re.M|re.I|re.S)
+
diff --git a/net-fs/tahoe-lafs/tahoe-lafs-1.10.0.ebuild b/net-fs/tahoe-lafs/tahoe-lafs-1.10.0-r1.ebuild
index bd294ec12954..2527428a1e8a 100644
--- a/net-fs/tahoe-lafs/tahoe-lafs-1.10.0.ebuild
+++ b/net-fs/tahoe-lafs/tahoe-lafs-1.10.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/tahoe-lafs/tahoe-lafs-1.10.0.ebuild,v 1.1 2013/08/01 13:02:05 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/tahoe-lafs/tahoe-lafs-1.10.0-r1.ebuild,v 1.1 2013/08/01 14:20:33 hasufell Exp $
EAPI=5
@@ -44,7 +44,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
S=${WORKDIR}/${MY_P}
-PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+PATCHES=( "${FILESDIR}"/${P}-{setup,ifconfig}.patch )
src_prepare() {
rm -r setuptools* setup.cfg || die