summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-30 08:02:31 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-30 08:02:31 +0000
commit0ed13bcd6fd03b3d98304dbed67db44201183e0f (patch)
tree8618e5a4bc2b5c5235c9f50b06798a6cbc6a2f65 /net-fs
parentupdated patches... moved patches out of portage to ibiblio (diff)
downloadgentoo-2-0ed13bcd6fd03b3d98304dbed67db44201183e0f.tar.gz
gentoo-2-0ed13bcd6fd03b3d98304dbed67db44201183e0f.tar.bz2
gentoo-2-0ed13bcd6fd03b3d98304dbed67db44201183e0f.zip
added latest stable. Fixes #4808. Submitted by Frank Barton
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs/ChangeLog8
-rw-r--r--net-fs/openafs/files/digest-openafs-1.2.51
-rw-r--r--net-fs/openafs/openafs-1.2.5.ebuild92
3 files changed, 100 insertions, 1 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index 0635b419df4f..2a8c91258af5 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for net-fs/openafs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.2 2002/07/30 05:08:52 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.3 2002/07/30 08:02:31 rphillips Exp $
*openafs-1.3.2 (29 Jul 2002)
@@ -8,6 +8,12 @@
Masked unstable version.
+*openafs-1.2.5 (30 Jul 2002)
+
+ 30 Jul 2002; Ryan Phillips <rphillips@gentoo.org> openafs-1.2.5.ebuild :
+
+ Added latest stable version
+
*openafs-1.2.2-r7 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/net-fs/openafs/files/digest-openafs-1.2.5 b/net-fs/openafs/files/digest-openafs-1.2.5
new file mode 100644
index 000000000000..36c605500ab8
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.2.5
@@ -0,0 +1 @@
+MD5 2d3380bc226fdedb9a74804412743349 openafs-1.2.5-src.tar.bz2 10223247
diff --git a/net-fs/openafs/openafs-1.2.5.ebuild b/net-fs/openafs/openafs-1.2.5.ebuild
new file mode 100644
index 000000000000..de5f0a378850
--- /dev/null
+++ b/net-fs/openafs/openafs-1.2.5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Frank C. Barton <bartof@rpi.edu>
+# /home/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.5.ebuild,v 1.0 2002/07/10 09:52:39 pm Exp
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 distributed file system targets the issues critical to
+distributed computing environments. AFS performs exceptionally well,
+both within small, local work groups of machines and across wide-area
+configurations in support of large, collaborative efforts. AFS provides
+an architecture geared towards system management, along with the tools
+to perform important management tasks. For a user, AFS is a familiar yet
+extensive UNIX environment for accessing files easily and quickly."
+
+SRC_URI="http://openafs.org/dl/openafs/1.2.5/openafs-1.2.5-src.tar.bz2"
+HOMEPAGE="http://www.openafs.org/"
+LICENSE="IPL-1"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
+
+ARCH=i386_linux24
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/config
+ cp Makefile.i386_linux24.in Makefile.i386_linux24.in.old
+ sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
+ Makefile.i386_linux24.in.old > Makefile.i386_linux24.in
+ rm Makefile.i386_linux24.in.old
+}
+
+src_compile() {
+ ./configure --with-afs-sysname=i386_linux24 --enable-transarc-paths || die
+ make || die
+ make dest || die
+}
+
+src_install () {
+
+
+ # Client
+
+ cd ${S}/${ARCH}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ dodir /afs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/afs.rc.rc6 afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/${ARCH}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/${ARCH}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+}
+
+pkg_postinst () {
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
+}