summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2005-11-08 13:16:13 +0000
committerChristian Andreetta <satya@gentoo.org>2005-11-08 13:16:13 +0000
commit22c5a19ba6e2421d8c338e60e201d582682c4352 (patch)
tree697e83f2c6577521e177a33d75a92f91e13e89da /net-fs
parentVersion bump (diff)
downloadgentoo-2-22c5a19ba6e2421d8c338e60e201d582682c4352.tar.gz
gentoo-2-22c5a19ba6e2421d8c338e60e201d582682c4352.tar.bz2
gentoo-2-22c5a19ba6e2421d8c338e60e201d582682c4352.zip
'examples' IUSE flag (bug #111508)
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog7
-rw-r--r--net-fs/samba/samba-3.0.14a-r2.ebuild19
-rw-r--r--net-fs/samba/samba-3.0.14a-r3.ebuild17
-rw-r--r--net-fs/samba/samba-3.0.20-r1.ebuild17
-rw-r--r--net-fs/samba/samba-3.0.20a.ebuild17
-rw-r--r--net-fs/samba/samba-3.0.20b.ebuild17
6 files changed, 52 insertions, 42 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index b1a5a494e7d1..b5c989f227d6 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/samba
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.210 2005/10/29 11:07:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.211 2005/11/08 13:16:13 satya Exp $
+
+ 08 Nov 2005; Christian Andreetta <satya@gentoo.org>
+ samba-3.0.14a-r2.ebuild, samba-3.0.14a-r3.ebuild, samba-3.0.20-r1.ebuild,
+ samba-3.0.20a.ebuild, samba-3.0.20b.ebuild:
+ 'examples' IUSE flag (bug #111508)
29 Oct 2005; Diego Pettenò <flameeyes@gentoo.org> samba-3.0.20b.ebuild:
Disable pie support for *BSD systems as it's not supported. Fixes bug #110278.
diff --git a/net-fs/samba/samba-3.0.14a-r2.ebuild b/net-fs/samba/samba-3.0.14a-r2.ebuild
index 0810c3e5a727..212498bbd4d6 100644
--- a/net-fs/samba/samba-3.0.14a-r2.ebuild
+++ b/net-fs/samba/samba-3.0.14a-r2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.14a-r2.ebuild,v 1.18 2005/10/03 11:59:36 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.14a-r2.ebuild,v 1.19 2005/11/08 13:16:13 satya Exp $
inherit eutils versionator
IUSE_LINGUAS="ja pl"
-IUSE="acl cups doc kerberos ldap mysql pam postgres python quotas readline
-winbind xml xml2 libclamav oav selinux"
+IUSE="acl cups doc examples kerberos ldap mysql pam postgres python quotas
+ readline winbind xml xml2 libclamav oav selinux"
VSCAN_VER=0.3.6
PATCH_VER=0.3.3
@@ -230,14 +230,15 @@ src_install() {
# docs
dodoc ${S2}/{COPYING,Manifest,README,Roadmap,WHATSNEW.txt}
- docinto examples
dodoc ${CONFDIR}/nsswitch.conf-wins
use winbind && dodoc ${CONFDIR}/nsswitch.conf-winbind
-
- cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
-
- chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
- chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+
+ if use examples; then
+ docinto examples
+ cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
+ chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
+ chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ fi
if use oav; then
docinto ${PFVSCAN}
diff --git a/net-fs/samba/samba-3.0.14a-r3.ebuild b/net-fs/samba/samba-3.0.14a-r3.ebuild
index b8672b1ee08c..58fac4cdabaa 100644
--- a/net-fs/samba/samba-3.0.14a-r3.ebuild
+++ b/net-fs/samba/samba-3.0.14a-r3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.14a-r3.ebuild,v 1.6 2005/10/03 11:59:36 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.14a-r3.ebuild,v 1.7 2005/11/08 13:16:13 satya Exp $
inherit eutils versionator
IUSE_LINGUAS="ja pl"
-IUSE="acl cups doc kerberos ldap mysql pam postgres python quotas readline
-winbind xml xml2 libclamav oav selinux"
+IUSE="acl cups doc examples kerberos ldap mysql pam postgres python quotas
+ readline winbind xml xml2 libclamav oav selinux"
VSCAN_VER=0.3.6
PATCH_VER=0.3.4
@@ -230,14 +230,15 @@ src_install() {
# docs
dodoc ${S2}/{COPYING,Manifest,README,Roadmap,WHATSNEW.txt}
- docinto examples
dodoc ${CONFDIR}/nsswitch.conf-wins
use winbind && dodoc ${CONFDIR}/nsswitch.conf-winbind
- cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
-
- chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
- chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ if use examples; then
+ docinto examples
+ cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
+ chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
+ chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ fi
if use oav; then
docinto ${PFVSCAN}
diff --git a/net-fs/samba/samba-3.0.20-r1.ebuild b/net-fs/samba/samba-3.0.20-r1.ebuild
index 8855548d1bd8..a4ed77c316de 100644
--- a/net-fs/samba/samba-3.0.20-r1.ebuild
+++ b/net-fs/samba/samba-3.0.20-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.20-r1.ebuild,v 1.3 2005/09/23 16:33:57 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.20-r1.ebuild,v 1.4 2005/11/08 13:16:13 satya Exp $
inherit eutils versionator
IUSE_LINGUAS="ja pl"
-IUSE="acl async automount cups doc kerberos ldap mysql pam postgres python quotas
- readline syslog winbind xml xml2 libclamav oav selinux"
+IUSE="acl async automount cups doc examples kerberos ldap mysql pam postgres
+ python quotas readline syslog winbind xml xml2 libclamav oav selinux"
RESTRICT="test"
VSCAN_VER=0.3.6
@@ -241,14 +241,15 @@ src_install() {
# docs
dodoc ${FILESDIR}/README.gentoo
dodoc ${S2}/{COPYING,Manifest,README,Roadmap,WHATSNEW.txt}
- docinto examples
dodoc ${CONFDIR}/nsswitch.conf-wins
use winbind && dodoc ${CONFDIR}/nsswitch.conf-winbind
- cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
-
- chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
- chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ if use examples; then
+ docinto examples
+ cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
+ chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
+ chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ fi
if use oav; then
docinto ${PFVSCAN}
diff --git a/net-fs/samba/samba-3.0.20a.ebuild b/net-fs/samba/samba-3.0.20a.ebuild
index 339c59b04a3e..483a99c3c091 100644
--- a/net-fs/samba/samba-3.0.20a.ebuild
+++ b/net-fs/samba/samba-3.0.20a.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.20a.ebuild,v 1.1 2005/10/06 14:55:45 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.20a.ebuild,v 1.2 2005/11/08 13:16:13 satya Exp $
inherit eutils versionator
IUSE_LINGUAS="ja pl"
-IUSE="acl async automount cups doc kerberos ldap mysql pam postgres python quotas
- readline syslog winbind xml xml2 libclamav oav selinux"
+IUSE="acl async automount cups doc examples kerberos ldap mysql pam postgres
+ python quotas readline syslog winbind xml xml2 libclamav oav selinux"
RESTRICT="test"
VSCAN_VER=0.3.6
@@ -241,14 +241,15 @@ src_install() {
# docs
dodoc ${FILESDIR}/README.gentoo
dodoc ${S2}/{COPYING,Manifest,README,Roadmap,WHATSNEW.txt}
- docinto examples
dodoc ${CONFDIR}/nsswitch.conf-wins
use winbind && dodoc ${CONFDIR}/nsswitch.conf-winbind
- cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
-
- chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
- chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ if use examples; then
+ docinto examples
+ cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
+ chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
+ chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ fi
if use oav; then
docinto ${PFVSCAN}
diff --git a/net-fs/samba/samba-3.0.20b.ebuild b/net-fs/samba/samba-3.0.20b.ebuild
index 053a7518e14e..60dc49f8aef5 100644
--- a/net-fs/samba/samba-3.0.20b.ebuild
+++ b/net-fs/samba/samba-3.0.20b.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.20b.ebuild,v 1.3 2005/10/29 11:07:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.20b.ebuild,v 1.4 2005/11/08 13:16:13 satya Exp $
inherit eutils versionator
IUSE_LINGUAS="ja pl"
-IUSE="acl async automount cups doc kerberos ldap ldapsam libclamav mysql oav
- pam postgres python quotas readline selinux swat syslog winbind xml xml2"
+IUSE="acl async automount cups doc examples kerberos ldap ldapsam libclamav mysql
+ oav pam postgres python quotas readline selinux swat syslog winbind xml xml2"
RESTRICT="test"
VSCAN_VER=0.3.6
@@ -247,7 +247,6 @@ src_install() {
# docs
dodoc ${FILESDIR}/README.gentoo
dodoc ${S2}/{COPYING,Manifest,README,Roadmap,WHATSNEW.txt}
- docinto examples
dodoc ${CONFDIR}/nsswitch.conf-wins
use winbind && dodoc ${CONFDIR}/nsswitch.conf-winbind
@@ -258,10 +257,12 @@ src_install() {
dodoc */*.conf
fi
- cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
-
- chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
- chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ if use examples; then
+ docinto examples
+ cp -pPR ${S2}/examples/* ${D}/usr/share/doc/${PF}/examples
+ chmod -R 755 `find ${D}/usr/share/doc/${PF}/examples -type d`
+ chmod -R 644 `find ${D}/usr/share/doc/${PF}/examples ! -type d`
+ fi
if ! use doc; then
if ! use swat; then