summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2009-01-20 09:09:43 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2009-01-20 09:09:43 +0000
commit4f7ce4453525882dbf587ecaa1d4ded9d93a1b41 (patch)
tree8795d380087ec57d410d4680f8e3bd2385bc5940 /net-fs
parentexplicitly set RDEPEND to DEPEND (diff)
downloadgentoo-2-4f7ce4453525882dbf587ecaa1d4ded9d93a1b41.tar.gz
gentoo-2-4f7ce4453525882dbf587ecaa1d4ded9d93a1b41.tar.bz2
gentoo-2-4f7ce4453525882dbf587ecaa1d4ded9d93a1b41.zip
Introducing new patches from upstream, in an attempt to fix bugs #253806 and #255369
(Portage version: 2.2_rc21/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog9
-rw-r--r--net-fs/autofs/autofs-5.0.4-r1.ebuild84
2 files changed, 92 insertions, 1 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 9cb4c7c59e22..6e873e720d56 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/autofs
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.77 2009/01/04 12:31:28 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.78 2009/01/20 09:09:43 stefaan Exp $
+
+*autofs-5.0.4-r1 (20 Jan 2009)
+
+ 20 Jan 2009; Stefaan De Roeck <stefaan@gentoo.org>
+ +autofs-5.0.4-r1.ebuild:
+ Introducing new patches from upstream, in an attempt to fix bugs #253806
+ and #255369
*autofs-5.0.4 (04 Jan 2009)
diff --git a/net-fs/autofs/autofs-5.0.4-r1.ebuild b/net-fs/autofs/autofs-5.0.4-r1.ebuild
new file mode 100644
index 000000000000..2c6f3c971fbf
--- /dev/null
+++ b/net-fs/autofs/autofs-5.0.4-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.4-r1.ebuild,v 1.1 2009/01/20 09:09:43 stefaan Exp $
+
+inherit eutils multilib autotools
+
+IUSE="ldap sasl"
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI_BASE="mirror://kernel/linux/daemons/${PN}/v5"
+# This list is taken directly from http://kernel.org/pub/linux/daemons/autofs/v5/patch_order-5.0.3
+# Please do not modify the order
+PATCH_LIST="
+ ${P}-fix-dumb-libxml2-check.patch
+ ${P}-expire-specific-submount-only.patch
+ ${P}-fix-negative-cache-non-existent-key.patch
+ ${P}-fix-ldap-detection.patch
+ ${P}-use-CLOEXEC-flag.patch
+ ${P}-fix-select-fd-limit.patch
+ ${P}-make-hash-table-scale-to-thousands-of-entries.patch"
+SRC_URI="${SRC_URI_BASE}/${P}.tar.bz2"
+for i in ${PATCH_LIST} ; do
+ SRC_URI="${SRC_URI} ${SRC_URI_BASE}/${i}"
+done ;
+DEPEND="virtual/libc
+ ldap? ( >=net-nds/openldap-2.0 )
+ sasl? ( virtual/krb5 )"
+ # currently, sasl code assumes the presence of kerberosV
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ for i in ${PATCH_LIST}; do
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${DISTDIR}"/${i}
+ done
+
+ cd "${S}"
+
+ # fixes bug #210762
+ epatch "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
+
+ # fixes bugs #253412 and #247969
+ epatch "${FILESDIR}"/${P}-user-ldflags-and-as-needed.patch
+
+ # # use CC and CFLAGS from environment (bug #154797)
+ # write these values in Makefile.conf
+ (echo "# Use the compiler and cflags determined by configure";
+ echo "CC := @CC@"; echo "CFLAGS := @CFLAGS@") >> Makefile.conf.in
+ # make sure Makefile.conf is parsed after Makefile.rules
+ sed -ni '/include Makefile.conf/{x; n; G}; p' Makefile
+ sed -i 's/^\(CC\|CXX\).*//' Makefile.rules
+ sed -i 's/^CFLAGS=-fPIE.*//' configure.in
+
+ # do not include <nfs/nfs.h>, rather <linux/nfs.h>,
+ # as the former is a lame header for the latter (bug #157968)
+ sed -i 's@nfs/nfs.h@linux/nfs.h@' include/rpc_subs.h
+
+ eautoreconf || die "Autoconf failed"
+}
+
+src_compile() {
+ CFLAGS="${CFLAGS}" \
+ econf \
+ $(use_with ldap openldap) \
+ $(use_with sasl) \
+ --enable-ignore-busy \
+ || die "configure failed"
+
+ emake DONTSTRIP=1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}"/autofs5.rc1 autofs
+}
+
+pkg_postinst() {
+ elog "Note: If you plan on using autofs for automounting"
+ elog "remote NFS mounts without having the NFS daemon running"
+ elog "please add portmap to your default run-level."
+}