summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-11-11 12:38:03 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-11-11 12:38:03 +0000
commit8140ca35e6f731b66dfc979c7704f26ac4f8b2a7 (patch)
treeb5f268da780ed3d439136124b7eb8c8e24f41504 /net-fs
parentNew version, 2.6 support in (diff)
downloadgentoo-2-8140ca35e6f731b66dfc979c7704f26ac4f8b2a7.tar.gz
gentoo-2-8140ca35e6f731b66dfc979c7704f26ac4f8b2a7.tar.bz2
gentoo-2-8140ca35e6f731b66dfc979c7704f26ac4f8b2a7.zip
New version, 2.6 support in
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/shfs/ChangeLog7
-rw-r--r--net-fs/shfs/Manifest5
-rw-r--r--net-fs/shfs/files/digest-shfs-0.321
-rw-r--r--net-fs/shfs/shfs-0.32.ebuild101
4 files changed, 111 insertions, 3 deletions
diff --git a/net-fs/shfs/ChangeLog b/net-fs/shfs/ChangeLog
index a78709cd28fd..cba0873a39d1 100644
--- a/net-fs/shfs/ChangeLog
+++ b/net-fs/shfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/shfs
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.5 2003/10/21 17:11:54 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.6 2003/11/11 12:37:55 lu_zero Exp $
+
+*shfs-0.32 (11 Nov 2003)
+
+ 11 Nov 2003; Luca Barbato <lu_zero@gentoo.org> shfs-0.32.ebuild:
+ New version, linux-2.6 support available.
21 Oct 2003; <lu_zero@gentoo.org> shfs-0.31-r1.ebuild: Fixed the ppc patch
and made it use src_unpack. Works again on ppc.
diff --git a/net-fs/shfs/Manifest b/net-fs/shfs/Manifest
index cf981de71816..aa4ad2f97ace 100644
--- a/net-fs/shfs/Manifest
+++ b/net-fs/shfs/Manifest
@@ -1,5 +1,6 @@
-MD5 b8cbda92d3f8788ebc8b4d206a5ef644 ChangeLog 1594
-MD5 d08b7078941056ab63096eba17be3f43 shfs-0.32.ebuild 2902
+MD5 ea0917226ea03cb240e8b621c39f9411 ChangeLog 1594
+MD5 82745d4694e05a78137b9a538efacecf shfs-0.32.ebuild 2899
+MD5 6075e6f8e572e5c88478b3a09ec234cb shfs-0.31.ebuild 1761
MD5 19c5d5e899a08787544dfa1caf39a9e0 shfs-0.31-r1.ebuild 2658
MD5 307c4e9fea61efad863724d214fcb916 files/shfs-amd64-makefile.patch 653
MD5 97e8d1e483ac538a072e0e82af787eeb files/amd.shfs 152
diff --git a/net-fs/shfs/files/digest-shfs-0.32 b/net-fs/shfs/files/digest-shfs-0.32
new file mode 100644
index 000000000000..589486862534
--- /dev/null
+++ b/net-fs/shfs/files/digest-shfs-0.32
@@ -0,0 +1 @@
+MD5 477c4236f24c770238075f04de38fd71 shfs-0.32.tar.gz 96346
diff --git a/net-fs/shfs/shfs-0.32.ebuild b/net-fs/shfs/shfs-0.32.ebuild
new file mode 100644
index 000000000000..32294fb23926
--- /dev/null
+++ b/net-fs/shfs/shfs-0.32.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/shfs-0.32.ebuild,v 1.1 2003/11/11 12:37:55 lu_zero Exp $
+
+IUSE="amd doc"
+
+DESCRIPTION="Secure Shell File System"
+HOMEPAGE="http://shfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+DEPEND="virtual/linux-sources
+ net-misc/openssh
+ amd? ( net-fs/am-utils )"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+
+ cd ${S}/shfsmount
+ emake ROOT=${D} MODULESDIR=${D}/lib/modules/${KV} \
+ KERNEL_SOURCES=/usr/src/linux || die
+
+ if [ "`echo ${KV}|grep 2.6`" ] ; then
+ cd ${S}/shfs/Linux-2.6/
+ GENTOO_ARCH=${ARCH}
+ unset ARCH
+ addwrite "/usr/src/${FK}"
+ export _POSIX2_VERSION=199209
+ emake -j1 -C /usr/src/linux SUBDIRS="`pwd`" modules || die
+ export ARCH=GENTOO_ARCH
+ else
+ cd ${S}/shfs/Linux-2.4/
+ emake ROOT=${D} MODULESDIR=${D}/lib/modules/${KV} \
+ KERNEL_SOURCES=/usr/src/linux || die
+ fi
+
+}
+
+src_install() {
+ # Install kernel module
+ cd ${S}/shfs/Linux-`echo ${KV}|sed "s/^\([0-9]*\.[0-9]*\).*/\1/"`
+
+ dodir /lib/modules/${KV}/kernel/fs/shfs/
+ insinto /lib/modules/${KV}/kernel/fs/shfs/
+ doins shfs.ko || die
+
+# Install binaries
+ cd ${S}/shfsmount
+ dobin shfsmount
+ dobin shfsumount
+
+ # Allows users to mount/umount
+ einfo " Setting suid bit on /usr/bin executables..."
+ fperms 4511 /usr/bin/shfsmount
+ fperms 4511 /usr/bin/shfsumount
+
+ # Performs symlink to support use of mount(8)
+ dodir /sbin
+ einfo " Adding /sbin/mount.shfs symlink..."
+ dosym /usr/bin/shfsmount /sbin/mount.shfs
+
+ # Install docs
+ doman ${S}/docs/manpages/shfsmount.8 ${S}/docs/manpages/shfsumount.8
+ use doc && dohtml -r ${S}/docs/html
+
+ # Install automount support (if desired)
+ if [ -n "`use amd`" ] ; then
+ einfo " Installing am-utils config files..."
+ insinto /etc/amd
+ doins ${FILESDIR}/amd.conf
+ doins ${FILESDIR}/amd.shfs
+ exeinto /etc/amd
+ doexe ${FILESDIR}/shfs.mount
+ dosym /etc/amd/shfs.mount /etc/amd/shfs.unmount
+ fi
+}
+
+pkg_postinst() {
+ echo "running depmod...."
+ depmod -aq || die
+
+ echo " "
+ einfo " Use either 'shfsmount' or 'mount -t shfs' to mount remote"
+ einfo " filesystems to into your local filesystem. "
+ echo " "
+ echo " "
+ einfo " Note the following: "
+ einfo " "
+ einfo " 1. The shfs.o kernel module has to be loaded first "
+ einfo " before you can start mounting filesystems. "
+ einfo " Try: 'insmod shfs' as root. "
+ einfo " "
+ einfo " 2. When mounting, you must enter the absolute path of "
+ einfo " the remote filesystem without any special chars, "
+ einfo " such as tilde (~), for example. "
+ echo " "
+}