summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-05 20:29:57 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-05 20:29:57 +0000
commitc0835993e572dfaefdfa1b4ba49548479ea9d253 (patch)
tree0abf76506a24599a25d8e4e71d417dade0357ab8 /net-ftp/ftpcube
parentAdded more themes. Submitted by Arvind <alibombali780@hotmail.com> in #20447. (diff)
downloadgentoo-2-c0835993e572dfaefdfa1b4ba49548479ea9d253.tar.gz
gentoo-2-c0835993e572dfaefdfa1b4ba49548479ea9d253.tar.bz2
gentoo-2-c0835993e572dfaefdfa1b4ba49548479ea9d253.zip
fix missing x problem
Diffstat (limited to 'net-ftp/ftpcube')
-rw-r--r--net-ftp/ftpcube/ChangeLog5
-rw-r--r--net-ftp/ftpcube/Manifest4
-rw-r--r--net-ftp/ftpcube/ftpcube-0.4.3.ebuild14
3 files changed, 18 insertions, 5 deletions
diff --git a/net-ftp/ftpcube/ChangeLog b/net-ftp/ftpcube/ChangeLog
index 189d2ed5f70a..c59e828742b1 100644
--- a/net-ftp/ftpcube/ChangeLog
+++ b/net-ftp/ftpcube/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-ftp/ftpcube
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ChangeLog,v 1.14 2003/05/05 09:19:21 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ChangeLog,v 1.15 2003/05/05 20:29:48 liquidx Exp $
+
+ 05 May 2003; Alastair Tse <liquidx@gentoo.org> ftpcube-0.4.3.ebuild:
+ added virtualx support to prevent failing when merging without X
05 May 2003; Alastair Tse <liquidx@gentoo.org> ftpcube-0.4.1.ebuild,
ftpcube-0.4.2.ebuild, ftpcube-0.4.3.ebuild:
diff --git a/net-ftp/ftpcube/Manifest b/net-ftp/ftpcube/Manifest
index b6f868ea64ed..7d3abd2c3024 100644
--- a/net-ftp/ftpcube/Manifest
+++ b/net-ftp/ftpcube/Manifest
@@ -1,6 +1,6 @@
-MD5 af68509bc224b72070e3dcd850be7aee ChangeLog 2298
+MD5 947ad1d926f25fe96fad38d5f3b4265c ChangeLog 2437
MD5 f9935ddf4cc425a1d87bb22db65da7fc ftpcube-0.4.2.ebuild 618
-MD5 deb03188826aaf16dba5708d00fe1bc2 ftpcube-0.4.3.ebuild 618
+MD5 c9e1411545ef35a2bf81df6bbe0f87f8 ftpcube-0.4.3.ebuild 769
MD5 b270e455be656571d477733646d703bc ftpcube-0.4.0.ebuild 1227
MD5 9bfef7f121eb4173e2eeef12e975c3f8 ftpcube-0.4.1.ebuild 602
MD5 9313a79ec3125eb37447dbd470da91a3 files/ftpcube-0.4.2-gentoo.patch 671
diff --git a/net-ftp/ftpcube/ftpcube-0.4.3.ebuild b/net-ftp/ftpcube/ftpcube-0.4.3.ebuild
index 25eaf771d17b..b5fefad07947 100644
--- a/net-ftp/ftpcube/ftpcube-0.4.3.ebuild
+++ b/net-ftp/ftpcube/ftpcube-0.4.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.4.3.ebuild,v 1.2 2003/05/05 09:19:21 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.4.3.ebuild,v 1.3 2003/05/05 20:29:48 liquidx Exp $
IUSE=""
-inherit distutils
+inherit distutils virtualx
S="${WORKDIR}/${P}"
DESCRIPTION="Graphical FTP client using wxPython"
@@ -21,3 +21,13 @@ src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
}
+
+src_compile() {
+ export maketype=distutils_src_compile
+ virtualmake
+}
+
+src_install() {
+ export maketype=distutils_src_install
+ virtualmake
+}