summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-08-26 18:55:44 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-08-26 18:55:44 +0000
commita3c572c269e2310d3dede2e82748bc1bf62af481 (patch)
treeb04df8cce1c866bf2d16dcc506624c5b29c4d067 /net-ftp/gproftpd/gproftpd-8.3.2.ebuild
parentPunt old version. (diff)
downloadgentoo-2-a3c572c269e2310d3dede2e82748bc1bf62af481.tar.gz
gentoo-2-a3c572c269e2310d3dede2e82748bc1bf62af481.tar.bz2
gentoo-2-a3c572c269e2310d3dede2e82748bc1bf62af481.zip
Version bump, purge old version
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-ftp/gproftpd/gproftpd-8.3.2.ebuild')
-rw-r--r--net-ftp/gproftpd/gproftpd-8.3.2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-ftp/gproftpd/gproftpd-8.3.2.ebuild b/net-ftp/gproftpd/gproftpd-8.3.2.ebuild
new file mode 100644
index 000000000000..94a12a31ada0
--- /dev/null
+++ b/net-ftp/gproftpd/gproftpd-8.3.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gproftpd/gproftpd-8.3.2.ebuild,v 1.1 2007/08/26 18:55:44 dertobi123 Exp $
+
+DESCRIPTION="GTK frontend to proftpd"
+HOMEPAGE="http://mange.dynup.net/linux.html"
+SRC_URI="http://mange.dynup.net/linux/gproftpd/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+IUSE="gnome ssl"
+
+# Requiring ProFTPD 1.2.9 due to security fixes
+DEPEND=">=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ >=x11-libs/pango-1.0
+ >=dev-libs/atk-1.0
+ dev-util/pkgconfig
+ >=media-libs/freetype-2.0
+ ssl? ( >=dev-libs/openssl-0.9.6f )"
+
+RDEPEND="${DEPEND}
+ >=net-ftp/proftpd-1.2.9"
+
+src_compile() {
+ local modules includes myconf
+
+ #location of proftpd.conf
+ myconf="/etc/proftpd"
+
+ if use ssl; then
+ # enable mod_tls
+ modules="${modules}:mod_tls"
+ includes="${include}:/usr/kerberos/include"
+ fi
+
+ econf --sysconfdir=${myconf} \
+ --localstatedir=/var \
+ --with-modules=${modules} \
+ --with-includes=${includes} || die "./configure failed"
+ emake || die "Build failure"
+}
+
+src_install () {
+ emake DESTDIR=${D} install || die "Installation failure"
+
+# Add the Gnome menu entry
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Internet/
+ doins ${S}/desktop/net-gproftpd.desktop
+ fi
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL README
+}
+
+pkg_postinst() {
+ elog "gproftpd looks for your proftpd.conf file in /etc/proftpd"
+ elog "run gproftpd with the option -c to specify an alternate location"
+ elog "ex: gproftpd -c /etc/proftpd.conf"
+ elog "Do NOT edit /etc/conf.d/proftpd with this program"
+}