summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-09 22:09:17 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-09 22:09:17 +0000
commit9ec2f7750fbe420ad100db46d04faf173a454bf2 (patch)
tree336540952c7e93c82b3c46f04e1484ccda86c7c6 /net-ftp/pure-ftpd
parentadding mjpegtools (diff)
downloadgentoo-2-9ec2f7750fbe420ad100db46d04faf173a454bf2.tar.gz
gentoo-2-9ec2f7750fbe420ad100db46d04faf173a454bf2.tar.bz2
gentoo-2-9ec2f7750fbe420ad100db46d04faf173a454bf2.zip
Version bump and updated ldap support.
Diffstat (limited to 'net-ftp/pure-ftpd')
-rw-r--r--net-ftp/pure-ftpd/ChangeLog9
-rw-r--r--net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.141
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.14.ebuild66
3 files changed, 75 insertions, 1 deletions
diff --git a/net-ftp/pure-ftpd/ChangeLog b/net-ftp/pure-ftpd/ChangeLog
index 56459ee03c6a..079bab007d2f 100644
--- a/net-ftp/pure-ftpd/ChangeLog
+++ b/net-ftp/pure-ftpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/pure-ftpd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.9 2003/01/29 21:54:28 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.10 2003/02/09 22:09:17 raker Exp $
+
+*pure-ftpd-1.0.14 (09 Feb 2003)
+
+ 09 Feb 2003; Nick Hadaway <raker@gentoo.org> pure-ftpd-1.0.14.ebuild,
+ files/digest-pure-ftpd-1.0.14 :
+ Version bump. Added some logic to complete ldap support as suggested
+ in bug #15367 by claer@unixlover.com
*pure-ftpd-1.0.13a (28 Jan 2003)
diff --git a/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.14 b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.14
new file mode 100644
index 000000000000..044a17602523
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.14
@@ -0,0 +1 @@
+MD5 b650c4d6f59ec0781b33876932ea2038 pure-ftpd-1.0.14.tar.bz2 427014
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.14.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.14.ebuild
new file mode 100644
index 000000000000..2829fc9b9dad
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-1.0.14.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/pure-ftpd-1.0.14.ebuild,v 1.1 2003/02/09 22:09:17 raker Exp $
+
+DESCRIPTION="Pure-FTPd is a fast, production-quality, standard-conformant FTP server"
+SRC_URI="ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/${P}.tar.bz2"
+HOMEPAGE="http://www.pureftpd.org/"
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3* )
+ postgres? ( >=dev-db/postgresql-7.2.2 )
+ ldap? ( >=net-nds/openldap-2.0.25 )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="pam mysql postgres ldap"
+
+src_compile() {
+ use pam && myconf="${myconf} --with-pam"
+ use ldap && myconf="${myconf} --with-ldap"
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+
+ econf --with-altlog --with-extauth \
+ --with-puredb --with-cookie \
+ --with-throttling --with-ratios \
+ --with-quotas --with-ftpwho \
+ --with-uploadscript --with-virtualhosts \
+ --with-virtualchroot --with-diraliases \
+ --with-peruserlimits ${myconf}
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall
+
+ dodoc AUTHORS CONTACT COPYING ChangeLog FAQ HISTORY INSTALL README* NEWS
+
+ dodir /etc/{conf.d,init.d}
+ cp ${FILESDIR}/ftpusers ${D}/etc/ftpusers
+ cp ${FILESDIR}/pure-ftpd.conf_d ${D}/etc/conf.d/pure-ftpd
+
+ use pam && insinto /etc/pam.d && doins pam/{ftplockout,pure-ftpd}
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pure-ftpd.rc6-r1 pure-ftpd
+
+ insopts -m 644
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/pure-ftpd.xinetd pure-ftpd
+
+ if [ `use ldap` ]; then
+ dodir /etc/openldap/schema
+ insinto /etc/openldap/schema
+ doins openldap.schema
+ insinto /etc/openldap
+ doins pureftpd-ldap.conf
+ fi
+}
+
+pkg_postinst() {
+ einfo "Before starting Pure-FTPd, you have to edit the /etc/conf.d/pure-ftpd file."
+ echo
+ ewarn "It's *really* important to read the README provided with Pure-FTPd."
+ ewarn "Just point your browser at http://www.pureftpd.org/README"
+}