summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-09-23 23:53:49 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-09-23 23:53:49 +0000
commita7c0b6cdc65ee47a85af7d8c46b61bf52f3fa478 (patch)
tree32d74f827ab1f2ddcebfcf0e55a6e25893063363 /net-ftp/pureadmin/pureadmin-0.3.ebuild
parentVersion bump, closes bug #148518. (diff)
downloadgentoo-2-a7c0b6cdc65ee47a85af7d8c46b61bf52f3fa478.tar.gz
gentoo-2-a7c0b6cdc65ee47a85af7d8c46b61bf52f3fa478.tar.bz2
gentoo-2-a7c0b6cdc65ee47a85af7d8c46b61bf52f3fa478.zip
Cleanup ebuilds. Version bump to 0.3. Fix bugs.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-ftp/pureadmin/pureadmin-0.3.ebuild')
-rw-r--r--net-ftp/pureadmin/pureadmin-0.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-ftp/pureadmin/pureadmin-0.3.ebuild b/net-ftp/pureadmin/pureadmin-0.3.ebuild
new file mode 100644
index 000000000000..6e709c4cf38d
--- /dev/null
+++ b/net-ftp/pureadmin/pureadmin-0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.3.ebuild,v 1.1 2006/09/23 23:53:49 chtekk Exp $
+
+inherit eutils
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="PureAdmin is a GUI tool used to make the management of Pure-FTPd a little easier."
+HOMEPAGE="http://purify.sourceforge.net/"
+SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug doc"
+
+DEPEND=">=gnome-base/libglade-2.0
+ sys-libs/zlib
+ virtual/fam
+ >=x11-libs/gtk+-2.0"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Move the docs to the correct location, if we want the docs
+ if use doc ; then
+ dodoc "${D}/usr/share/doc/pureadmin/*.txt"
+ fi
+ rm -Rf "${D}/usr/share/doc/pureadmin"
+
+ make_desktop_entry pureadmin "Pure-FTPd menu config" pureadmin
+}
+
+pkg_postinst() {
+ einfo
+ ewarn "PureAdmin is at a beta-stage right now and it may break your"
+ ewarn "configuration. DO NOT use it for safety critical system"
+ ewarn "or production use!"
+ einfo
+ einfo "You need root-privileges to be able to use PureAdmin."
+ einfo "This will probably change in the future."
+ einfo
+}