summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-12-02 18:49:05 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-12-02 18:49:05 +0000
commit3528864db3ecda074a7d4d0823fe0b31d6308965 (patch)
tree22d5afbd18358414237ab8f3ac7c1a6ca1c30895 /net-ftp
parentrepoman fix (diff)
downloadgentoo-2-3528864db3ecda074a7d4d0823fe0b31d6308965.tar.gz
gentoo-2-3528864db3ecda074a7d4d0823fe0b31d6308965.tar.bz2
gentoo-2-3528864db3ecda074a7d4d0823fe0b31d6308965.zip
new version since 11-04
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog10
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.6.31
-rw-r--r--net-ftp/lftp/lftp-2.6.3.ebuild68
3 files changed, 78 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 5e3d7aa4d111..6df108c5c0ed 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.13 2002/09/17 22:47:39 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.14 2002/12/02 18:49:05 spider Exp $
+
+
+*lftp-2.6.3 (02 Dec 2002)
+
+ 02 Dec 2002; Spider <spider@gentoo.org> lftp-2.6.3.ebuild :
+ in my quest to get my suddenly broken ftp-ssl to work I'm updating this
+ ebuild to the latest version avaiable. KEWORDS set to ~ where not -
+
*lftp-2.6.2 (11 Sep 2002)
diff --git a/net-ftp/lftp/files/digest-lftp-2.6.3 b/net-ftp/lftp/files/digest-lftp-2.6.3
new file mode 100644
index 000000000000..8f61e4939c48
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.6.3
@@ -0,0 +1 @@
+MD5 ea369708825cd9fbd22bb4727abaa4a9 lftp-2.6.3.tar.bz2 1126534
diff --git a/net-ftp/lftp/lftp-2.6.3.ebuild b/net-ftp/lftp/lftp-2.6.3.ebuild
new file mode 100644
index 000000000000..f001697a809c
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.6.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.3.ebuild,v 1.1 2002/12/02 18:49:05 spider Exp $
+
+IUSE="ssl socks5 nls"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="LFTP is a sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc -sparc -sparc64 ~alpha"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/configure-lftp-2.6.2.diff \
+ || die "patch failed"
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+
+}